Re: [PATCH v5 0/5] linux-user: implement execveat

2023-01-25 Thread Drew DeVault
On Wed Jan 25, 2023 at 10:46 AM CET, Laurent Vivier wrote: > Applied to my linux-user-for-8.0 branch. Thanks!

Re: [PATCH v3] linux-user: implement execveat

2022-11-04 Thread Drew DeVault
On Fri Nov 4, 2022 at 10:53 AM CET, Philippe Mathieu-Daudé wrote: > Splitting this big patch would ease review: It's only +165/-131, are you sure it really needs to be split? > 1/ Replace safe_execve() by safe_execveat() > > -safe_execve(exec_path, argp, envp)) > +safe_execveat(AT_FDCWD,

[PATCH v4] linux-user: implement execveat

2022-11-04 Thread Drew DeVault
References: https://gitlab.com/qemu-project/qemu/-/issues/1007 Signed-off-by: Drew DeVault --- v3 => v4: implement strace for execveat linux-user/strace.c| 91 +++--- linux-user/strace.list | 2 +- linux-user/syscall.c | 203 +

[PATCH v3] linux-user: implement execveat

2022-11-03 Thread Drew DeVault
References: https://gitlab.com/qemu-project/qemu/-/issues/1007 Signed-off-by: Drew DeVault --- v2 => v3: - Rebase to address the is_proc_myself fix - Drop the ifdefs linux-user/syscall.c | 203 ++- 1 file changed, 105 insertions(+), 98 deletions(-) d

[PATCH v2] linux-user: implement execveat

2022-11-03 Thread Drew DeVault
References: https://gitlab.com/qemu-project/qemu/-/issues/1007 Signed-off-by: Drew DeVault --- linux-user/syscall.c | 204 +++ 1 file changed, 111 insertions(+), 93 deletions(-) diff --git a/linux-user/syscall.c b/linux-user/syscall.c index f55cdebee5

Re: [PATCH] linux-user: implement execveat

2022-11-03 Thread Drew DeVault
You're right, that's a much better approach. New patch coming up shortly.

[PATCH] linux-user: implement execveat

2022-10-31 Thread Drew DeVault
References: https://gitlab.com/qemu-project/qemu/-/issues/1007 Signed-off-by: Drew DeVault --- linux-user/syscall.c | 50 ++-- 1 file changed, 44 insertions(+), 6 deletions(-) diff --git a/linux-user/syscall.c b/linux-user/syscall.c index f55cdebee5

Re: [Qemu-devel] Combining -loadvm and -snapshot

2019-02-13 Thread Drew DeVault
On 2019-02-13 11:46 AM, Kevin Wolf wrote: > Reading from the backing file would be correct in your special case > (because the overlay was only just created and doesn't contain data > yet), but generally speaking, this would make the disk content > inconsistent because it would mix newer data from

[Qemu-devel] Combining -loadvm and -snapshot

2019-02-12 Thread Drew DeVault
ckends, but I'm a little unfamiliar with this code and the refactoring is not minor so I would like to get feedback from some of the wiser folks on this mailing list before I sink too much time into this. Thoughts? -- Drew DeVault

Re: [Qemu-devel] [PATCH 0/3] multiboot: Fix offset of bootloader name

2015-01-15 Thread Drew DeVault
On 01/15/2015 04:26 AM, Kevin Wolf wrote: This fixes a recent Multiboot load regression (see patch 2) that we noticed while hacking on the advent calendar image for December 24. These changes all look fine to me.

Re: [Qemu-devel] [PATCH] Add bootloader name to multiboot implementation

2014-11-13 Thread Drew DeVault
cc-ing a few people I found in the blame for the relevant files. Mind taking a look at this patch? Thanks! On 11/04/2014 12:49 PM, Drew DeVault wrote: Ping: http://patchwork.ozlabs.org/patch/404885/ Does anyone know someone I can cc on this? This part of the code doesn't have a dedi

Re: [Qemu-devel] [PATCH] Add bootloader name to multiboot implementation

2014-11-04 Thread Drew DeVault
Ping: http://patchwork.ozlabs.org/patch/404885/ Does anyone know someone I can cc on this? This part of the code doesn't have a dedicated maintainer. On 10/29/2014 11:52 PM, Drew DeVault wrote: The name is set to "qemu". Signed-off-by: Drew DeVault --- For the future, it m

[Qemu-devel] [PATCH] Add bootloader name to multiboot implementation

2014-10-29 Thread Drew DeVault
The name is set to "qemu". Signed-off-by: Drew DeVault --- For the future, it may be useful to add a command line flag for setting this to some user-specified value. I also considered naming it "qemu-system-i386" or "qemu-system-x86_64" (as appropriate), but co