Re: [Qemu-devel] [PATCH 3/5] hw/pxa2xx_lcd.c: drop VMSTATE_UINTTL usage

2012-02-22 Thread Mitsyanko Igor
her than for migration, but again the change is in code that is not related to savevm) Cheers It's an improvement in a way that it fixes a (style) bug in code, VMSTATE_UINTTL* macro are not intended for target_phys_addr_t. -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] [PATCH 3/5] hw/pxa2xx_lcd.c: drop VMSTATE_UINTTL usage

2012-02-22 Thread Mitsyanko Igor
On 02/22/2012 04:48 PM, andrzej zaborowski wrote: On 22 February 2012 13:26, Mitsyanko Igor wrote: On 02/22/2012 03:36 PM, andrzej zaborowski wrote: Why's uint32_t more correct though? The purpose of using a named type across qemu is to mark fields as memory addresses (similar to s

Re: [Qemu-devel] [PATCH 3/5] hw/pxa2xx_lcd.c: drop VMSTATE_UINTTL usage

2012-02-22 Thread Mitsyanko Igor
a pxa specific memory address type. Introducing new type doesn't look pretty to me, maybe just rename variables to source_addr, dest_addr e.t.c? -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] [PATCH 0/5] VMState cleanups

2012-02-22 Thread Mitsyanko Igor
in hw.h now. But without NEED_CPU_H. -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] KVM call agenda for tuesday 31

2012-02-22 Thread Mitsyanko Igor
er implementation to retrieve buffer size directly from capabilities register, but I can take another approach for this of course. -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] [PATCH v11 5/9] ARM: exynos4210: basic Power Management Unit implementation

2012-02-01 Thread Mitsyanko Igor
registers with big empty gaps between them. Starting from V10, PMU state includes only actually existing registers, and empty gaps between these registers behave as RAZ/WI. -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] KVM call agenda for tuesday 31

2012-01-31 Thread Mitsyanko Igor
TE_BUFFER_MULTIPLY is just a partial solution to a bigger set of possible problems. SD card's vmstate implementation requires shift operation, SDHC gets size from switch {} statement, something else later may require division or addition e.t.c., get_bufsize callback will cover all

[Qemu-devel] [PATCH v10 4/9] ARM: exynos4210: PWM support.

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin Signed-off-by: Evgeny Voevodin Reviewed-by: Peter Maydell --- Makefile.target |2 +- hw/exynos4210.c | 12 ++ hw/exynos4210_pwm.c | 413 +++ 3 files changed, 426 insertions(+), 1 deletions(-) create mode 1006

[Qemu-devel] [PATCH v10 7/9] hw/lan9118: Add basic 16-bit mode support.

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin Signed-off-by: Evgeny Voevodin --- hw/lan9118.c | 124 +++--- 1 files changed, 118 insertions(+), 6 deletions(-) diff --git a/hw/lan9118.c b/hw/lan9118.c index 9b199d0..bb790a3 100644 --- a/hw/lan9118.c +++ b/hw/lan9118

[Qemu-devel] [PATCH v10 0/9] ARM: Samsung Exynos4210-based boards support

2012-01-26 Thread Mitsyanko Igor
ARM: Samsung exynos4210-based boards emulation ARM: exynos4210: PWM support. ARM: exynos4210: MCT support. hw/lan9118: Add basic 16-bit mode support. hw/exynos4210.c: Add LAN support for SMDKC210. Maksim Kozlov (2): ARM: exynos4210: UART support ARM: exynos4210: basic Power Management Unit

[Qemu-devel] [PATCH v10 5/9] ARM: exynos4210: basic Power Management Unit implementation

2012-01-26 Thread Mitsyanko Igor
From: Maksim Kozlov Patch adds basic model for Exynos4210 SoC PMU. This model implements PMU registers just as a bulk of memory. Currently, the only reason this device exists is that secondary CPU boot loader uses PMU INFORM5 register as a holding pen. Signed-off-by: Maksim Kozlov --- Makefile

Re: [Qemu-devel] [PATCH v10 5/9] ARM: exynos4210: basic Power Management Unit implementation

2012-01-26 Thread Mitsyanko Igor
On 01/26/2012 03:42 PM, Mitsyanko Igor wrote: Re: [PATCH v10 5/9] ARM: exynos4210: basic Power Management Unit implementation Please ignore this patch, it's wrong, I'm sending correct version of this patch right away as a reply to original patch. Sorry about that. -- Mitsyanko

[Qemu-devel] [PATCH v10 1/9] ARM: exynos4210: IRQ subsystem support.

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin Signed-off-by: Evgeny Voevodin --- Makefile.target |1 + hw/exynos4210.h | 82 hw/exynos4210_combiner.c | 472 ++ hw/exynos4210_gic.c | 436 ++ 4 fil

[Qemu-devel] [PATCH v10 6/9] ARM: exynos4210: MCT support.

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin Signed-off-by: Evgeny Voevodin Reviewed-by: Peter Maydell --- Makefile.target |2 +- hw/exynos4210.c | 19 + hw/exynos4210_mct.c | 1479 +++ 3 files changed, 1499 insertions(+), 1 deletions(-) create mode 1006

[Qemu-devel] [PATCH v10 8/9] hw/exynos4210.c: Add LAN support for SMDKC210.

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin SMDKC210 uses lan9215 chip, but lan9118 in 16-bit mode seems to be enough. Signed-off-by: Evgeny Voevodin Reviewed-by: Peter Maydell --- hw/exynos4_boards.c | 27 +-- 1 files changed, 25 insertions(+), 2 deletions(-) diff --git a/hw/exynos4_boa

[Qemu-devel] [PATCH v10 5/9] ARM: exynos4210: basic Power Management Unit implementation

2012-01-26 Thread Mitsyanko Igor
From: Maksim Kozlov Patch adds basic model for Exynos4210 SoC PMU. This model implements PMU registers just as a bulk of memory. Currently, the only reason this device exists is that secondary CPU boot loader uses PMU INFORM5 register as a holding pen. Signed-off-by: Maksim Kozlov --- Makefile

[Qemu-devel] [PATCH v10 3/9] ARM: exynos4210: UART support

2012-01-26 Thread Mitsyanko Igor
From: Maksim Kozlov Add basic support of exynos4210 UART Signed-off-by: Maksim Kozlov --- Makefile.target |2 +- hw/exynos4210.c | 29 +++ hw/exynos4210.h |9 + hw/exynos4210_uart.c | 661 ++ 4 files changed, 700 inserti

[Qemu-devel] [PATCH v10 2/9] ARM: Samsung exynos4210-based boards emulation

2012-01-26 Thread Mitsyanko Igor
From: Evgeny Voevodin Add initial support of NURI and SMDKC210 boards Signed-off-by: Evgeny Voevodin --- Makefile.target |3 +- hw/exynos4210.c | 193 +++ hw/exynos4210.h | 40 +++ hw/exynos4_boards.c | 143 +++

[Qemu-devel] [PATCH v4 2/4] hw/sd.c: add SD card save/load support

2012-01-25 Thread Mitsyanko Igor
This patch updates SD card emulation to support save/load of card's state. Signed-off-by: Mitsyanko Igor --- hw/sd.c | 102 +-- 1 files changed, 73 insertions(+), 29 deletions(-) diff --git a/hw/sd.c b/hw/sd.c index 07eb263..bf

[Qemu-devel] [PATCH v4 3/4] hw/sd.c: convert SD state binary variables to bool

2012-01-25 Thread Mitsyanko Igor
SDstate members wp_switch, wp_groups, spi, expecting_acmd and enable are in fact binary variables s converting them to type "bool" makes code a little bit more clear. API modified to reflect new variables types. Signed-off-by: Mitsyanko Igor --- hw/s

[Qemu-devel] [PATCH v4 1/4] vmstate: introduce get_bufsize entry in VMStateField

2012-01-25 Thread Mitsyanko Igor
rom VMState Field structure to compensate for extra memory consuption because of get_bufsize addition. Macros VMSTATE_VBUFFER* are modified to use new callback instead of .size_offset. Macro VMSTATE_BUFFER_MULTIPLY and VMFlag VMS_MULTIPLY are removed completely as they are now redundant. Signed-off-by: Mi

[Qemu-devel] [PATCH v4 0/4] Improve SD controllers emulation

2012-01-25 Thread Mitsyanko Igor
. Fourth patch adds imlementation of new device: SD host controller fully compliant with "SD host controller specification version 2.00". It also uses vmstate field modification introduced in first patch. Mitsyanko Igor (4): vmstate: introduce get_bufsize entry in VMStateField hw/sd.c:

Re: [Qemu-devel] [PATCH v9 5/6] arm: SoC model for Calxeda Highbank

2012-01-12 Thread Mitsyanko Igor
); +} +} else { + hw_error("Unable to find %s\n", bios_name); +} +} I'm sorry, I forgot to ask in my previous message, how does control is passed to uboot image at 0xfff88000 address? Shouldn't highbank_binfo be modified somehow if bi

Re: [Qemu-devel] [PATCH v9 5/6] arm: SoC model for Calxeda Highbank

2012-01-12 Thread Mitsyanko Igor
On 01/12/2012 05:09 PM, Andreas Färber wrote: Am 12.01.2012 13:47, schrieb Mitsyanko Igor: On 01/11/2012 08:31 PM, Mark Langsdorf wrote: +sysram = g_new(MemoryRegion, 1); +memory_region_init_ram(sysram, "highbank.sysram", 0x8000); +memory_region_add_subregion(sysmem,

Re: [Qemu-devel] [PATCH v9 5/6] arm: SoC model for Calxeda Highbank

2012-01-12 Thread Mitsyanko Igor
ysbus_mmio_map(busdev, 0, 0xfff3c000); > + You can use sysbus_create_simple() here (of course, if you didn't avoid it intentionally for some reason). -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

Re: [Qemu-devel] [PATCH] hw/lan9118: Add save/load support

2012-01-12 Thread Mitsyanko Igor
buffer_size--; } looks wrong (I haven't dug dip into it though) and must be ... while (s->txp->buffer_size && (n--)) { ... -- Mitsyanko Igor ASWG, Moscow R&D center, Samsung Electronics email: i.mitsya...@samsung.com

[Qemu-devel] [PATCH V3 4/5] hw/sd.c: convert wp_switch and spi to bool

2011-12-28 Thread Mitsyanko Igor
Currently several binary variables in SDState represented as bool type while several other represented as int. This patch converts wp_switch and spi variables to bool and modifies rest of the code to treat this variables as bool instead of int. Signed-off-by: Mitsyanko Igor --- hw/sd.c |8

[Qemu-devel] [PATCH V3 3/5] hw/sd.c: convert wp_groups, expecting_acmd and enable to bool

2011-12-28 Thread Mitsyanko Igor
rue' where it's required. Signed-off-by: Mitsyanko Igor --- hw/sd.c | 18 +- hw/sd.h |2 +- 2 files changed, 10 insertions(+), 10 deletions(-) diff --git a/hw/sd.c b/hw/sd.c index 3e5628e..955f4fb 100644 --- a/hw/sd.c +++ b/hw/sd.c @@ -426,7 +426,7 @@ static

[Qemu-devel] [PATCH V3 2/5] hw/sd.c: add SD card save/load support

2011-12-28 Thread Mitsyanko Igor
We couldn't properly implement save/restore functionality of SD host controllers states without SD card's state VMStateDescription implementation. This patch updates SD card emulation to support save/load of card's state. Signed-off-by: Mitsyanko Igor ---

[Qemu-devel] [PATCH V3 0/5] Improve SD controllers emulation

2011-12-28 Thread Mitsyanko Igor
ted buffers. This modification is used later in second patch to implement SD card's VMStateDescription structure. Third patch adds imlementation of new device: SD host controller fully compliant with "SD host controller specification version 2.00". It also uses first patch modific

[Qemu-devel] [PATCH V3 1/5] vmstate: introduce get_bufsize entry in VMStateField

2011-12-28 Thread Mitsyanko Igor
rom VMState Field structure to compensate for extra memory consuption because of get_bufsize addition. Macros VMSTATE_VBUFFER* are modified to use new callback instead of .size_offset. Macro VMSTATE_BUFFER_MULTIPLY and VMFlag VMS_MULTIPLY are removed completely as they are now redundant. Signed-off-by: Mi

Re: [Qemu-devel] [PATCH V2 2/3] hw/sd.c: add SD card save/load support

2011-12-28 Thread Mitsyanko Igor
On 12/28/2011 05:26 PM, Peter Maydell wrote: On 28 December 2011 12:08, Mitsyanko Igor wrote: We couldn't properly implement save/restore functionality of SD host controllers states without SD card's state VMStateDescription implementation. This patch updates SD card emulation to su

[Qemu-devel] [PATCH V2 2/3] hw/sd.c: add SD card save/load support

2011-12-28 Thread Mitsyanko Igor
it was appropriate. Signed-off-by: Mitsyanko Igor --- hw/sd.c | 130 ++- hw/sd.h |4 +- 2 files changed, 89 insertions(+), 45 deletions(-) diff --git a/hw/sd.c b/hw/sd.c index 07eb263..4b5b538 100644 --- a/hw/sd.c +++ b/hw/sd

[Qemu-devel] [PATCH V2 1/3] vmstate: introduce get_bufsize entry in VMStateField

2011-12-28 Thread Mitsyanko Igor
rom VMState Field structure to compensate for extra memory consuption because of get_bufsize addition. Macros VMSTATE_VBUFFER* are modified to use new callback instead of .size_offset. Macro VMSTATE_BUFFER_MULTIPLY and VMFlag VMS_MULTIPLY are removed completely as they are now redundant. Signed-off-by: Mi

[Qemu-devel] [PATCH V2 0/3] Improve SD controllers emulation

2011-12-28 Thread Mitsyanko Igor
ion structure. Third patch adds imlementation of new device: SD host controller fully compliant with "SD host controller specification version 2.00". It also uses first patch modifications. Mitsyanko Igor (3): vmstate: introduce get_bufsize entry in VMStateField hw/sd.c: add SD card

Re: [Qemu-devel] [PATCH 1/3] vmstate: introduce calc_size VMStateField

2011-12-27 Thread Mitsyanko Igor
On 12/27/2011 05:10 PM, Andreas Färber wrote: Am 27.12.2011 09:11, schrieb Mitsyanko Igor: On 12/26/2011 07:20 PM, Peter Maydell wrote: On 26 December 2011 10:03, Mitsyanko Igor wrote: diff --git a/hw/hw.h b/hw/hw.h index efa04d1..8ce4475 100644 --- a/hw/hw.h +++ b/hw/hw.h @@ -303,9 +303,9

Re: [Qemu-devel] [PATCH 2/3] hw/sd.c: add SD card save/load support

2011-12-27 Thread Mitsyanko Igor
bool, too? Andreas As Peter mentioned previously, we should use either uint8_t or bool for all binary variables for consistency, and we probably shouldn't use bool for wp_groups array since sizeof(bool) uncertainty. So I'm considering just make everything uint8_t. -- Mitsyank

Re: [Qemu-devel] [PATCH 2/3] hw/sd.c: add SD card save/load support

2011-12-27 Thread Mitsyanko Igor
On 12/26/2011 06:58 PM, Peter Maydell wrote: On 26 December 2011 10:03, Mitsyanko Igor wrote: We couldn't properly implement save/restore functionality of SD host controllers states without SD card's state VMStateDescription implementation. This patch updates SD card emulation to su

Re: [Qemu-devel] [PATCH 1/3] vmstate: introduce calc_size VMStateField

2011-12-27 Thread Mitsyanko Igor
On 12/26/2011 07:20 PM, Peter Maydell wrote: On 26 December 2011 10:03, Mitsyanko Igor wrote: New calc_size field in VMStateField is supposed to help us easily add save/restore support of dynamically allocated buffers in device's states. There are some cases when information on si

[Qemu-devel] [PATCH V2 1/3] vmstate: introduce get_bufsize entry in VMStateField

2011-12-26 Thread Mitsyanko Igor
rom VMState Field structure to compensate for extra memory consuption because of get_bufsize addition. Macros VMSTATE_VBUFFER* are modified to use new callback instead of .size_offset. Macro VMSTATE_BUFFER_MULTIPLY and VMFlag VMS_MULTIPLY are removed completely as they are now redundant. Signed-off-by: Mi

[Qemu-devel] [PATCH 2/3] hw/sd.c: add SD card save/load support

2011-12-26 Thread Mitsyanko Igor
We couldn't properly implement save/restore functionality of SD host controllers states without SD card's state VMStateDescription implementation. This patch updates SD card emulation to support save/load of card's state. Signed-off-by: Mitsyanko Igor --- hw/milkymist-memcard

[Qemu-devel] [PATCH 1/3] vmstate: introduce calc_size VMStateField

2011-12-26 Thread Mitsyanko Igor
tion with size field seems redundant, and still it would't cover cases when we need to perform a set of operations to get size value. With this new .calc_size field we can calculate size of dynamic array in whichever way we need. Signed-off-by: Mitsyanko Igor --- hw/hw.h | 14 ++

[Qemu-devel] [PATCH 0/3] Improve SD controllers emulation

2011-12-26 Thread Mitsyanko Igor
ementation of new device: SD host controller fully compliant with "SD host controller specification version 2.00". It also uses first patch modifications. Mitsyanko Igor (3): vmstate: introduce calc_size VMStateField hw/sd.c: add SD card save/load support hw/: Introduce spec. ver. 2.

Re: [Qemu-devel] [PATCH v3 12/14] hw/sd.c, hw/sd.h: add receive ready query routine to SD/MMC API

2011-12-14 Thread Mitsyanko Igor
On 12/13/2011 08:22 PM, Peter Maydell wrote: On 13 December 2011 15:11, Peter Maydell wrote: On 12 December 2011 06:43, Evgeny Voevodin wrote: From: Mitsyanko Igor Data transfer direction between host controller and SD/MMC card is selected by host controller configuration registers, but

Re: [Qemu-devel] [PATCH v3 13/14] ARM: exynos4210: added SD/MMC host controller

2011-12-13 Thread Mitsyanko Igor
On 12/13/2011 06:56 PM, Peter Maydell wrote: On 12 December 2011 06:43, Evgeny Voevodin wrote: --- /dev/null +++ b/hw/exynos4210_sdhc.c @@ -0,0 +1,1666 @@ +/* + * Samsung exynos4210 SD/MMC host controller + * (SD host controller specification ver. 2.0 compliant) Is there anything in this impl