Fix few regressions introduced while introducing xhci-sysbus.

Cleaned a bit code style while here, patches included for 6.0.

Philippe Mathieu-Daudé (5):
  hw/usb/hcd-xhci: Make xhci base model abstract
  hw/usb/Kconfig: Fix USB_XHCI_NEC (depends on USB_XHCI_PCI)
  hw/usb/hcd-xhci: Rename "base-xhci" as TYPE_XHCI_COMMON
  hw/usb/hcd-xhci-pci: Use OBJECT_DECLARE_SIMPLE_TYPE() macro
  hw/usb/hcd-xhci-pci: Rename "pci-xhci" as TYPE_XHCI_PCI_COMMON

 hw/usb/hcd-xhci-pci.h    |  6 ++----
 hw/usb/hcd-xhci.h        |  4 +++-
 include/hw/usb/xhci.h    |  1 -
 hw/usb/hcd-xhci-nec.c    |  2 +-
 hw/usb/hcd-xhci-pci.c    | 18 +++++++++---------
 hw/usb/hcd-xhci-sysbus.c |  2 +-
 hw/usb/hcd-xhci.c        | 11 ++++++-----
 hw/usb/Kconfig           |  4 +---
 8 files changed, 23 insertions(+), 25 deletions(-)

-- 
2.26.2



Reply via email to