[PATCH v2 06/28] cputlb: Rename helper_ret_ld*_cmmu to cpu_ld*_code

2019-12-16 Thread Richard Henderson
There are no uses of the *_cmmu names other than the bare wrapping within the *_code inlines. Therefore rename the functions so we can drop the inlines. Use abi_ptr instead of target_ulong in preparation for user-only; the two types are identical for softmmu. Reviewed-by: Aleksandar Markovic Si

Re: [PATCH v2 06/28] cputlb: Rename helper_ret_ld*_cmmu to cpu_ld*_code

2019-12-20 Thread Alex Bennée
Richard Henderson writes: > There are no uses of the *_cmmu names other than the bare wrapping > within the *_code inlines. Therefore rename the functions so we > can drop the inlines. > > Use abi_ptr instead of target_ulong in preparation for user-only; > the two types are identical for softm

Re: [PATCH v2 06/28] cputlb: Rename helper_ret_ld*_cmmu to cpu_ld*_code

2019-12-28 Thread Richard Henderson
On 12/21/19 4:25 AM, Alex Bennée wrote: >> -#define CPU_MMU_INDEX (cpu_mmu_index(env, true)) >> -#define MEMSUFFIX _code >> -#define SOFTMMU_CODE_ACCESS >> +uint32_t cpu_ldub_code(CPUArchState *env, abi_ptr addr); >> +uint32_t cpu_lduw_code(CPUArchState *env, abi_ptr addr); >> +uint32_t cpu_ldl_cod