Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread Sergey Fedorov
On 17/03/16 23:46, Richard Henderson wrote: On 03/17/2016 01:45 PM, Sergey Fedorov wrote: Probably it's time to audit the code that handles direct jumping and clean-up/document/rename things to make it more easy to understand? :) Seconded! I'll go for it, then :) Kind regards, Sergey

Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread Paolo Bonzini
On 17/03/2016 18:57, Richard Henderson wrote: > > @@ -951,18 +959,10 @@ static inline void tb_jmp_remove(TranslationBlock > > *tb, int n) > > } > > /* now we can suppress tb(n) from the list */ > > *ptb = tb->jmp_next[n]; > > - > > -tb->jmp_next[n] = NULL; > >

[Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread sergey . fedorov
From: Paolo Bonzini Simple code simplification. Signed-off-by: Paolo Bonzini Signed-off-by: Sergey Fedorov --- translate-all.c | 19 +-- 1 file changed, 9 insertions(+), 10 deletions(-) diff --git

Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread Sergey Fedorov
On 17/03/16 23:45, Sergey Fedorov wrote: On 17/03/16 22:31, Paolo Bonzini wrote: On 17/03/2016 18:57, Richard Henderson wrote: @@ -951,18 +959,10 @@ static inline void tb_jmp_remove(TranslationBlock *tb, int n) } /* now we can suppress tb(n) from the list */

Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread Richard Henderson
On 03/17/2016 06:46 AM, sergey.fedo...@linaro.org wrote: > From: Paolo Bonzini > > Simple code simplification. > > Signed-off-by: Paolo Bonzini > Signed-off-by: Sergey Fedorov > --- > translate-all.c | 19

Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-19 Thread Richard Henderson
On 03/17/2016 01:45 PM, Sergey Fedorov wrote: > Probably it's time to audit the code that handles direct jumping and > clean-up/document/rename things to make it more easy to understand? :) Seconded! r~

Re: [Qemu-devel] [PATCH 3/5] tcg: always keep jump target and tb->jmp_next consistent

2016-03-18 Thread Sergey Fedorov
On 17/03/16 22:31, Paolo Bonzini wrote: On 17/03/2016 18:57, Richard Henderson wrote: @@ -951,18 +959,10 @@ static inline void tb_jmp_remove(TranslationBlock *tb, int n) } /* now we can suppress tb(n) from the list */ *ptb = tb->jmp_next[n]; - -