try to make breakpoint related functions more cleaner. originally, these functions implicit use 0,1,2,3 as name of breakpoint, really hard to understand, so name them readable, and also refactor the statement to check these types for clean reason.
v2 changes: 1. split 'breakpoint_enabled' into '{local,global}_enable' 2. add some braces for if statement target-i386/cpu.h | 22 ++-- target-i386/helper.c | 74 ++++++++++++++++++++-------------- target-i386/machine.c | 5 +- target-i386/misc_helper.c | 4 +- target-i386/seg_helper.c | 6 ++-- 5 files changed, 77 insertions(+), 34 deletions(-) -- regards! li guang