Re: [Qemu-devel] [RFC v2 PATCH 3/6] blockdev: rename block_stream_cb to a generic block_job_cb

2012-09-07 Thread Paolo Bonzini
Il 07/09/2012 19:04, Jeff Cody ha scritto: > On 09/07/2012 12:27 PM, Paolo Bonzini wrote: >> Il 30/08/2012 20:47, Jeff Cody ha scritto: >>> @@ -53,6 +53,8 @@ static const int if_max_devs[IF_COUNT] = { >>> [IF_SCSI] = 7, >>> }; >>> >>> +static void block_job_cb(void *opaque, int ret); >>> +

Re: [Qemu-devel] [RFC v2 PATCH 3/6] blockdev: rename block_stream_cb to a generic block_job_cb

2012-09-07 Thread Jeff Cody
On 09/07/2012 12:27 PM, Paolo Bonzini wrote: > Il 30/08/2012 20:47, Jeff Cody ha scritto: >> @@ -53,6 +53,8 @@ static const int if_max_devs[IF_COUNT] = { >> [IF_SCSI] = 7, >> }; >> >> +static void block_job_cb(void *opaque, int ret); >> + >> /* >> * We automatically delete the drive when

Re: [Qemu-devel] [RFC v2 PATCH 3/6] blockdev: rename block_stream_cb to a generic block_job_cb

2012-09-07 Thread Paolo Bonzini
Il 30/08/2012 20:47, Jeff Cody ha scritto: > @@ -53,6 +53,8 @@ static const int if_max_devs[IF_COUNT] = { > [IF_SCSI] = 7, > }; > > +static void block_job_cb(void *opaque, int ret); > + > /* > * We automatically delete the drive when a device using it gets > * unplugged. Questionable

[Qemu-devel] [RFC v2 PATCH 3/6] blockdev: rename block_stream_cb to a generic block_job_cb

2012-08-30 Thread Jeff Cody
Signed-off-by: Jeff Cody --- blockdev.c | 8 +--- trace-events | 2 +- 2 files changed, 6 insertions(+), 4 deletions(-) diff --git a/blockdev.c b/blockdev.c index 7c83baa..68d65fb 100644 --- a/blockdev.c +++ b/blockdev.c @@ -53,6 +53,8 @@ static const int if_max_devs[IF_COUNT] = { [I