On Mon, Feb 08, 2010 at 11:31:40AM +0100, Jes Sorensen wrote:
> On 01/28/10 05:39, Kevin O'Connor wrote:
> >As a side note, it should probably do the e820 map check even for qemu
> >users (ie, not just kvm).
>
> Hi Kevin,
>
> Here is an updated version of the patch which does the e820 read
> unco
On 01/28/10 05:39, Kevin O'Connor wrote:
As a side note, it should probably do the e820 map check even for qemu
users (ie, not just kvm).
Hi Kevin,
Here is an updated version of the patch which does the e820 read
unconditionally of the return from kvm_para_available() so it should
work for co
On Fri, Jan 29, 2010 at 10:03:55AM +0100, Jes Sorensen wrote:
> On 01/28/10 05:39, Kevin O'Connor wrote:
> >The advantage being that it should be possible to write one set of
> >helper functions in both qemu and seabios that can then be used to
> >pass arbitrary content.
>
> The only issue here is
On Fri, Jan 29, 2010 at 10:03:55AM +0100, Jes Sorensen wrote:
> On 01/28/10 05:39, Kevin O'Connor wrote:
> >I think defining accessor functions for every piece of data passed
> >through qemu-cfg interface is going to get tiring. I'd prefer to
> >extend the existing qemu-cfg "file" interface for ne
On 01/28/10 05:39, Kevin O'Connor wrote:
I think defining accessor functions for every piece of data passed
through qemu-cfg interface is going to get tiring. I'd prefer to
extend the existing qemu-cfg "file" interface for new content.
For example, add a helper with something like:
int qemu_cf
On Tue, Jan 26, 2010 at 10:52:12PM +0100, Jes Sorensen wrote:
> Read optional table of e820 entries from qemu_cfg
[...]
> --- seabios.orig/src/paravirt.c
> +++ seabios/src/paravirt.c
> @@ -132,6 +132,23 @@ u16 qemu_cfg_smbios_entries(void)
> return cnt;
> }
>
> +u32 qemu_cfg_e820_entries(vo