PATCH: Check relayclient in check_badrcptto

2005-07-02 Thread Gordon Rowell
--- plugins/check_badrcptto.orig2005-07-02 17:13:11.0 +1000 +++ plugins/check_badrcptto 2005-07-02 17:13:18.0 +1000 @@ -7,6 +7,9 @@ sub check_for_badrcptto { my ($self, $transaction, $recipient) = @_; + + return (DECLINED) if $self->qp->connection->relay_client();

PATCH: Check relayclient in rhsbl

2005-07-02 Thread Gordon Rowell
--- plugins/rhsbl.orig 2005-07-02 17:15:11.0 +1000 +++ plugins/rhsbl 2005-07-02 17:15:29.0 +1000 @@ -9,6 +9,8 @@ sub mail_handler { my ($self, $transaction, $sender) = @_; + return (DECLINED) if $self->qp->connection->relay_client(); + my $res = new Net::DNS::Resolv

PATCH: Check relayclient in dnsbl

2005-07-02 Thread Gordon Rowell
--- plugins/dnsbl.orig 2005-07-02 12:17:32.0 +1000 +++ plugins/dnsbl 2005-07-02 17:17:00.0 +1000 @@ -17,6 +17,8 @@ sub connect_handler { my ($self, $transaction) = @_; + return (DECLINED) if $self->qp->connection->relay_client(); + my $remote_ip = $self->qp->connect

Re: PATCH: Check relayclient in ...

2005-07-02 Thread John Peacock
Gordon Rowell wrote: --- plugins/check_badrcptto.orig2005-07-02 17:13:11.0 +1000 +++ plugins/check_badrcptto 2005-07-02 17:13:18.0 +1000 --- plugins/rhsbl.orig 2005-07-02 17:15:11.0 +1000 +++ plugins/rhsbl 2005-07-02 17:15:29.0 +1000 --- pl

Re: PATCH: Check relayclient in ...

2005-07-02 Thread Gordon Rowell
John Peacock wrote: [...] These three I'm not going to commit (without discussion), because I don't like the code duplication involved. Rather than patching every plugin to respect the check_relay() setting (and yes, I know, I have done this recently), and remember to add that code to any *ne

Re: PATCH: Check relayclient in dnsbl

2007-05-25 Thread Robin Bowes
Gordon Rowell wrote: > --- plugins/dnsbl.orig 2005-07-02 12:17:32.0 +1000 > +++ plugins/dnsbl 2005-07-02 17:17:00.0 +1000 > @@ -17,6 +17,8 @@ > sub connect_handler { >my ($self, $transaction) = @_; > > + return (DECLINED) if $self->qp->connection->relay_client(); > + >

Re: PATCH: Check relayclient in dnsbl

2007-05-25 Thread Robin Bowes
Robin Bowes wrote: > Gordon Rowell wrote: >> --- plugins/dnsbl.orig 2005-07-02 12:17:32.0 +1000 >> +++ plugins/dnsbl 2005-07-02 17:17:00.0 +1000 >> @@ -17,6 +17,8 @@ >> sub connect_handler { >>my ($self, $transaction) = @_; >> >> + return (DECLINED) if $self->qp->connec