On 6/17/2016 9:15 AM, Philippe Guibert wrote:
> On Thu, Jun 16, 2016 at 8:52 PM, Lou Berger <lber...@labn.net> wrote:
>
> Hello Lou,
>
>> Philippe,
>>
>> I've posted a fix to this (patch on patch) in
>>
>> https://github.com/LabNConsulting/quagga-vnc/commit/cd54370cb94d598aa95bd7561cc012200920d97a
>>
> I posted 2 minor comments:
>
> 1) The code has been compacted; however i fear this may lead to
> confusion ( especially because you perform if() just behind #endif
> macro).
> instead of:
>
> #if ENABLE_BGP_VNC
> if (v != RD_TYPE_VNC_ETH)
> #endif
> v |= (u_int16_t) *pnt;
>
> I would do:
>
> #if ENABLE_BGP_VNC
> if (v != RD_TYPE_VNC_ETH)
>    v |= (u_int16_t) *pnt;
> #else
> v |= (u_int16_t) *pnt;
> #endif
>
> IMHO, I think this brings more clarity about the algorithm in place.
I considered this, but I hate duplicate code so came down on the other
side.  But I was on the fence, so will make this change.


> 2) duplicate encode_rd stuff
>> this was covered in the v2 patch just sent to the list.
> point 2 is resolved by v2 patch then.
>
>> okay, will post a pointer to v3 once we resolve the 2 minor comments.
> waiting for v3 version with point 1) fix to ack.
Thanks!
Lou
>> Thanks,
>>
> Thanks,
>
> Philippe
>



_______________________________________________
Quagga-dev mailing list
Quagga-dev@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-dev

Reply via email to