Re: Review Request 37336: Added `execute()` method to process::Subprocess

2015-11-20 Thread Jie Yu
> On Nov. 20, 2015, 10:12 p.m., Jie Yu wrote: > > 3rdparty/libprocess/include/process/subprocess.hpp, line 328 > > > > > > I don't like the name 'execute'. When you create the Subprocess > > instance, the

Re: Review Request 37336: Added `execute()` method to process::Subprocess

2015-11-20 Thread Jie Yu
> On Nov. 20, 2015, 10:12 p.m., Jie Yu wrote: > > 3rdparty/libprocess/include/process/subprocess.hpp, lines 53-75 > > > > > > What's the motivation of storing this? Should the caller already have > > those

Re: Review Request 37336: Added `execute()` method to process::Subprocess

2015-11-20 Thread Jie Yu
> On Nov. 20, 2015, 10:12 p.m., Jie Yu wrote: > > 3rdparty/libprocess/include/process/subprocess.hpp, lines 336-343 > > > > > > Why introduce this method? I think the caller should be responsible for > > killing

Re: Review Request 40371: Changed mesos-execute to add containerizer option.

2015-11-20 Thread Timothy Chen
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40371/#review107444 --- src/cli/execute.cpp (line 237)

Re: Review Request 40560: Removed redundant fields from Update message in Executor API Protobuf

2015-11-20 Thread Vinod Kone
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40560/#review107448 --- Ship it! Ship It! - Vinod Kone On Nov. 20, 2015, 10:47 p.m.,

Review Request 40570: Modified stateUpdate(...) function to get the TaskStatus object by constant reference instead of copy

2015-11-20 Thread Anand Mazumdar
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40570/ --- Review request for mesos and Vinod Kone. Bugs: MESOS-3476

Re: Review Request 40563: Added functionality for handling status updates from HTTP based executors

2015-11-20 Thread Anand Mazumdar
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40563/ --- (Updated Nov. 21, 2015, 12:21 a.m.) Review request for mesos, Ben Mahler,

Re: Review Request 40570: Modified stateUpdate(...) function to get the TaskStatus object by constant reference instead of copy

2015-11-20 Thread Vinod Kone
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40570/#review107454 --- Ship it! Ship It! - Vinod Kone On Nov. 21, 2015, 12:21 a.m.,

Re: Review Request 40563: Added functionality for handling status updates from HTTP based executors

2015-11-20 Thread Vinod Kone
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40563/#review107452 --- src/slave/http.cpp (lines 318 - 322)

Re: Review Request 37336: Added `execute()` method to process::Subprocess

2015-11-20 Thread Marco Massenzio
> On Nov. 20, 2015, 10:12 p.m., Jie Yu wrote: > > 3rdparty/libprocess/include/process/subprocess.hpp, lines 53-75 > > > > > > What's the motivation of storing this? Should the caller already have > > those

Re: Review Request 39597: Add Newbie guide.

2015-11-20 Thread Timothy Chen
> On Nov. 6, 2015, 5:18 p.m., Vaibhav Khanduja wrote: > > docs/NewbieQuickStart.md, line 108 > > > > > > I am a "newbie" so was referring to your wip guide. I tried to run this > > command, but looks like it did

Re: Review Request 39597: Add Newbie guide.

2015-11-20 Thread Timothy Chen
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/39597/#review107462 --- Diana are you still able to finish the comments? - Timothy Chen

Re: Review Request 40367: Added backtick usage in comments to the C++ style guide.

2015-11-20 Thread Timothy Chen
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40367/#review107459 --- Ship it! Ship It! - Timothy Chen On Nov. 16, 2015, 9:31 p.m.,

Re: Review Request 40114: Windows: Began adding Windows support to `process/future.hpp`

2015-11-20 Thread Daniel Pravat
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40114/ --- (Updated Nov. 21, 2015, 1:18 a.m.) Review request for mesos and Alex Clemmer.

Re: Review Request 40114: Windows: Began adding Windows support to `process/future.hpp`

2015-11-20 Thread Daniel Pravat
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40114/ --- (Updated Nov. 21, 2015, 1:47 a.m.) Review request for mesos and Alex Clemmer.

Re: Review Request 40563: Added functionality for handling status updates from HTTP based executors

2015-11-20 Thread Anand Mazumdar
> On Nov. 21, 2015, 12:58 a.m., Vinod Kone wrote: > > src/slave/http.cpp, lines 318-322 > > > > > > indent by 4 spaces. > > > > also, it's hard to tell that None() is the argument for statusUpdate() > >

Re: Review Request 40563: Added functionality for handling status updates from HTTP based executors

2015-11-20 Thread Anand Mazumdar
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40563/ --- (Updated Nov. 21, 2015, 1:45 a.m.) Review request for mesos, Ben Mahler,

Re: Review Request 40396: Quota: Added a test for offer rescinding.

2015-11-20 Thread Alexander Rukletsov
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40396/ --- (Updated Nov. 20, 2015, 8:21 a.m.) Review request for mesos, Bernd Mathiske,

Re: Review Request 38956: Quota: Added allocator-agnostic tests.

2015-11-20 Thread Alexander Rukletsov
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/38956/ --- (Updated Nov. 20, 2015, 8:20 a.m.) Review request for mesos, Bernd Mathiske,

Re: Review Request 38956: Quota: Added allocator-agnostic tests.

2015-11-20 Thread Alexander Rukletsov
> On Nov. 20, 2015, 5:58 a.m., Joerg Schad wrote: > > src/tests/master_quota_tests.cpp, line 222 > > > > > > Shouldn't the expect call happen before StartSlave()? Otherwise the > > slave might have started before

Re: Review Request 40507: Cleanup leaked containerizer and potentially orphaned process in SlaveTest.LaunchTaskInfoWithContainerInfo.

2015-11-20 Thread Mesos ReviewBot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40507/#review107330 --- Patch looks great! Reviews applied: [40507] Passed command:

Re: Review Request 40375: [WIP] Support distinguishing revocable resources in the Resource protobuf.

2015-11-20 Thread Klaus Ma
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40375/ --- (Updated Nov. 21, 2015, 11:47 a.m.) Review request for mesos, Guangya Liu,

Re: Review Request 40247: Added HTTP endpoints for creating and destroying persistent volumes.

2015-11-20 Thread Mesos ReviewBot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40247/#review107477 --- Patch looks great! Reviews applied: [40242, 40243, 40244, 40245,

Re: Review Request 39456: Documentation: added containerizer internals

2015-11-20 Thread Timothy Chen
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/39456/#review107467 --- Are you still working on this? This doesn't look complete to me?

Re: Review Request 39939: Make docker_socket option support different protocols.

2015-11-20 Thread Timothy Chen
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/39939/#review107466 --- Ship it! Ship It! - Timothy Chen On Nov. 4, 2015, 5:13 p.m.,

Re: Review Request 39597: Add Newbie guide.

2015-11-20 Thread Vaibhav Khanduja
> On Nov. 6, 2015, 5:18 p.m., Vaibhav Khanduja wrote: > > docs/NewbieQuickStart.md, line 108 > > > > > > I am a "newbie" so was referring to your wip guide. I tried to run this > > command, but looks like it did

Re: Review Request 40559: Added a wait() function to Subprocess.

2015-11-20 Thread Mesos ReviewBot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40559/#review107475 --- Patch looks great! Reviews applied: [40250, 40251, 40252, 40274,

Re: Review Request 40570: Modified stateUpdate(...) function to get the TaskStatus object by constant reference instead of copy

2015-11-20 Thread Guangya Liu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/40570/#review107473 --- Ship it! Ship It! - Guangya Liu On εδΈ€ζœˆ 21, 2015, 12:21 a.m.,

<    1   2