Re: [rspec-users] requests: is it possible to put the fill_in's into a method?

2012-02-26 Thread S Ahmed
ahh, nice makes sense thanks! On Sun, Feb 26, 2012 at 12:25 PM, Andrew Premdas wrote: > On 26 February 2012 16:36, S Ahmed wrote: > >> I'm testing my signup page, and I want to minimize the duplication of >> the fill_in code for filling in the form fields and testing how my page >> reacts when

Re: [rspec-users] Testing Signin for Admin_Employee

2012-02-26 Thread Zach Dennis
On Sat, Feb 25, 2012 at 9:25 AM, J. B. Rainsberger wrote: > On Thu, Feb 23, 2012 at 22:45, Justin Ko wrote: > >> Hello, what you want is "shared examples/context": >> https://gist.github.com/1894922 > > I commented there, too. I commented there as well. -- @zachdennis http://www.continuousthink

Re: [rspec-users] requests: is it possible to put the fill_in's into a method?

2012-02-26 Thread Michael Guterl
On Sun, Feb 26, 2012 at 11:36 AM, S Ahmed wrote: > I'm testing my signup page, and I want to minimize the duplication of the > fill_in code for filling in the form fields and testing how my page reacts > when someone forgets to enter input. > > fill_in "", with: "abc123" > > Any tricks of doin

Re: [rspec-users] requests: is it possible to put the fill_in's into a method?

2012-02-26 Thread Andrew Premdas
On 26 February 2012 16:36, S Ahmed wrote: > I'm testing my signup page, and I want to minimize the duplication of the > fill_in code for filling in the form fields and testing how my page reacts > when someone forgets to enter input. > > fill_in "", with: "abc123" > > Any tricks of doing this

[rspec-users] requests: is it possible to put the fill_in's into a method?

2012-02-26 Thread S Ahmed
I'm testing my signup page, and I want to minimize the duplication of the fill_in code for filling in the form fields and testing how my page reacts when someone forgets to enter input. fill_in "", with: "abc123" Any tricks of doing this? Say I have 10 fill_in calls, so say I want to test to