Re: Re: [Rails-core] Pull requests on Github

2013-07-18 Thread Andrés Mejía
> > Funding for some core team members to be able to dedicate more time to > Rails development? That can only help. On Thu, Jul 18, 2013 at 8:48 AM, Rafael Mendonça França < rafaelmfra...@gmail.com> wrote: > I don't think we need to do something. If you look at projects with same > size of Rai

Re: [Rails-core] [HELP] - Ruby Drag and Drop script on screen element in Mac OS

2013-06-20 Thread Andrés Mejía
Hi Muthu, Actually it isn't that hard. To drag and drop you need 2 things: 1. *Drag:* Click the element, and while holding the mouse button pressed, move the mouse around. You don't need to press the button too hard as this might either break the mouse or make it too difficult to move the mouse w

Re: [Rails-core] link_to should have its body and url arguments reversed

2013-03-15 Thread Andrés Mejía
You can always use link_to @person { "Click me" } if you find that infinitely more readable than link_to "Click me", @person without the need to introduce a backwards incompatible change that would break every Rails app ever written. On Fri, Mar 15, 2013 at 3:39 PM, Michael Grohn wrote: > @M

Re: [Rails-core] Correct Use or Naming of Migrations

2013-02-18 Thread Andrés Mejía
Keep the discussion on topic, will you? If you want to bash about how Rails sucks for not using foreign keys then open a new thread for that. On Mon, Feb 18, 2013 at 10:32 AM, Rodrigo Rosenfeld Rosas < rr.ro...@gmail.com> wrote: > Em 18-02-2013 09:27, Godfrey Chan escreveu: > > ... > 2. You are

Re: [Rails-core] #asset_url helper method

2012-10-29 Thread Andrés Mejía
If I remember correctly, asset_path will return the full URL if you set config.action_mailer.asset_host = "http://my.assets.com"; in your environment file. On Mon, Oct 29, 2012 at 2:24 PM, Scott Carleton wrote: > I haven't had time to test but you're saying the asset_path helper will > provide

Re: [Rails-core] Being strict on differentiating between IEC prefixes and SI prefixes.

2012-10-02 Thread Andrés Mejía
UTC-7, Allen Madsen wrote: > > This pull request poses two problems in my mind. The changes are not > backwards compatible, which could lead to some serious head scratching. > Secondly, even though they're a standard now, they're not commonly used, > which leads to more head scr

Re: [Rails-core] Being strict on differentiating between IEC prefixes and SI prefixes.

2012-10-02 Thread Andrés Mejía
I'm -1 for this. On Tue, Oct 2, 2012 at 4:53 AM, Jarl Friis wrote: > One of the greatest things about rails is that it is so > standards-compliant, > no other framework that I have seen have complied to the > HTTP standard (think REST) in such a degree that Rails does. Kudos to > you all for tha

Re: [Rails-core] Test Locations in Rails 4

2012-09-29 Thread Andrés Mejía
+1. I never saw the point of the existing naming scheme. On Sat, Sep 29, 2012 at 6:39 PM, Luís Ferreira wrote: > Yes, seems obvious. Just pointing that out. But the changes seem really > nice and makes the placing of test files more obvious and semantic. > On Sep 30, 2012, at 12:36 AM, Mike Moor

Re: [Rails-core] Behavior of first_or_create

2012-07-24 Thread Andrés Mejía
I would definitely expect User.where(:first_name => 'Scarlett').first_or_create(:last_name => "O'Hara") to call User.create(:first_name => 'Scarlett', :last_name => "O'Hara") if that's not what's happening then I think it's a bug and should be fixed. Matt, do you have a minimal app that shows t

Re: [Rails-core] Could we add a new list for engines developers?

2012-07-22 Thread Andrés Mejía
+1 for the forum idea. On Sun, Jul 22, 2012 at 6:32 PM, Ryan Bigg wrote: > All this talk of categorization sounds almost like there should be some > kind of Rails forum for discussing things in, rather than isolated mailing > lists. > > There's an engine for that. https://github.com/radar/forem

Re: [Rails-core] perform_deliveries to be set per email / interceptors should he able to stop delivery

2012-07-19 Thread Andrés Mejía
-1. I don't see the point of this option. If you don't want to send an email, then don't call the mailer method and that's it. Also: 3. The email content may be spammy and you want to prevent that delivery Well, don't spam your users in the first place! On Thu, Jul 19, 2012 at 7:37 AM, Aditya

Re: [Rails-core] Re: Defining #blank for Array.

2012-07-10 Thread Andrés Mejía
I use it. It makes total sense to me. If you have a piece of paper with a list of 10 blank lines, how do you know there are exactly 10 blank lines instead of 3 or 7 or 13? On Tue, Jul 10, 2012 at 1:55 PM, Michael Boutros wrote: > Do you think anyone currently uses #blank? on enumerables in its c

Re: [Rails-core] Virtual attribute

2012-07-06 Thread Andrés Mejía
I like the idea because I've also suffered with this problem before. What about passing the class as the second argument like in serialize? class Monkey < ActiveRecord::Base attr_virtual :birth_date, Date end On Thu, Jul 5, 2012 at 2:38 PM, Aleksey Magusev wrote: > Periodically i need to u

Re: [Rails-core] ActiveRecord update_attribute vs update_attributes

2012-06-13 Thread Andrés Mejía
+1 for making update_attribute run validations. On Wed, Jun 13, 2012 at 10:37 AM, MikeGehard wrote: > Greetings all, > > I would like to start a conversation about the subtle difference between > update_attribute and update_attributes, namely that update_attribute skips > validations and update_

Re: [Rails-core] Why locales are not in assets?

2012-04-05 Thread Andrés Mejía
You can put them anywhere you want. If you want to put them in assets, just add config.i18n.load_path += Dir[Rails.root.join('assets', 'locales', '*.{rb,yml}').to_s] to your config/application.rb file. On Thu, Apr 5, 2012 at 11:35 AM, Rafael Mendonça França < rafaelmfra...@gmail.com> wrote: >

Re: [Rails-core] Generating new project creates a few files with bad syntax Rails 3.2.1

2012-03-02 Thread Andrés Mejía
I don't mean to offend, but you are one of the most annoying people to ever write to this list. On Fri, Mar 2, 2012 at 6:05 PM, Mark Peterson wrote: > > > On Friday, March 2, 2012 5:37:17 PM UTC-5, Mark Peterson wrote: >> >> On Friday, March 2, 2012 5:25:30 PM UTC-5, Prem Sichanugrist wrote: >>>

Re: [Rails-core] New to Ruby on Rails - Assigning variation (like size or color) to products

2012-02-22 Thread Andrés Mejía
This list is used to discuss Rails' internal details. For this kind of questions, use Rails Talk: http://groups.google.com/group/rubyonrails-talk/ On Wed, Feb 22, 2012 at 6:13 PM, Kisha M Richardson < kisha.richard...@gmail.com> wrote: > Hey Everyone, > > I'm completely new to ruby. I'm building

Re: [Rails-core] Automatic parameter bindings in controllers by argument names (like in Merb)

2011-09-07 Thread Andrés Mejía
I don't know if this was discussed already, but it's definitely a great idea! On Wed, Sep 7, 2011 at 8:54 PM, Rodrigo Rosenfeld Rosas wrote: > Is there any reason why Rails decided not to support argument binding in > controller actions like Merb? > > https://github.com/wycats/**merb/tree/master/

Re: [Rails-core] Javascript is now a first-class code citizen - Really?!

2011-08-31 Thread Andrés Mejía
I like Jasmine too. On Wed, Aug 31, 2011 at 1:45 PM, Wael Nasreddine wrote: > On Aug 31, 2011, at 20:14, Nicolás Sanguinetti > wrote: > > > On Wed, Aug 31, 2011 at 3:10 PM, Wael Nasreddine > > wrote: > >> +1 too, jasmine for unit testing and capybara for integration tests > > > > Well… make