Re: [Rails-core] Re: Scaffold Generator Woes

2012-03-09 Thread Trek Glowacki
So, just to recap the flow of this conversation for myself: a) We, as developers *of* Rails (or at least those who lurk here), realize that we're not the primary target of scaffolding. So, while it could be moved to gem for pros, it would be hard on new developers if it wasn't baked in and hi

Re: [Rails-core] Scaffold Generator Woes

2012-03-08 Thread Trek Glowacki
I spent 4 years using Rails as a teaching language both inside and outside a local University. We stopped telling students that scaffolding even existed after two semesters. It wash't that, as you might except, we had a problem with generating code instead of doing work by hand. Instead we saw t

Re: [Rails-core] Generating new project creates a few files with bad syntax Rails 3.2.1

2012-03-02 Thread Trek Glowacki
> > Isn't "name 'bob'" the syntax for passing "bob" as an argument into the > "name" method? Or has that all changed too? > > If I saw "name 'bob'", I would think that there's a method named "name" > defined somewhere. > > def name(str) > # do something with str > end > > Sounds like a great

Re: [Rails-core] Javascript is now a first-class code citizen - Really?!

2011-09-01 Thread Trek Glowacki
I think the appropriate question to ask is "of Rails developers unit testing their javascript, who is *not* using Jasmine" I definitely get the impression that * most people are not unit testing their javascript application code, instead relying on integration tests to catch errors * among thos

Re: [Rails-core] additional checkbox values

2010-02-27 Thread Trek Glowacki
As I mentioned, I only recall seeing it from quite some time back. Have been unable to relocate it. 2010/2/26 Prem Sichanugrist : > Could you please point out to the ticket that was rejected? > > On 27 ก.พ. 2553, at 2:43, Trek wrote: > >> Every once in a while I get bit when hand crafting a checkb

Re: [Rails-core] Rails 3 : basic routes

2010-02-16 Thread Trek Glowacki
I've been using Rails to teach web application development at the University level since 2005. The very first thing we do in the section about routing is entirely zero out the routes.rb file to be an empty routing block. This comes from several semesters of working with default routes available an

[Rails-core] Re: #3187 : Handle "blank slate" more easily with render method thanks to :default_template option

2009-09-11 Thread Trek Glowacki
:if_nil doesn't describe all cases. The collection could be not nil (e.g. an empty array) and you'd still want the blank slate to show. I'd suggest something related to blankness since it's the "blank slate" and both [ ].blank? and nil.blank? return true. render :partial => "post", :collection =

[Rails-core] Re: #3088 - [PATCH] Make has_one with :conditions hash scope build or creation of object with those conditions

2009-08-28 Thread Trek Glowacki
On Thu, Aug 27, 2009 at 2:50 PM, Luciano G. Panaro wrote: > > On Aug 27, 2:18 pm, Trek Glowacki wrote: >> I like the concept and think it should be expanded to other >> associations. We already define certain attributes of associated >> objects for selecting, the symmetr

[Rails-core] Re: #3088 - [PATCH] Make has_one with :conditions hash scope build or creation of object with those conditions

2009-08-27 Thread Trek Glowacki
I like the concept and think it should be expanded to other associations. We already define certain attributes of associated objects for selecting, the symmetry of having build/create defaults is handy. I could use it on a current project right now: has_many :trial_memberships, :conditions => {:s

[Rails-core] Re: updating join table (HMT) with checkbox and extra fields

2009-05-11 Thread Trek Glowacki
Hi, rubyonrails-core is for discussing the development _of_ Rails. Repost this on rubyonrails-t...@googlegroups.com for help with development _using_ Rails. Additionally, you may want to see http://wonderfullyflawed.com/2009/02/17/rails-forms-microformat/ for a detailed explanation of what HTML

[Rails-core] Re: The Base class in Rails

2008-10-09 Thread Trek Glowacki
I always assumed that AR::Base and AC::Base's name came from the concept of an abstract base class. I think ::Base is a fine name for the top-most superclass in a module, but that might just be a side effect of previous experience. -Trek On Thu, Oct 9, 2008 at 12:42 PM, Manfred Stienstra <[EMAIL

[Rails-core] Re: +3 patch needs a better name for an options key passed to map.resources

2008-01-27 Thread Trek Glowacki
I'd just suggest letting :other_name (or whatever the correct term shakes out to be) take an array map.resources :people, :other_names => ['folks', 'gentes','personoj'] do |person| person.resources :comments end This pattern can support multiple aliasing in segment paths for people who ne