Re: [sage-devel] is_constant in the SymbolicRing

2016-01-08 Thread William Stein
Is the function used anywhere else in sage? On Friday, January 8, 2016, Nathann Cohen wrote: > > A confusing name not in the global namespace isn't much better. How > about a > > rename that is clearer? Ideas > > Unless you mean the function to be called by the users, in which case > the name

Re: [sage-devel] is_constant in the SymbolicRing

2016-01-08 Thread Nathann Cohen
> A confusing name not in the global namespace isn't much better. How about a > rename that is clearer? Ideas Unless you mean the function to be called by the users, in which case the name and behaviour must be pretty clear to anyone, it is probably better to make it private. >is_named_con

[sage-devel] Notebooks from admin viewpoint

2016-01-08 Thread Jori Mäntysalo
I am basically just a sysadmin. For normal users and normal processes I can for example userdel -r to totally remove a user and files of him/her. Or use top or ps to see who is eating memory or burning cpu. Or even put on some ulimits to users. Sometimes chown some files etc. What of these f

Re: [IPython-dev] [sage-devel] Re: Jupyter notebook by default?

2016-01-08 Thread kcrisman
These all sound like awesome ideas to me for moving more *robustly* to a sws -> ipynb transition! Would attached files work properly (or at all)? I'm only asking out of ignorance. -- You received this message because you are subscribed to the Google Groups "sage-devel" group. To unsubscribe

Re: [sage-devel] is_constant in the SymbolicRing

2016-01-08 Thread William Stein
On Friday, January 8, 2016, Vincent Delecroix <20100.delecr...@gmail.com> wrote: > That would still expose the method in the namespace. Having "2" or > "log(2)" not being symbolic constant is confusing! I would definitely > prefer an "_is_symbolic_constant". A confusing name not in the global na

[sage-devel] Re: asymptotic expansions in SageMath

2016-01-08 Thread Karan Desai
Hello Daniel, I skimmed through the ticket and the docs quickly and it seems familiar to me conceptually. As a new developer, I think working on this ticket will give me a good tour through a small part of the source code. I will read it all carefully, and will ask anything I do't understand. I wi

Re: [sage-devel] Re: is_constant in the SymbolicRing

2016-01-08 Thread Vincent Delecroix
That would still expose the method in the namespace. Having "2" or "log(2)" not being symbolic constant is confusing! I would definitely prefer an "_is_symbolic_constant". On 08/01/16 16:20, Volker Braun wrote: Maybe it should be renamed to .is_symbolic_contstant(), freeing up .is_constant() f

[sage-devel] Re: is_constant in the SymbolicRing

2016-01-08 Thread Volker Braun
Maybe it should be renamed to .is_symbolic_contstant(), freeing up .is_constant() for you. On Friday, January 8, 2016 at 6:16:38 PM UTC+1, Daniel Krenn wrote: > > Dear all, > > from the method-name and also from the one-line description > "Return True if this symbolic expression is a const

Re: [sage-devel] is_constant in the SymbolicRing

2016-01-08 Thread Bill Page
On 8 January 2016 at 12:16, Daniel Krenn wrote: > PPS: At the moment (not having answers to this posting), my favourite > implementation would be something like >def is_constant(self): >return not self.variables() > To give an obvious counter-example: SR(random()).is_constant() b

[sage-devel] is_constant in the SymbolicRing

2016-01-08 Thread Daniel Krenn
Dear all, from the method-name and also from the one-line description "Return True if this symbolic expression is a constant." of Expression.is_constant, I expected that this gives more or less the same result as checking whether symbolic expression has an empty .variables(). However, we have

[sage-devel] asymptotic expansions in SageMath

2016-01-08 Thread Daniel Krenn
Dear all, since 6.10, computation with asymptotic expansions is possible in SageMath. The project was included into last year's Google Summer of Code and we are happy that meanwhile all code has been merged into SageMath. Since the end of this GSOC2015-project, a lot has been improved. Details

[sage-devel] Sage Days 75: Algorithmic Coding Theory, Greater Paris Area, August 22-26, 2016

2016-01-08 Thread david . lucas
Dear Sage-devel,Sage Days 75, will take place at Inria Saclay, (Greater Paris Area, Polytechnique campus), France on August 22-26, 2016. The dedicated wiki page can be found here . We'll have introductions to Sage and tutorials in the morning, and coding sprint

Re: [sage-devel] Updating Sagemath's README on Github [help] [newbie]

2016-01-08 Thread Karan Desai
Hi fellow developers, I have finally updated README.txt and converted it to README.md The original README.txt looks like these: https://www.github.com/sagemath/sage The beautified version, README.md looks like these: https://github.com/karandesai-96/sage/tree/t/19846/beautify_readme Nils, I hav

Re: [sage-devel] Sage & pip

2016-01-08 Thread Samuel Lelievre
2016-01-05 13:25:40 +, John Cremona: So I reinstalled openssl-dev using the package manager, then did what > you suggest above (without the ssl), and am now rebuilding all the > things which depend on python2. > > I would prefer it if the build process would not proceed without > openssl

Re: [sage-devel] The coefficients() method of a MultivariatePowerSeriesRing is unreasonably slow

2016-01-08 Thread Bruno Grenet
Le vendredi 8 janvier 2016 10:13:46 UTC+1, Johan S. R. Nielsen a écrit : > > The call to f.coefficients() run the following lines (self = f): > > tmp = {} > for j in self._bg_value.coefficients(): > for m in j.monomials(): > > tmp[self.parent(m)]=j.monomial_coefficient(self.parent(

[sage-devel] The coefficients() method of a MultivariatePowerSeriesRing is unreasonably slow

2016-01-08 Thread Johan S . R . Nielsen
The call to f.coefficients() run the following lines (self = f): tmp = {} for j in self._bg_value.coefficients(): for m in j.monomials(): tmp[self.parent(m)]=j.monomial_coefficient(self.parent()._poly_ring(m)) I may be missing something, but it seems that instead of the inner loop, on

[sage-devel] Re: The coefficients() method of a MultivariatePowerSeriesRing is unreasonably slow

2016-01-08 Thread Ralf Stephan
On Friday, January 8, 2016 at 1:51:27 AM UTC+1, Daniel Lowengrub wrote: > > 1) If we are just reading the coefficients of the power series, why should > it matter if we first cast it to a polynomial? > We are not. There are substitutions happening, leading to expensive computation of powers.