Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Gerd Hoffmann
Hi, > the same or just use it on the first one we encounter. We're probably > putting way too much thought into this scenario that Intel likely has no > expectation of supporting though ;) Thanks, Yea, lets stick with the plain simple "igd-opregion". Even if intel allows multiple igd devices

Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Alex Williamson
On Wed, 2016-02-03 at 17:09 -0500, Kevin O'Connor wrote: > On Wed, Feb 03, 2016 at 02:38:47PM -0700, Alex Williamson wrote: > > On Wed, 2016-02-03 at 12:43 -0700, Alex Williamson wrote: > > > On Wed, 2016-02-03 at 10:04 +0100, Gerd Hoffmann wrote: > > > >   Hi, > > > >   > > > > > +static void inte

Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Kevin O'Connor
On Wed, Feb 03, 2016 at 02:38:47PM -0700, Alex Williamson wrote: > On Wed, 2016-02-03 at 12:43 -0700, Alex Williamson wrote: > > On Wed, 2016-02-03 at 10:04 +0100, Gerd Hoffmann wrote: > > >   Hi, > > >   > > > > +static void intel_igd_opregion_setup(struct pci_device *dev, void *arg) > > > > +{ >

Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Alex Williamson
On Wed, 2016-02-03 at 12:43 -0700, Alex Williamson wrote: > On Wed, 2016-02-03 at 10:04 +0100, Gerd Hoffmann wrote: > >   Hi, > >   > > > +static void intel_igd_opregion_setup(struct pci_device *dev, void *arg) > > > +{ > > > +struct romfile_s *file = romfile_find("etc/igd-opregion"); > >   > >

Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Alex Williamson
On Wed, 2016-02-03 at 10:04 +0100, Gerd Hoffmann wrote: >   Hi, >  > > +static void intel_igd_opregion_setup(struct pci_device *dev, void *arg) > > +{ > > +struct romfile_s *file = romfile_find("etc/igd-opregion"); >  > Is it possible to have multiple igd devices in a single machine? > So, shou

[SeaBIOS] [PATCH] block: Move drive setup to new function block_setup()

2016-02-03 Thread Kevin O'Connor
Move the list of drive setup calls from post.c to a new function in block.c. Signed-off-by: Kevin O'Connor --- src/block.c | 16 src/block.h | 1 + src/post.c | 22 ++ 3 files changed, 19 insertions(+), 20 deletions(-) diff --git a/src/block.c b/src/block.

[SeaBIOS] [PATCH 0/4] Some additional PCI cleanups

2016-02-03 Thread Kevin O'Connor
Some additional PCI code cleanup - most notable is the first patch which adds a '%pP' modifier to the 'printf' code for outputting 'struct pci_device' pointers. This series is on top of the previous series; it is also at: https://github.com/KevinOConnor/seabios/tree/testing -Kevin Kevin O'Co

[SeaBIOS] [PATCH 1/4] pci: Implement '%pP' printf handler for 'struct pci_device' pointers

2016-02-03 Thread Kevin O'Connor
Handle '%pP' format descriptions as a pointer to a 'struct pci_device' and display it in bus:device.function (%02x:%02x.%x) format. Signed-off-by: Kevin O'Connor --- src/fw/pciinit.c | 25 + src/hw/ahci.c| 5 ++--- src/hw/esp-scsi.c| 8 ++-- src/hw/l

[SeaBIOS] [PATCH 3/4] pci: Split low-level pci code from higher-level 'struct pci_device' code

2016-02-03 Thread Kevin O'Connor
Split pci.c into pci.c and pcidevice.c. The low-level code that interacts directly with the PCI devices remains in pci.c, while functions dealing with the higher level pci_device cache move to pcidevice.c. Only pci.c is needed in 16bit mode. Signed-off-by: Kevin O'Connor --- Makefile

[SeaBIOS] [PATCH 2/4] pci: Move code in pci.c that is specific to pciinit.c to pciinit.c

2016-02-03 Thread Kevin O'Connor
Signed-off-by: Kevin O'Connor --- src/fw/mtrr.c| 1 - src/fw/pciinit.c | 37 + src/hw/pci.c | 26 -- src/hw/pci.h | 15 --- src/util.h | 2 ++ 5 files changed, 39 insertions(+), 42 deletions(-) diff --git

[SeaBIOS] [PATCH 4/4] scsi: Always use MAXDESCSIZE when building drive description

2016-02-03 Thread Kevin O'Connor
Signed-off-by: Kevin O'Connor --- src/hw/esp-scsi.c | 2 +- src/hw/lsi-scsi.c | 2 +- src/hw/megasas.c | 3 ++- src/hw/pvscsi.c | 2 +- 4 files changed, 5 insertions(+), 4 deletions(-) diff --git a/src/hw/esp-scsi.c b/src/hw/esp-scsi.c index 086a032..c98989c 100644 --- a/src/hw/esp-scsi.c +++

Re: [SeaBIOS] [RFC PATCH v2] fw/pci: Add support for mapping Intel IGD OpRegion via QEMU

2016-02-03 Thread Gerd Hoffmann
Hi, > +static void intel_igd_opregion_setup(struct pci_device *dev, void *arg) > +{ > +struct romfile_s *file = romfile_find("etc/igd-opregion"); Is it possible to have multiple igd devices in a single machine? So, should we include the pci address in the file name? Guess not needed, it's