Re: jdk11u and jdk/jdk : jtreg test error in security/infra/java/security/cert/CertPathValidator/certification/ActalisCA.java

2018-12-19 Thread Rajan Halade
I will address these after this winter break or during if I get time. Thanks, Rajan On 12/19/18 2:28 AM, Lindenmaier, Goetz wrote: Hi, the amount of tests failing is increasing: security/infra/java/security/cert/CertPathValidator/certification/ActalisCA.java security/infra/java/securit

Re: RFR 6722928: Support SSPI as a native GSS-API provider

2018-12-19 Thread Valerie Peng
Sure, those typedefs makes sense. Thanks, Valerie On 12/19/2018 12:31 PM, Nico Williams wrote: On Wed, Dec 12, 2018 at 02:20:24PM -0800, Valerie Peng wrote: - gss_unwrap: add "const" to the 2nd and 3rd arguments? Isn't variable naming convention starts with lower case? the argument qop_state ma

Re: RFR 6722928: Support SSPI as a native GSS-API provider

2018-12-19 Thread Ivan Gerasimov
Hi Max! In sspi.cpp native memory is allocated via `new` or `new []`, and sometimes the returned pointer is checked for NULL. If `new` fails, it will throw the `std:: bad_alloc` exception, so I believe you should use `new (std::nothrow)` and `new (std::nothrow) []` instead. With kind regar

Re: RFR 8215643: Microbenchmarks for KeyAgreement and Cipher

2018-12-19 Thread Jamil Nimeh
Hi Adam.  On the whole the benchmarks look good to me.  Can I ask why those ciphers and key agreement schemes that support multiple key lengths aren't called out in the @Param annotations?  I'm thinking 192 and 256 bit for AES and maybe 1024 and 3072 and/or 4096 for DH.  Do we not need numbers

Re: RFR 6722928: Support SSPI as a native GSS-API provider

2018-12-19 Thread Nico Williams
On Wed, Dec 12, 2018 at 02:20:24PM -0800, Valerie Peng wrote: > - gss_unwrap: add "const" to the 2nd and 3rd arguments? Isn't variable > naming convention starts with lower case? the argument qop_state may be > non-null but is not set?|| Nowadays we have gss_const_* types. You have to use those b

Re: RFR 6722928: Support SSPI as a native GSS-API provider

2018-12-19 Thread Valerie Peng
Hi Max, Here are more comments/questions on : I am a bit unclear on the handling of the gss qop and MS qop. There are a few places where you seem to treat them as the same thing. But there are also cases where they seem unrelated as you didn't set one using the other and vice versa. For all

RFR 8215643: Microbenchmarks for KeyAgreement and Cipher

2018-12-19 Thread Adam Petcher
Webrev: http://cr.openjdk.java.net/~apetcher/8215643/webrev.00/ JBS: https://bugs.openjdk.java.net/browse/JDK-8215643 Please review this enhancement that adds two new crypto microbenchmarks. See the JBS ticket for the motivation behind these new benchmarks. The Cipher benchmark nearly duplicate

Re: RFR: 8214532,Update RFC 2459 references in javadoc to RFC 5280

2018-12-19 Thread Seán Coffey
Thanks Sean. I've made those edits and pushed to JDK 12 repo. Regards, Sean. On 19/12/18 14:21, Sean Mullan wrote: Just a couple of minor comments: * DNSName 184 * draft-ietf-pkix-new-part1-00.txt: DNSName restrictions are expressed as foo.bar.com. Change "draft-ietf-pkix-new-part1-0

Re: RFR: 8214532,Update RFC 2459 references in javadoc to RFC 5280

2018-12-19 Thread Sean Mullan
Just a couple of minor comments: * DNSName 184 * draft-ietf-pkix-new-part1-00.txt: DNSName restrictions are expressed as foo.bar.com. Change "draft-ietf-pkix-new-part1-00.txt" to RFC 5280. * X509CertImpl 67 * * can be referenced in RFC 5280. remove extra '*'. --Sean On 12/19/18 6:

RFR: 8214532,Update RFC 2459 references in javadoc to RFC 5280

2018-12-19 Thread Seán Coffey
Some doc edits to update RFC 2459 to 5280. I've updated the relevant section numbers where necessary. No edits to Java SE specification docs. I've taken the opportunity to put a space in some "RFC" references also as it seems to be preferred approach. I've removed a paragraph in src/java.

RE: jdk11u and jdk/jdk : jtreg test error in security/infra/java/security/cert/CertPathValidator/certification/ActalisCA.java

2018-12-19 Thread Lindenmaier, Goetz
Hi, the amount of tests failing is increasing: security/infra/java/security/cert/CertPathValidator/certification/ActalisCA.java security/infra/java/security/cert/CertPathValidator/certification/ComodoCA.java security/infra/java/security/cert/CertPathValidator/certification/B