Re: RFR: 8259065: Optimize MessageDigest.getInstance [v4]

2021-01-06 Thread Claes Redestad
On Thu, 7 Jan 2021 03:59:13 GMT, Claes Redestad wrote: >> By caching default constructors used in >> `java.security.Provider::newInstanceUtil` in a `ClassValue`, we can reduce >> the overhead of allocating instances in a variety of places, e.g., >> `MessageDigest::getInstance`, without comprom

Re: RFR: 8259065: Optimize MessageDigest.getInstance [v3]

2021-01-06 Thread Claes Redestad
On Wed, 6 Jan 2021 20:52:19 GMT, Valerie Peng wrote: >> Claes Redestad has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Add cloneInstance baseline micro > > src/java.base/share/classes/java/security/MessageDigest.java line 185: > >> 183:

Re: RFR: 8259065: Optimize MessageDigest.getInstance [v4]

2021-01-06 Thread Claes Redestad
> By caching default constructors used in > `java.security.Provider::newInstanceUtil` in a `ClassValue`, we can reduce > the overhead of allocating instances in a variety of places, e.g., > `MessageDigest::getInstance`, without compromising thread-safety or security. > > On the provided microbe

Re: RFR: 8259065: Optimize MessageDigest.getInstance [v3]

2021-01-06 Thread Valerie Peng
On Wed, 6 Jan 2021 01:27:09 GMT, Claes Redestad wrote: >> By caching default constructors used in >> `java.security.Provider::newInstanceUtil` in a `ClassValue`, we can reduce >> the overhead of allocating instances in a variety of places, e.g., >> `MessageDigest::getInstance`, without comprom

Re: RFR: 8237578: JDK-8214339 (SSLSocketImpl wraps SocketException) appears to not be fully fixed

2021-01-06 Thread Xue-Lei Andrew Fan
On Wed, 6 Jan 2021 23:28:34 GMT, Clive Verghese wrote: > This PR aims to revert some more cases where SocketExceptions are improperly > being wrapped as SSLException. Some work for this was done in > [JDK-8235263](https://bugs.openjdk.java.net/browse/JDK-8235263), but that > change did not cov

RFR: 8237578: JDK-8214339 (SSLSocketImpl wraps SocketException) appears to not be fully fixed

2021-01-06 Thread Clive Verghese
This PR aims to revert some more cases where SocketExceptions are improperly being wrapped as SSLException. Some work for this was done in [JDK-8235263](https://bugs.openjdk.java.net/browse/JDK-8235263), but that change did not cover all the cases. As it was mentioned in JDK-8235263, some appli

Re: RFR: 8259065: Optimize MessageDigest.getInstance

2021-01-06 Thread Valerie Peng
On Wed, 6 Jan 2021 02:29:58 GMT, David Schlosnagle wrote: >> Since much of the cost is now the creation of the MessageDigest itself, I >> added a microbenchmark to stat this overhead: >> >> Benchmark >> (digesterName) Mode Cnt Score

Integrated: 8250564: Remove terminally deprecated constructor in GSSUtil

2021-01-06 Thread Joe Darcy
On Tue, 5 Jan 2021 21:02:21 GMT, Joe Darcy wrote: > Back in JDK 16, two unintended default constructors were identified and > deprecated for removal. The time has come to remove them. > > Please also review the corresponding CSRs: > > JDK-8258521 Remove terminally deprecated constructor in GSS

Re: RFR: 8250564: Remove terminally deprecated constructor in GSSUtil

2021-01-06 Thread Sean Mullan
On Tue, 5 Jan 2021 21:02:21 GMT, Joe Darcy wrote: > Back in JDK 16, two unintended default constructors were identified and > deprecated for removal. The time has come to remove them. > > Please also review the corresponding CSRs: > > JDK-8258521 Remove terminally deprecated constructor in GSS

Integrated: 8259291: Cleanup unnecessary local variables

2021-01-06 Thread Xue-Lei Andrew Fan
On Wed, 6 Jan 2021 05:17:35 GMT, Xue-Lei Andrew Fan wrote: > In the SunJSSE provider implementation, there are a few local variables that > is not necessary. For example: > > byte[] finished = prfKey.getEncoded(); > return finished; > > could be simplified as: > > return prfK

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v12]

2021-01-06 Thread Jim Laskey
On Wed, 6 Jan 2021 16:09:25 GMT, Brett Okken wrote: >> Jim Laskey has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Correct range used by nextBytes > > src/java.base/share/classes/java/util/random/RandomGenerator.java line 147: > >> 145:

Integrated: 8259312: VerifyCACerts.java fails as soneraclass2ca cert will expire in 90 days

2021-01-06 Thread Rajan Halade
On Wed, 6 Jan 2021 15:55:28 GMT, Rajan Halade wrote: > …in 90 days This pull request has now been integrated. Changeset: 3be6e069 Author:Rajan Halade URL: https://git.openjdk.java.net/jdk/commit/3be6e069 Stats: 3 lines in 1 file changed: 2 ins; 0 del; 1 mod 8259312: VerifyCACert

Re: RFR: 8259312: VerifyCACerts.java fails as soneraclass2ca cert will expire in 90 days

2021-01-06 Thread Sean Mullan
On Wed, 6 Jan 2021 15:55:28 GMT, Rajan Halade wrote: > …in 90 days Marked as reviewed by mullan (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/1963

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v12]

2021-01-06 Thread Brett Okken
On Wed, 6 Jan 2021 15:36:21 GMT, Jim Laskey wrote: >> This PR is to introduce a new random number API for the JDK. The primary API >> is found in RandomGenerator and RandomGeneratorFactory. Further description >> can be found in the JEP https://openjdk.java.net/jeps/356 . >> >> javadoc can be

RFR: 8259312: VerifyCACerts.java fails as soneraclass2ca cert will expire in 90 dayseibcccttchjcjfkgtgbcgitkibtitbvvtbfgejetjlcn

2021-01-06 Thread Rajan Halade
…in 90 days - Commit messages: - 8259312: VerifyCACerts.java fails as soneraclass2ca cert will expire in 90 days Changes: https://git.openjdk.java.net/jdk/pull/1963/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=1963&range=00 Issue: https://bugs.openjdk.java.net/bro

Re: RFR: 8259291: Cleanup unnecessary local variables

2021-01-06 Thread Sean Mullan
On Wed, 6 Jan 2021 05:17:35 GMT, Xue-Lei Andrew Fan wrote: > In the SunJSSE provider implementation, there are a few local variables that > is not necessary. For example: > > byte[] finished = prfKey.getEncoded(); > return finished; > > could be simplified as: > > return prfK

RFR: 8259319: Illegal package access when SunPKCS11 requires SunJCE's classes

2021-01-06 Thread Martin Balao
As described in JDK-8259319 [1], this fix proposal is to set proper access permissions so the SunPKCS11 provider can create instances of SunJCE classes when a Security Manager is installed and the fallback scheme is used. No regressions found in jdk/sun/security/pkcs11 tests category. -- [1] -

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v3]

2021-01-06 Thread Brett Okken
On Wed, 25 Nov 2020 14:07:04 GMT, Rémi Forax wrote: >> Jim Laskey has updated the pull request incrementally with one additional >> commit since the last revision: >> >> 8248862: Implement Enhanced Pseudo-Random Number Generators >> >> Changes to RandomGeneratorFactory requested by @Pau

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v3]

2021-01-06 Thread Jim Laskey
On Thu, 26 Nov 2020 15:41:16 GMT, Jim Laskey wrote: >> src/java.base/share/classes/java/util/random/RandomGeneratorFactory.java >> line 46: >> >>> 44: import java.util.stream.Stream; >>> 45: import jdk.internal.util.random.RandomSupport.RandomGeneratorProperty; >>> 46: >> >> Instead of callin

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v3]

2021-01-06 Thread Jim Laskey
On Wed, 6 Jan 2021 15:31:32 GMT, Jim Laskey wrote: >> I kind of like the idea - not sure how expressive a BigInteger string is >> though. I might be able to express as >> BigInteger.ONE.shiftLeft(i).subtract(j).shiftLeft(k). Will ponder. > > Done Also added getDefault and getDefaultFactory t

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v12]

2021-01-06 Thread Jim Laskey
> This PR is to introduce a new random number API for the JDK. The primary API > is found in RandomGenerator and RandomGeneratorFactory. Further description > can be found in the JEP https://openjdk.java.net/jeps/356 . > > javadoc can be found at > http://cr.openjdk.java.net/~jlaskey/prng/doc/a

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v9]

2021-01-06 Thread Jim Laskey
On Tue, 5 Jan 2021 02:43:08 GMT, Brett Okken wrote: >> Jim Laskey has updated the pull request with a new target base due to a >> merge or a rebase. The pull request now contains 34 commits: >> >> - Merge branch 'master' into 8248862 >> - 8248862: Implement Enhanced Pseudo-Random Number Gene

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v9]

2021-01-06 Thread Brett Okken
On Mon, 4 Jan 2021 19:52:18 GMT, Jim Laskey wrote: >> This PR is to introduce a new random number API for the JDK. The primary API >> is found in RandomGenerator and RandomGeneratorFactory. Further description >> can be found in the JEP https://openjdk.java.net/jeps/356 . >> >> javadoc can be

Re: RFR: 8248862: Implement Enhanced Pseudo-Random Number Generators [v11]

2021-01-06 Thread Jim Laskey
> This PR is to introduce a new random number API for the JDK. The primary API > is found in RandomGenerator and RandomGeneratorFactory. Further description > can be found in the JEP https://openjdk.java.net/jeps/356 . > > javadoc can be found at > http://cr.openjdk.java.net/~jlaskey/prng/doc/a