Integrated: 8264948: Check for TLS extensions total length

2021-04-09 Thread Xue-Lei Andrew Fan
On Fri, 9 Apr 2021 04:55:14 GMT, Xue-Lei Andrew Fan wrote: > To improve the readability, it would be nice to check the TLS extensions > total length while parsing. > > No new regression test, trial update. This pull request has now been integrated. Changeset: 5784f6b7 Author:Xue-Lei

Re: RFR: 8264208: Console charset API [v2]

2021-04-09 Thread Bernd Eckenfels
Hello, I like the API, it is useful, however not enough to replace the defaultCharset once the Change to UTF8 is done. You still need a way to query the platforms file encoding (especially on Windows). Also I wonder if the Javadoc needs to discuss platform aspects of console, especially

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params

2021-04-09 Thread Weijun Wang
On Wed, 24 Mar 2021 21:36:21 GMT, Weijun Wang wrote: > This enhancement contains the following code changes: > > 1. Create a new public API `javax/xml/crypto/dsig/spec/RSAPSSParameterSpec` > and remove the internal one. > 2. Update marshaling and unmarshaling code inside

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v4]

2021-04-09 Thread Weijun Wang
> This enhancement contains the following code changes: > > 1. Create a new public API `javax/xml/crypto/dsig/spec/RSAPSSParameterSpec` > and remove the internal one. > 2. Update marshaling and unmarshaling code inside `DOMRSAPSSSignatureMethod` > so it understands extra fields in

Re: RFR: 8261355: No data buffering in SunPKCS11 Cipher encryption when the underlying mechanism has no padding [v4]

2021-04-09 Thread Valerie Peng
On Thu, 8 Apr 2021 21:52:43 GMT, Martin Balao wrote: >> Hi, >> >> I'd like to propose a fix for JDK-8261355 [1]. >> >> The scheme used for holding data and padding while performing encryption >> operations is almost the same than the existing one for decryption. The only >> difference is

Re: RFR: 8264208: Console charset API [v2]

2021-04-09 Thread Joe Wang
On Fri, 9 Apr 2021 21:06:00 GMT, Naoto Sato wrote: >> Please review the changes for the subject issue. This has been suggested in >> a recent discussion thread for the JEP 400 >> [[1](https://mail.openjdk.java.net/pipermail/core-libs-dev/2021-March/075214.html)]. >> A CSR has also been

Re: RFR: 8264208: Console charset API [v2]

2021-04-09 Thread Joe Wang
On Fri, 9 Apr 2021 21:02:26 GMT, Naoto Sato wrote: >> src/java.base/share/classes/java/io/Console.java line 404: >> >>> 402: * >>> 403: * @return A {@code Charset} object used in this {@code Console}. >>> 404: * @since 17 >> >> A couple of minor comments: >> May replace {@code

Re: RFR: 8264948: Check for TLS extensions total length [v2]

2021-04-09 Thread Jamil Nimeh
On Fri, 9 Apr 2021 19:29:50 GMT, Xue-Lei Andrew Fan wrote: >> To improve the readability, it would be nice to check the TLS extensions >> total length while parsing. >> >> No new regression test, trial update. > > Xue-Lei Andrew Fan has updated the pull request incrementally with one >

RFR: Release Note for JDK-8264968 Provide the support for specifying a signer in keytool -genkeypair command

2021-04-09 Thread Hai-May Chao
Please review the release note for JDK-8264968: https://bugs.openjdk.java.net/browse/JDK-8264968 Thanks, Hai-May

Re: RFR: 8264208: Console charset API [v2]

2021-04-09 Thread Naoto Sato
> Please review the changes for the subject issue. This has been suggested in > a recent discussion thread for the JEP 400 > [[1](https://mail.openjdk.java.net/pipermail/core-libs-dev/2021-March/075214.html)]. > A CSR has also been drafted, and comments are welcome >

Re: RFR: 8264208: Console charset API [v2]

2021-04-09 Thread Naoto Sato
On Fri, 9 Apr 2021 19:25:02 GMT, Joe Wang wrote: >> Naoto Sato has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Reflected the review comments. > > src/java.base/share/classes/java/io/Console.java line 404: > >> 402: * >> 403:

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v3]

2021-04-09 Thread Sean Mullan
On Fri, 9 Apr 2021 19:54:22 GMT, Weijun Wang wrote: >> I'm ok with not supporting SHA-1, although adding it would not be a security >> issue. It is blocked by default now, but it can be re-enabled, and SHA-1 in >> general is still available in the JDK. >> >> I'm fine with adding support for

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v3]

2021-04-09 Thread Weijun Wang
On Fri, 9 Apr 2021 17:23:05 GMT, Sean Mullan wrote: >> src/java.xml.crypto/share/classes/com/sun/org/apache/xml/internal/security/algorithms/implementations/SignatureBaseRSA.java >> line 588: >> >>> 586: >>> 587: public enum DigestAlgorithm { >>> 588: //SHA1("SHA-1",

Re: RFR: 8264208: Console charset API

2021-04-09 Thread Joe Wang
On Fri, 9 Apr 2021 16:47:55 GMT, Naoto Sato wrote: > Please review the changes for the subject issue. This has been suggested in > a recent discussion thread for the JEP 400 > [[1](https://mail.openjdk.java.net/pipermail/core-libs-dev/2021-March/075214.html)]. > A CSR has also been drafted,

Re: RFR: 8264948: Check for TLS extensions total length [v2]

2021-04-09 Thread Xue-Lei Andrew Fan
On Fri, 9 Apr 2021 05:55:40 GMT, Jamil Nimeh wrote: >> Xue-Lei Andrew Fan has updated the pull request incrementally with one >> additional commit since the last revision: >> >> Change to use decode_error for incorrect extension length > >

Re: RFR: 8264948: Check for TLS extensions total length [v2]

2021-04-09 Thread Xue-Lei Andrew Fan
> To improve the readability, it would be nice to check the TLS extensions > total length while parsing. > > No new regression test, trial update. Xue-Lei Andrew Fan has updated the pull request incrementally with one additional commit since the last revision: Change to use decode_error

Re: RFR: 8255410: Add ChaCha20 and Poly1305 support to SunPKCS11 provider [v2]

2021-04-09 Thread Valerie Peng
> Could someone (perhaps Jamil?) please help review this change? This enhances > SunPKCS11 provider with ChaCha20-Poly1305 cipher and ChaCha20 key generation > support. Majority of the regression tests are adapted from the existing ones > for SunJCE provider's ChaCha20-Poly1305 cipher impl.

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v3]

2021-04-09 Thread Weijun Wang
On Fri, 9 Apr 2021 16:44:07 GMT, Sean Mullan wrote: >> Weijun Wang has updated the pull request incrementally with one additional >> commit since the last revision: >> >> spec word change, no hashCode and equals, test change > >

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v3]

2021-04-09 Thread Sean Mullan
On Wed, 24 Mar 2021 21:39:28 GMT, Weijun Wang wrote: >> Weijun Wang has updated the pull request incrementally with one additional >> commit since the last revision: >> >> spec word change, no hashCode and equals, test change > >

RFR: 8255410: Add ChaCha20 and Poly1305 support to SunPKCS11 provider

2021-04-09 Thread Valerie Peng
Could someone (perhaps Jamil?) please help review this change? This enhances SunPKCS11 provider with ChaCha20-Poly1305 cipher and ChaCha20 key generation support. Majority of the regression tests are adapted from the existing ones for SunJCE provider's ChaCha20-Poly1305 cipher impl. When

RFR: 8264208: Console charset API

2021-04-09 Thread Naoto Sato
Please review the changes for the subject issue. This has been suggested in a recent discussion thread for the JEP 400 [[1](https://mail.openjdk.java.net/pipermail/core-libs-dev/2021-March/075214.html)]. A CSR has also been drafted, and comments are welcome

Re: RFR: 8241306: Add SignatureMethodParameterSpec subclass for RSASSA-PSS params [v3]

2021-04-09 Thread Sean Mullan
On Thu, 1 Apr 2021 13:32:47 GMT, Weijun Wang wrote: >> This enhancement contains the following code changes: >> >> 1. Create a new public API `javax/xml/crypto/dsig/spec/RSAPSSParameterSpec` >> and remove the internal one. >> 2. Update marshaling and unmarshaling code inside

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Roger Riggs
On Fri, 9 Apr 2021 15:47:35 GMT, Conor Cleary wrote: >> src/java.naming/share/classes/com/sun/jndi/ldap/LdapPoolManager.java line >> 413: >> >>> 411: return AccessController.doPrivileged( >>> 412: (PrivilegedAction) () -> Long.getLong(propName, >>> defVal).longValue()

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Conor Cleary
On Fri, 9 Apr 2021 13:46:46 GMT, Roger Riggs wrote: >> ### Description >> This fix is part of a previous effort to both cleanup/modernise JNDI code, >> the details of which can be seen in >> [JDK-8048091](https://bugs.openjdk.java.net/browse/JDK-8048091). A number >> JNDI methods under

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Conor Cleary
On Fri, 9 Apr 2021 14:01:32 GMT, Roger Riggs wrote: >> That is a very neat alternative yes. Approaching the problem like that >> especially improves the readability >>

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Roger Riggs
On Fri, 9 Apr 2021 13:51:30 GMT, Conor Cleary wrote: >> An alternative here would be to use >> sun.security.action.privilegedGetProperty(prop, default). >> The package is already exported from java.base to java.desktop, etc. > > That is a very neat alternative yes. Approaching the problem like

Integrated: 8260923: Add more tests for SSLSocket input/output shutdown

2021-04-09 Thread Abdul Kolarkunnu
On Fri, 26 Feb 2021 11:12:08 GMT, Abdul Kolarkunnu wrote: > There is a lack of tests in the area of java.net.Socket.shutdownInput() and > java.net.Socket.shutdownOutput() , so added more tests in this area of with > different TLS versions. Please review. This pull request has now been

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Conor Cleary
On Fri, 9 Apr 2021 13:45:03 GMT, Roger Riggs wrote: >> src/java.naming/share/classes/com/sun/jndi/ldap/LdapPoolManager.java line >> 401: >> >>> 399: return AccessController.doPrivileged( >>> 400: (PrivilegedAction) () -> >>> System.getProperty(propName, defVal) >>>

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Roger Riggs
On Fri, 9 Apr 2021 13:15:16 GMT, Conor Cleary wrote: > ### Description > This fix is part of a previous effort to both cleanup/modernise JNDI code, > the details of which can be seen in > [JDK-8048091](https://bugs.openjdk.java.net/browse/JDK-8048091). A number > JNDI methods under

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Roger Riggs
On Fri, 9 Apr 2021 13:30:27 GMT, Alan Bateman wrote: >> ### Description >> This fix is part of a previous effort to both cleanup/modernise JNDI code, >> the details of which can be seen in >> [JDK-8048091](https://bugs.openjdk.java.net/browse/JDK-8048091). A number >> JNDI methods under

Re: RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Alan Bateman
On Fri, 9 Apr 2021 13:15:16 GMT, Conor Cleary wrote: > ### Description > This fix is part of a previous effort to both cleanup/modernise JNDI code, > the details of which can be seen in > [JDK-8048091](https://bugs.openjdk.java.net/browse/JDK-8048091). A number > JNDI methods under

RFR: 8048199: Replace anonymous inner classes with lambdas, where applicable, in JNDI

2021-04-09 Thread Conor Cleary
### Description This fix is part of a previous effort to both cleanup/modernise JNDI code, the details of which can be seen in [JDK-8048091](https://bugs.openjdk.java.net/browse/JDK-8048091). A number JNDI methods under `java.naming` use Anonymous Inner Classes in cases where only a single

Re: RFR: 8260923: Add more tests for SSLSocket input/output shutdown

2021-04-09 Thread Sean Coffey
On Tue, 2 Mar 2021 10:31:03 GMT, Abdul Kolarkunnu wrote: >> There is a lack of tests in the area of java.net.Socket.shutdownInput() and >> java.net.Socket.shutdownOutput() , so added more tests in this area of with >> different TLS versions. Please review. > > @coffeys Thanks for increasing

Re: RFR: 8260923: Add more tests for SSLSocket input/output shutdown [v2]

2021-04-09 Thread Sean Coffey
On Fri, 9 Apr 2021 11:15:40 GMT, Abdul Kolarkunnu wrote: >> There is a lack of tests in the area of java.net.Socket.shutdownInput() and >> java.net.Socket.shutdownOutput() , so added more tests in this area of with >> different TLS versions. Please review. > > Abdul Kolarkunnu has updated

Re: RFR: 8260923: Add more tests for SSLSocket input/output shutdown [v2]

2021-04-09 Thread Abdul Kolarkunnu
> There is a lack of tests in the area of java.net.Socket.shutdownInput() and > java.net.Socket.shutdownOutput() , so added more tests in this area of with > different TLS versions. Please review. Abdul Kolarkunnu has updated the pull request incrementally with one additional commit since the

RE: [11u] RFR: 8226374: Restrict TLS signature schemes and named groups

2021-04-09 Thread Doerr, Martin
That one was hard to see. Pushed. Thanks, Martin > -Original Message- > From: Hohensee, Paul > Sent: Donnerstag, 8. April 2021 23:36 > To: Doerr, Martin ; Langer, Christoph > ; jdk-updates-dev d...@openjdk.java.net>; security-dev > Cc: Lindenmaier, Goetz > Subject: RE: [11u] RFR: