Re: RFR: 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with JDK native libraries

2023-04-11 Thread Jiangli Zhou
On Wed, 12 Apr 2023 03:20:47 GMT, Jiangli Zhou wrote: > Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This > resolves the related duplicate symbol failures when both libnio and libsctp > are statically linked with the launcher. > > Remove #include "nio_util.h" from

RFR: 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with JDK native libraries

2023-04-11 Thread Jiangli Zhou
Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This resolves the related duplicate symbol failures when both libnio and libsctp are statically linked with the launcher. Remove #include "nio_util.h" from SctpChannelImpl.c and SctpNet.c. Looks like that's only needed for

Re: RFR: 8304845: COPYING in MUSCLE library includes incomplete license

2023-04-11 Thread Man Cao
On Mon, 10 Apr 2023 16:56:04 GMT, Valerie Peng wrote: > Could someone please help review this fix? Besides updating the md and > COPYING files to address the incomplete license issue, this PR also updates > the version to 1.9.9. Thank you for fixing this! Not an official Reviewer, but it

Re: RFR: JDK-8287061: Support for rematerializing scalar replaced objects participating in allocation merges [v7]

2023-04-11 Thread Cesar Soares Lucas
On Thu, 6 Apr 2023 03:25:31 GMT, Vladimir Kozlov wrote: >> Cesar Soares Lucas has updated the pull request with a new target base due >> to a merge or a rebase. The pull request now contains seven commits: >> >> - Merge with Master >> - Addressing PR review 2: refactor & reuse

RFR: 8304845: COPYING in MUSCLE library includes incomplete license

2023-04-11 Thread Valerie Peng
8304845: COPYING in MUSCLE library includes incomplete license - Commit messages: - Update to 1.9.9 and more .md changes. - 8304845: COPYING in MUSCLE library includes incomplete license Changes: https://git.openjdk.org/jdk/pull/13409/files Webrev:

Withdrawn: 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with JDK native libraries

2023-04-11 Thread Jiangli Zhou
On Tue, 11 Apr 2023 19:19:07 GMT, Jiangli Zhou wrote: > Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This > resolves related duplicate symbol failure when both libnio and libsctp are > statically linked with. This pull request has been closed without being integrated.

Re: RFR: JDK-8287061: Support for rematerializing scalar replaced objects participating in allocation merges [v7]

2023-04-11 Thread Cesar Soares Lucas
On Thu, 6 Apr 2023 04:34:52 GMT, Vladimir Kozlov wrote: >> Cesar Soares Lucas has updated the pull request with a new target base due >> to a merge or a rebase. The pull request now contains seven commits: >> >> - Merge with Master >> - Addressing PR review 2: refactor & reuse

RFR: 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with JDK native libraries

2023-04-11 Thread Jiangli Zhou
Rename 'handleSocketError' to 'sctpHandleSocketError' in libsctp. This resolves related duplicate symbol failure when both libnio and libsctp are statically linked with. - Commit messages: - 8305858: Resolve multiple definition of 'handleSocketError' when statically linking with

Re: RFR: 8305091: Change ChaCha20 cipher init behavior to match AES-GCM

2023-04-11 Thread Jamil Nimeh
On Tue, 11 Apr 2023 18:15:22 GMT, Xue-Lei Andrew Fan wrote: >> This fixes an issue where the key/nonce reuse policy for SunJCE ChaCha20 and >> ChaCha20-Poly1305 was overly strict in enforcing no-reuse when the Cipher >> was in DECRYPT_MODE. For decryption, this should be allowed and be >>

Re: RFR: 8305091: Change ChaCha20 cipher init behavior to match AES-GCM

2023-04-11 Thread Xue-Lei Andrew Fan
On Tue, 11 Apr 2023 17:26:25 GMT, Jamil Nimeh wrote: > This fixes an issue where the key/nonce reuse policy for SunJCE ChaCha20 and > ChaCha20-Poly1305 was overly strict in enforcing no-reuse when the Cipher was > in DECRYPT_MODE. For decryption, this should be allowed and be consistent >

RFR: 8305091: Change ChaCha20 cipher init behavior to match AES-GCM

2023-04-11 Thread Jamil Nimeh
This fixes an issue where the key/nonce reuse policy for SunJCE ChaCha20 and ChaCha20-Poly1305 was overly strict in enforcing no-reuse when the Cipher was in DECRYPT_MODE. For decryption, this should be allowed and be consistent with the AES-GCM decryption initialization behavior. - Issue:

Integrated: 8305761: Resolve multiple definition of 'jvm' when statically linking with JDK native libraries

2023-04-11 Thread Jiangli Zhou
On Sat, 8 Apr 2023 01:11:08 GMT, Jiangli Zhou wrote: > Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol > problems when statically linking the launcher executable with JDK native > libraries. This pull request has now been integrated. Changeset: ce4b9955 Author:Jiangli

Re: RFR: 8305761: Resolve multiple definition of 'jvm' when statically linking with JDK native libraries [v2]

2023-04-11 Thread Jiangli Zhou
On Mon, 10 Apr 2023 19:38:18 GMT, Jiangli Zhou wrote: >> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol >> problems when statically linking the launcher executable with JDK native >> libraries. > > Jiangli Zhou has updated the pull request incrementally with one additional

Integrated: JDK-8302696 Revert API signature changes made in JDK-8285504 and JDK-8285263

2023-04-11 Thread Mark Powers
On Fri, 7 Apr 2023 19:09:43 GMT, Mark Powers wrote: > https://bugs.openjdk.org/browse/JDK-8302696 This pull request has now been integrated. Changeset: 9486969b Author:Mark Powers Committer: Sean Mullan URL:

Re: RFR: 8305761: Resolve multiple definition of 'jvm' when statically linking with JDK native libraries [v2]

2023-04-11 Thread Kevin Walls
On Mon, 10 Apr 2023 19:38:18 GMT, Jiangli Zhou wrote: >> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol >> problems when statically linking the launcher executable with JDK native >> libraries. > > Jiangli Zhou has updated the pull request incrementally with one additional

Re: RFR: 8305761: Resolve multiple definition of 'jvm' when statically linking with JDK native libraries [v2]

2023-04-11 Thread Alan Bateman
On Mon, 10 Apr 2023 19:38:18 GMT, Jiangli Zhou wrote: >> Rename various 'jvm' variables to 'jvm_' to avoid duplicate symbol >> problems when statically linking the launcher executable with JDK native >> libraries. > > Jiangli Zhou has updated the pull request incrementally with one additional