Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v5]

2024-01-02 Thread Stefan Karlsson
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename > createJavaProcessBuilder' changed the name of the ProcessTools helper > functions used to create `ProcessBuilder`s used to spawn new java test > processes. > > We now have `createTestJavaProcessBuilder` and >

Re: RFR: 8265372: Simplify PKCS9Attribute

2024-01-02 Thread Weijun Wang
On Tue, 2 Jan 2024 18:22:51 GMT, Ben Perez wrote: >> src/java.base/share/classes/sun/security/pkcs/PKCS9Attribute.java line 186: >> >>> 184: /** >>> 185: * Array of attribute OIDs defined in PKCS9, by number. >>> 186: */ >> >> I don't think `PKCS9_OIDS` is useful now. It's used

Re: RFR: 8265372: Simplify PKCS9Attribute

2024-01-02 Thread Ben Perez
On Thu, 21 Dec 2023 16:27:43 GMT, Weijun Wang wrote: >> Refactored PKCS9Attribute to use a hash map instead of multiple arrays. The >> key for the hash map is an `ObjectIdentifier` and the values are a record >> `AttributeInfo` that stores the information previously contained in the >> arrays

Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v4]

2024-01-02 Thread Stefan Karlsson
> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename > createJavaProcessBuilder' changed the name of the ProcessTools helper > functions used to create `ProcessBuilder`s used to spawn new java test > processes. > > We now have `createTestJavaProcessBuilder` and >

Re: RFR: 8321713: Harmonize executeTestJvm with create[Limited]TestJavaProcessBuilder [v3]

2024-01-02 Thread Stefan Karlsson
On Mon, 11 Dec 2023 14:06:43 GMT, Stefan Karlsson wrote: >> [JDK-8315097](https://bugs.openjdk.org/browse/JDK-8315097): 'Rename >> createJavaProcessBuilder' changed the name of the ProcessTools helper >> functions used to create `ProcessBuilder`s used to spawn new java test >> processes. >>

Re: RFR: 8310813: Simplify and modernize equals, hashCode, and compareTo for BigInteger [v10]

2024-01-02 Thread Pavel Rappo
> Please review this PR to use modern APIs and language features to simplify > equals, hashCode, and compareTo for BigInteger. If you have any performance > concerns, please raise them. > > This PR is cherry-picked from a bigger, not-yet-published PR, to test the > waters. That latter PR will

Re: RFR: JDK-8319122: Improve documentation of various Zip-file related APIs [v2]

2024-01-02 Thread Yakov Shafranovich
On Fri, 10 Nov 2023 15:44:19 GMT, Yakov Shafranovich wrote: >> The various Zip/Jar-file related Java APIs have some long-standing >> differences or peculiarities with respect to the ZIP-file specification or >> compared to other implementations which should be documented in the API-doc. >>

Re: RFR: 8322766: Micro bench SSLHandshake should use default algorithms [v2]

2024-01-02 Thread John Jiang
On Tue, 2 Jan 2024 13:43:27 GMT, Sean Mullan wrote: >> John Jiang has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Use default algorithms > > Can you change the bug summary to "Micro bench SSLHandshake should use modern > algorithms"?

Re: RFR: 8322766: Micro bench SSLHandshake would use modern algorithms [v2]

2024-01-02 Thread Sean Mullan
On Sat, 30 Dec 2023 00:48:00 GMT, John Jiang wrote: >> test/micro/org/openjdk/bench/java/security/SSLHandshake.java is using >> keystore type `JKS` and TrustManagerFactory/KeyManagerFactory algorithm >> `SunX509`. >> It may be better to use `PKCS12` and `PKIX` respectively. > > John Jiang has