hg: hsx/hotspot-rt/hotspot: 2 new changesets

2012-04-13 Thread coleen . phillimore
Changeset: 27dab8a7c762 Author:coleenp Date: 2012-04-12 22:03 -0400 URL: http://hg.openjdk.java.net/hsx/hotspot-rt/hotspot/rev/27dab8a7c762 7160467: Fix test for 7158988 Summary: Ended up checking in FieldMonitor.java as TestPostFieldModification.java Reviewed-by: kamg ! test/runt

hg: jdk8/tl/jdk: 7152169: TEST_BUG: sun/security/tools/jarsigner/ec.sh occasionally fail due to keytool error on sparc

2012-04-13 Thread vincent . x . ryan
Changeset: 7340f4a3c830 Author:vinnie Date: 2012-04-13 19:00 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/7340f4a3c830 7152169: TEST_BUG: sun/security/tools/jarsigner/ec.sh occasionally fail due to keytool error on sparc Reviewed-by: mullan ! src/share/classes/sun/securit

Re: RFR: 7160570: Intrinsification support for tracing framework

2012-04-13 Thread Tom Rodriguez
It's unfortunate that we can't use sizeof(_thread_id) in a static context. In osThread_solaris.hpp there's a type name mismatch. + static size_t thread_id_size() { return sizeof(pid_t); } thread_t thread_id() const { return _thread_id; } Otherwise it looks good. tom On Apr 13, 20

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Eamonn McManus
I think there is a good case to be made for throwing an exception in the constructor if the name or type is null. I guess that would require a minor spec change, though. Without such a change, the code can be simplified using Objects.equals and Objects.hash. That assumes it doesn't need to be back

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Karen Kinnear
Thank you for checking Frederic. thanks, Karen On Apr 13, 2012, at 10:43 AM, Frederic Parain wrote: > Karen, > > As far as I can tell, getDescriptor() never returns null. > > In the javax.management package, getDescriptor() calls > ImmutableDescriptor.nonNullDescriptor(descriptor).clone() > wh

hg: hsx/hotspot-rt/hotspot: 7160924: jvmti: GetPhase returns incorrect phase before VMInit event is issued

2012-04-13 Thread staffan . larsen
Changeset: df4cd4aac5c1 Author:rbackman Date: 2012-04-12 13:24 +0200 URL: http://hg.openjdk.java.net/hsx/hotspot-rt/hotspot/rev/df4cd4aac5c1 7160924: jvmti: GetPhase returns incorrect phase before VMInit event is issued Reviewed-by: acorn, dcubed ! src/share/vm/runtime/thread.cpp

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Frederic Parain
Karen, As far as I can tell, getDescriptor() never returns null. In the javax.management package, getDescriptor() calls ImmutableDescriptor.nonNullDescriptor(descriptor).clone() which returns a reference to a singleton empty Descriptor instance if the descriptor field is null. The getDescriptor

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Frederic Parain
Fixed in this new webrev: http://cr.openjdk.java.net/~fparain/7148497/webrev.02/ Fred On 4/13/12 3:01 PM, Staffan Larsen wrote: This is much easier to read! In MBeanFeatureInfo.hasSameName() this check is not needed: 274 if(info.getName() == null) { 275return false; 276

hg: jdk8/tl/jdk: 2 new changesets

2012-04-13 Thread sean . mullan
Changeset: fa26ac92b29e Author:mullan Date: 2012-04-13 09:46 -0400 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/fa26ac92b29e 7152564: Improve CodeSource.matchLocation(CodeSource) performance 7155693: CodeSource.matchLocation getPort test can be improved Reviewed-by: chegar ! src

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Karen Kinnear
Frederic, Looks good. And I like the refactoring. A question - does the Descriptor field have the same potential for being null? e.g. in MBeanFeatureInfo.java new line 160 - do you need to check getDescriptor() == null as well? in MBeanConstructorinfo.java line 197, do you need the alternative

Re: RFR: 7160570: Intrinsification support for tracing framework

2012-04-13 Thread Rickard Bäckman
Thank you Staffan, still need one Reviewer, any takers? Thanks /R On 04/13/2012 11:21 AM, Staffan Larsen wrote: Looks good. /Staffan On 11 apr 2012, at 14:55, Rickard Bäckman wrote: Hi all, can I get reviews for the following change where we add support for intrinsics for a couple of met

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Staffan Larsen
This is much easier to read! In MBeanFeatureInfo.hasSameName() this check is not needed: 274 if(info.getName() == null) { 275return false; 276 } since String.equals() with a null argument works as expected (return false). The same is true for the implementation in ha

Re: RFR: 7148497: javax.management.MBeanAttributeInfo.hashCode throws NullPointerException

2012-04-13 Thread Frederic Parain
Thanks Staffan and Dmitry for your feedback, here's a new webrev with a refactored code for name and descriptions fields which are common to most MBean*Info classes: http://cr.openjdk.java.net/~fparain/7148497/webrev.01/ Thanks, Fred On 4/12/12 8:18 AM, Dmitry Samersoff wrote: Frederic, I'm

Re: RFR: 7160570: Intrinsification support for tracing framework

2012-04-13 Thread Staffan Larsen
Looks good. /Staffan On 11 apr 2012, at 14:55, Rickard Bäckman wrote: > Hi all, > > can I get reviews for the following change where we add support for > intrinsics for a couple of methods specified by the tracing framework? > > http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7160570 > >