Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v3]

2020-09-11 Thread Lin Zang
> - enable parallel heap inspecton for ShenandoahHeap > - preliminary evaluation: > Time of jmap histo on (8GB heap with 4GB objects) > * before: 5.186s > * after : 1.698s Lin Zang has refreshed the contents of this pull request, and previous commits have been removed. The

Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v3]

2020-09-11 Thread Lin Zang
On Fri, 11 Sep 2020 13:54:38 GMT, Zhengyu Gu wrote: >> Thank you, we'll take a look next week. > > Hi Lin, > > 1) The patch does not compile with assertion on > @@ -1490,7 +1490,7 @@ private: >cl->do_object(obj); >obj->oop_iterate(); > } > -assert(q.is_empty(), "should

Integrated: 8253033: CheckUnhandledOops check fails in ThreadSnapshot::initialize…

2020-09-11 Thread Leonid Mesnik
On Thu, 10 Sep 2020 23:38:45 GMT, Leonid Mesnik wrote: > The NULL oops are corrupted by CheckUnhandledOops and should be re-written > with NULL to pass testing > with -XX:+CheckUnhandledOops. This pull request has now been integrated. Changeset: 306b1663 Author:Leonid Mesnik URL:

Re: RFR: 8253033: CheckUnhandledOops check fails in ThreadSnapshot::initialize… [v2]

2020-09-11 Thread David Holmes
On Fri, 11 Sep 2020 18:26:03 GMT, Coleen Phillimore wrote: >> This is a specific of "CheckUnhandledOops" >> I've written in bug comment "Another possible fix would be to disable >> corruption of NULL unhandled oops. They couldn't >> be changed really." >> We discussed it with Coleen and seems

Re: RFR: 8253033: CheckUnhandledOops check fails in ThreadSnapshot::initialize… [v2]

2020-09-11 Thread David Holmes
On Fri, 11 Sep 2020 02:56:26 GMT, Leonid Mesnik wrote: >> The NULL oops are corrupted by CheckUnhandledOops and should be re-written >> with NULL to pass testing >> with -XX:+CheckUnhandledOops. > > Leonid Mesnik has updated the pull request incrementally with one additional > commit since the

Re: RFR: 8253033: CheckUnhandledOops check fails in ThreadSnapshot::initialize… [v2]

2020-09-11 Thread Coleen Phillimore
On Fri, 11 Sep 2020 03:37:55 GMT, Leonid Mesnik wrote: >> I'm missing something. How can a NULL oop get corrupted even if there is a >> GC? > > This is a specific of "CheckUnhandledOops" > I've written in bug comment "Another possible fix would be to disable > corruption of NULL unhandled

Re: RFR: 8253033: CheckUnhandledOops check fails in ThreadSnapshot::initialize… [v2]

2020-09-11 Thread Coleen Phillimore
On Fri, 11 Sep 2020 02:56:26 GMT, Leonid Mesnik wrote: >> The NULL oops are corrupted by CheckUnhandledOops and should be re-written >> with NULL to pass testing >> with -XX:+CheckUnhandledOops. > > Leonid Mesnik has updated the pull request incrementally with one additional > commit since the

Re: RFR: 8252933: com.sun.tools.jdi.ObjectReferenceImpl#validateAssignment always requests referenceType

2020-09-11 Thread Daniil Titov
On Fri, 11 Sep 2020 04:00:35 GMT, Chris Plummer wrote: >> The change fixes the regression introduced by >> https://bugs.openjdk.java.net/browse/JDK-8241080. >> >> Method validateAssignment() in com.sun.tools.jdi.ObjectReferenceImpl now >> always retrieves the reference type and that >>

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-11 Thread Bradford Wetmore
On Fri, 11 Sep 2020 07:15:26 GMT, Dmitriy Dumanskiy wrote: >> 1) This is un-necessary churn. >> 2) I can't even be sure I am finding the ones in my area because there's so >> much here >> 3) The ones I can find have no need of whatever performance improvement this >> might bring. >> I think

Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v2]

2020-09-11 Thread Zhengyu Gu
On Fri, 11 Sep 2020 10:54:42 GMT, Aleksey Shipilev wrote: >> Hi @shipilev, >> I have update a PR that trying to reuse code in serial and parallel >> heap iteration. >> would you like to review again? Thanks >> -Lin > > Thank you, we'll take a look next week. Hi Lin, 1) The patch

Re: RFR: 8227745: Enable Escape Analysis for Better Performance in the Presence of JVMTI Agents

2020-09-11 Thread Richard Reingruber
On Fri, 11 Sep 2020 09:54:50 GMT, Erik Helin wrote: > > > Sorry, now I see. Yes, please remove `, 8233915` from the title! Thanks for helping. The commit message does look better now. - PR: https://git.openjdk.java.net/jdk/pull/119

Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v2]

2020-09-11 Thread Aleksey Shipilev
On Fri, 11 Sep 2020 09:05:53 GMT, Lin Zang wrote: >> Thanks @shipilev, This is shenandoah support based on parallel heap >> inspection enabling in serviceability (tracked with >> https://bugs.openjdk.java.net/browse/JDK-8215624). hope it is helpful for >> your review. > > Hi @shipilev, >

Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v2]

2020-09-11 Thread Lin Zang
> - enable parallel heap inspecton for ShenandoahHeap > - preliminary evaluation: > Time of jmap histo on (8GB heap with 4GB objects) > * before: 5.186s > * after : 1.698s Lin Zang has refreshed the contents of this pull request, and previous commits have been removed. The

Re: RFR: 8252104: parallel heap inspection for ShenandoahHeap [v2]

2020-09-11 Thread Lin Zang
On Wed, 9 Sep 2020 03:00:26 GMT, Lin Zang wrote: >> Thanks, this looks interesting. >> >> I need more time to digest this. It feels like we can merge together the >> parallel (new) and serial (old) heap iteration >> code for better maintainability. I could try to do so later. > > Thanks

Re: RFR: JDK-8247589: Implementation of Alpine Linux/x64 Port [v2]

2020-09-11 Thread Aleksei Voitylov
On Tue, 8 Sep 2020 23:44:58 GMT, David Holmes wrote: >> Aleksei Voitylov has updated the pull request incrementally with one >> additional commit since the last revision: >> >> JDK-8247589: Implementation of Alpine Linux/x64 Port > > make/autoconf/platform.m4 line 536: > >> 534:

Re: RFR: 8252105: parallel heap inspection for ZCollectedHeap [v2]

2020-09-11 Thread Lin Zang
On Thu, 10 Sep 2020 09:57:29 GMT, Lin Zang wrote: >> Just looked at this briefly. My initial comment is that we need to avoid all >> the code duplicated from ZHeapIterator and >> isolate all this a bit better. Perhaps folding everything into one iterator, >> that can be used by both

Re: RFR: 8252999: Cleanup: replace .equals("") with .isEmpty() within all codebase

2020-09-11 Thread Dmitriy Dumanskiy
On Thu, 10 Sep 2020 23:57:38 GMT, Phil Race wrote: >> **isEmpty** is faster + has less byte code + easier to read. Benchmarks >> could be found >> >> [here](https://medium.com/javarevisited/micro-optimizations-in-java-string-equals-22be19fd8416). > > 1) This is un-necessary churn. > 2) I

Re: RFR: JDK-8247589: Implementation of Alpine Linux/x64 Port [v2]

2020-09-11 Thread Aleksei Voitylov
> continuing the review thread from here > https://mail.openjdk.java.net/pipermail/core-libs-dev/2020-September/068546.html > >> The download side of using JNI in these tests is that it complicates the >> setup a bit for those that run jtreg directly and/or just build the JDK >> and not the test