Re: RFR: 8244765: Undo exclusiveAccess.dirs changes for JDK-8220295 and see if there are still any testing issues

2021-12-14 Thread Serguei Spitsyn
On Mon, 13 Dec 2021 21:00:02 GMT, Chris Plummer wrote: > This changes removes (most) Attach API tests from exclusiveAccess.dirs so the > tests can be run in parallel. I haven't seen any issues with this change, > except the jstatd tests can fail due to an RMI issue. I filed > https://bugs.open

Re: RFR: 8278643: CoreUtils.getCoreFileLocation() should print out the size of the core file found

2021-12-14 Thread Serguei Spitsyn
On Tue, 14 Dec 2021 01:14:45 GMT, Chris Plummer wrote: > Include the size of the core file when printing a message that it was found. Marked as reviewed by sspitsyn (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/6822

Re: RFR: 8273904: debug agent ArrayTypeImp::newInstance() fails to send reply packet if there is an error

2021-12-14 Thread Serguei Spitsyn
On Tue, 14 Dec 2021 03:10:00 GMT, Chris Plummer wrote: > ArrayTypeImp::newInstance() was returning false instead of true for one error > condition, resulting in a failure to send a reply packet containing the > error. See the bug description for details. Marked as reviewed by sspitsyn (Reviewe

Re: RFR: 8269838: BasicTypeDataBase.findDynamicTypeForAddress(addr, basetype) can be simplified

2021-12-14 Thread Kevin Walls
On Tue, 14 Dec 2021 06:57:36 GMT, Chris Plummer wrote: > SA had a bunch of vtable related code that searched for the vtable pointer of > a hotspot object in a few places. This was all related to weird ways that > Solaris would store the vtable pointer. In the case of > https://bugs.openjdk.jav

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation

2021-12-14 Thread Coleen Phillimore
On Mon, 13 Dec 2021 23:14:43 GMT, Coleen Phillimore wrote: > This change makes VM_Version_Ext part of VM_Version (the platform dependent > part) and moves some duplicated code. x86 had the most code in > VM_Version_Ext, so the most code moved there. There might be some unneeded > functions bu

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation

2021-12-14 Thread Coleen Phillimore
On Tue, 14 Dec 2021 02:32:54 GMT, David Holmes wrote: >> This change makes VM_Version_Ext part of VM_Version (the platform dependent >> part) and moves some duplicated code. x86 had the most code in >> VM_Version_Ext, so the most code moved there. There might be some unneeded >> functions but

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation [v2]

2021-12-14 Thread Coleen Phillimore
On Tue, 14 Dec 2021 16:24:10 GMT, Coleen Phillimore wrote: >> src/hotspot/os/linux/os_perf_linux.cpp line 929: >> >>> 927: bool CPUInformationInterface::initialize() { >>> 928: _cpu_info = new CPUInformation(); >>> 929: VM_Version::initialize_cpu_information(); >> >> I can't figure out when

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation [v2]

2021-12-14 Thread Coleen Phillimore
> This change makes VM_Version_Ext part of VM_Version (the platform dependent > part) and moves some duplicated code. x86 had the most code in > VM_Version_Ext, so the most code moved there. There might be some unneeded > functions but I didn't want to remove them with this change. > > Tier1 (

Re: RFR: 8273904: debug agent ArrayTypeImp::newInstance() fails to send reply packet if there is an error

2021-12-14 Thread Alex Menkov
On Tue, 14 Dec 2021 03:10:00 GMT, Chris Plummer wrote: > ArrayTypeImp::newInstance() was returning false instead of true for one error > condition, resulting in a failure to send a reply packet containing the > error. See the bug description for details. Marked as reviewed by amenkov (Reviewer

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation [v2]

2021-12-14 Thread Harold Seigel
On Tue, 14 Dec 2021 17:42:00 GMT, Coleen Phillimore wrote: >> This change makes VM_Version_Ext part of VM_Version (the platform dependent >> part) and moves some duplicated code. x86 had the most code in >> VM_Version_Ext, so the most code moved there. There might be some unneeded >> function

Re: RFR: 8269838: BasicTypeDataBase.findDynamicTypeForAddress(addr, basetype) can be simplified

2021-12-14 Thread Serguei Spitsyn
On Tue, 14 Dec 2021 06:57:36 GMT, Chris Plummer wrote: > SA had a bunch of vtable related code that searched for the vtable pointer of > a hotspot object in a few places. This was all related to weird ways that > Solaris would store the vtable pointer. In the case of > https://bugs.openjdk.jav

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation [v2]

2021-12-14 Thread Coleen Phillimore
On Tue, 14 Dec 2021 17:42:00 GMT, Coleen Phillimore wrote: >> This change makes VM_Version_Ext part of VM_Version (the platform dependent >> part) and moves some duplicated code. x86 had the most code in >> VM_Version_Ext, so the most code moved there. There might be some unneeded >> function

Re: RFR: 8202579: Revisit VM_Version and VM_Version_ext for overlap and consolidation [v2]

2021-12-14 Thread David Holmes
On Tue, 14 Dec 2021 17:42:00 GMT, Coleen Phillimore wrote: >> This change makes VM_Version_Ext part of VM_Version (the platform dependent >> part) and moves some duplicated code. x86 had the most code in >> VM_Version_Ext, so the most code moved there. There might be some unneeded >> function

Integrated: 8278643: CoreUtils.getCoreFileLocation() should print out the size of the core file found

2021-12-14 Thread Chris Plummer
On Tue, 14 Dec 2021 01:14:45 GMT, Chris Plummer wrote: > Include the size of the core file when printing a message that it was found. This pull request has now been integrated. Changeset: 54c9a996 Author:Chris Plummer URL: https://git.openjdk.java.net/jdk/commit/54c9a99663c47b047739

Integrated: 8244765: Undo exclusiveAccess.dirs changes for JDK-8220295 and see if there are still any testing issues

2021-12-14 Thread Chris Plummer
On Mon, 13 Dec 2021 21:00:02 GMT, Chris Plummer wrote: > This changes removes (most) Attach API tests from exclusiveAccess.dirs so the > tests can be run in parallel. I haven't seen any issues with this change, > except the jstatd tests can fail due to an RMI issue. I filed > https://bugs.open

Integrated: 8273904: debug agent ArrayTypeImp::newInstance() fails to send reply packet if there is an error

2021-12-14 Thread Chris Plummer
On Tue, 14 Dec 2021 03:10:00 GMT, Chris Plummer wrote: > ArrayTypeImp::newInstance() was returning false instead of true for one error > condition, resulting in a failure to send a reply packet containing the > error. See the bug description for details. This pull request has now been integrat

RFR: 8276982: VM.class_hierarchy jcmd help output and man page text needs clarifications/improvements

2021-12-14 Thread Chris Plummer
Clarify the help output for VM.class_hierarchy. The old jcmd help output was misleading, and because of this got translated incorrectly for the man page. - Commit messages: - Fix VM.class_hierarchy help output and man page. Changes: https://git.openjdk.java.net/jdk/pull/6845/files

Re: RFR: 8276982: VM.class_hierarchy jcmd help output and man page text needs clarifications/improvements

2021-12-14 Thread Thomas Stuefe
On Wed, 15 Dec 2021 03:08:40 GMT, Chris Plummer wrote: > Clarify the help output for VM.class_hierarchy. The old jcmd help output was > misleading, and because of this got translated incorrectly for the man page. Looks good and trivial. Thanks, Thomas - Marked as reviewed by stue

Re: RFR: 8276982: VM.class_hierarchy jcmd help output and man page text needs clarifications/improvements

2021-12-14 Thread David Holmes
On Wed, 15 Dec 2021 03:08:40 GMT, Chris Plummer wrote: > Clarify the help output for VM.class_hierarchy. The old jcmd help output was > misleading, and because of this got translated incorrectly for the man page. LGTM 2. Thanks, David - Marked as reviewed by dholmes (Reviewer).

Re: RFR: 8276982: VM.class_hierarchy jcmd help output and man page text needs clarifications/improvements

2021-12-14 Thread Serguei Spitsyn
On Wed, 15 Dec 2021 03:08:40 GMT, Chris Plummer wrote: > Clarify the help output for VM.class_hierarchy. The old jcmd help output was > misleading, and because of this got translated incorrectly for the man page. Marked as reviewed by sspitsyn (Reviewer). - PR: https://git.openjdk