Re: RFR: 8305085: Remove finalize() from test/hotspot/jtreg/serviceability/jvmti/RedefineClasses/RedefineFinalizer.java

2023-04-12 Thread David Holmes
On Wed, 12 Apr 2023 19:19:01 GMT, Chris Plummer wrote: >> The whole test is removed. > > I'm not sure of the current plan to actually remove finalize() support, but > unless it is going away in 21, it seems this test should remain in place for > now. I agree with @plummercj this is a test of

Re: RFR: 8305083: Remove finalize() from test/hotspot/jtreg/vmTestbase/nsk/share/ and /jpda that are used in serviceability/dcmd/framework tests

2023-04-12 Thread David Holmes
On Wed, 12 Apr 2023 19:16:14 GMT, Chris Plummer wrote: > The interaction of Finalizable, FinalizableObject, Finalizer, and > FinalizerThread is hard to follow, These classes implement a cleanup-at-vm-exit mechanism, which uses `finalize` as the cleanup method. It is unclear if the classes that

Re: RFR: 8299414: JVMTI FollowReferences should support references from VirtualThread stack [v7]

2023-04-12 Thread David Holmes
On Wed, 12 Apr 2023 14:55:59 GMT, Alan Bateman wrote: >> Alex Menkov has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Fixed indent in collect_vthread_stack_roots > > In the spec for FollowReferences, it says that the heap roots include >

Re: RFR: 8305936: JavaThread::create_system_thread_object has unused is_visible argument

2023-04-12 Thread Alan Bateman
On Thu, 13 Apr 2023 05:41:31 GMT, David Holmes wrote: > Please review this simple cleanup of an unused parameter in > `create_system_thread_object`. Details are in JBS. > > Testing: tiers 1-3 > > Thanks. Marked as reviewed by alanb (Reviewer). - PR Review: https://git.openjdk.o

RFR: 8305936: JavaThread::create_system_thread_object has unused is_visible argument

2023-04-12 Thread David Holmes
Please review this simple cleanup of an unused parameter in `create_system_thread_object`. Details are in JBS. Testing: tiers 1-3 Thanks. - Commit messages: - 8305936: JavaThread::create_system_thread_object has unused is_visible argument Changes: https://git.openjdk.org/jdk/pu

RFR: 8305935: Resolve multiple definition of 'jmm_' when statically linking with JDK native libraries

2023-04-12 Thread Jiangli Zhou
Rename 'jmm_' to 'jmm__management_ext' in libmanagement_ext to resolve related linker errors when statically linking with both libmanagement and libmanagement_ext. - Commit messages: - 8305935: Resolve multiple definition of 'jmm_' when statically linking with JDK native libraries

Re: RFR: 8299414: JVMTI FollowReferences should support references from VirtualThread stack [v7]

2023-04-12 Thread Alex Menkov
On Wed, 12 Apr 2023 14:55:59 GMT, Alan Bateman wrote: > In the spec for FollowReferences, it says that the heap roots include > "references from thread stacks". There is a similar sentence in the > deprecated IterateOverReachableObjects function. We should decide whether > these sentences need

Re: RFR: 8305085: Remove finalize() from test/hotspot/jtreg/serviceability/jvmti/RedefineClasses/RedefineFinalizer.java

2023-04-12 Thread Chris Plummer
On Tue, 11 Apr 2023 09:03:49 GMT, Afshin Zafari wrote: > The whole test is removed. I'm not sure of the current plan to actually remove finalize() support, but unless it is going away in 21, it seems this test should remain in place for now. - PR Comment: https://git.openjdk.org

Re: RFR: 8291555: Implement alternative fast-locking scheme [v58]

2023-04-12 Thread Roman Kennke
> This change adds a fast-locking scheme as an alternative to the current > stack-locking implementation. It retains the advantages of stack-locking > (namely fast locking in uncontended code-paths), while avoiding the overload > of the mark word. That overloading causes massive problems with Li

Re: RFR: 8305083: Remove finalize() from test/hotspot/jtreg/vmTestbase/nsk/share/ and /jpda that are used in serviceability/dcmd/framework tests

2023-04-12 Thread Chris Plummer
On Tue, 11 Apr 2023 08:16:29 GMT, Afshin Zafari wrote: > The `finalize()` method is removed from base classes/interfaces and are > replaced by a Cleaner callback.. The interaction of Finalizable, FinalizableObject, Finalizer, and FinalizerThread is hard to follow, so it is hard to tell if your

Re: RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v13]

2023-04-12 Thread Martin Doerr
On Wed, 12 Apr 2023 17:31:49 GMT, Roger Riggs wrote: >> Define an internal jdk.internal.util.Architecture enumeration and static >> methods to replace uses of the system property `os.arch`. >> The enumeration values are defined to match those used in the build. >> The initial values are: `X64, X

Re: RFR: 8298048: Combine CDS archive heap into a single block

2023-04-12 Thread Ioi Lam
On Tue, 11 Apr 2023 21:47:40 GMT, Ashutosh Mehra wrote: > cds changes look good! just few nitpicks. Thanks for the review. I've incorporated your suggestions. - PR Comment: https://git.openjdk.org/jdk/pull/13284#issuecomment-1505698259

Re: RFR: 8298048: Combine CDS archive heap into a single block [v5]

2023-04-12 Thread Ioi Lam
> This PR combines the "open" and "closed" regions of the CDS archive heap into > a single region. This significantly simplifies the implementation, making it > more compatible with non-G1 collectors. There's a net removal of ~1000 lines > in src code and another ~1200 lines of tests. > > **Not

Integrated: 8304834: Fix wrapper insertion in TestScaffold.parseArgs(String args[])

2023-04-12 Thread Leonid Mesnik
On Thu, 23 Mar 2023 21:49:55 GMT, Leonid Mesnik wrote: > The TestScaffold incorrectly parse options, it should insert wrapper class > between VM options and applications classame. This pull request has now been integrated. Changeset: bc151633 Author:Leonid Mesnik URL: https://git.o

Re: RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v12]

2023-04-12 Thread Roger Riggs
On Wed, 12 Apr 2023 09:07:34 GMT, Martin Doerr wrote: >> Roger Riggs has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Correct mapping and test of ppc64 > > Works on PPC64 Big Endian, now. However, little Endian fails: > STARTEDArchTes

Re: RFR: 8298048: Combine CDS archive heap into a single block [v4]

2023-04-12 Thread Ioi Lam
> This PR combines the "open" and "closed" regions of the CDS archive heap into > a single region. This significantly simplifies the implementation, making it > more compatible with non-G1 collectors. There's a net removal of ~1000 lines > in src code and another ~1200 lines of tests. > > **Not

Re: RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v13]

2023-04-12 Thread Roger Riggs
> Define an internal jdk.internal.util.Architecture enumeration and static > methods to replace uses of the system property `os.arch`. > The enumeration values are defined to match those used in the build. > The initial values are: `X64, X86, AARCH64, RISCV64, S390, PPC64` > Note that `amd64` and

Re: RFR: 8299414: JVMTI FollowReferences should support references from VirtualThread stack [v7]

2023-04-12 Thread Alan Bateman
On Wed, 12 Apr 2023 01:12:49 GMT, Alex Menkov wrote: >> The fix updates JVMTI FollowReferences implementation to report references >> from virtual threads: >> - unmounted vthreads are detected and reported as >> JVMTI_HEAP_REFERENCE_THREAD; >> - stack references for unmounted VT are reported as

Re: RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v10]

2023-04-12 Thread Lutz Schmidt
On Wed, 12 Apr 2023 03:44:45 GMT, Amit Kumar wrote: > Another remark: Old JDK on s390 used "os.arch = zArch_64", current one > "os.arch = s390x". @offamitkumar: You probably want to take a look. zArch_64 is not relevant/not used in the OpenJDK port to IBM System z. As noted elsewhere in the PR

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Markus Grönlund
On Wed, 12 Apr 2023 11:01:43 GMT, Serguei Spitsyn wrote: >> Markus Grönlund has updated the pull request incrementally with one >> additional commit since the last revision: >> >> renames > > src/hotspot/share/prims/jvmtiAgent.cpp line 357: > >> 355: vm_exit_during_initialization("Coul

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Markus Grönlund
On Tue, 4 Apr 2023 14:39:19 GMT, Markus Grönlund wrote: >> Greetings, >> >> We are adding support to let JFR report on Agents. >> >> Design >> >> An Agent is a library that uses any instrumentation or profiling APIs. Most >> agents are started and initialized on the command line, but age

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Serguei Spitsyn
On Tue, 4 Apr 2023 14:39:19 GMT, Markus Grönlund wrote: >> Greetings, >> >> We are adding support to let JFR report on Agents. >> >> Design >> >> An Agent is a library that uses any instrumentation or profiling APIs. Most >> agents are started and initialized on the command line, but age

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Markus Grönlund
On Wed, 12 Apr 2023 10:31:37 GMT, Serguei Spitsyn wrote: >> Markus Grönlund has updated the pull request incrementally with one >> additional commit since the last revision: >> >> renames > > src/hotspot/share/prims/jvmtiAgent.cpp line 323: > >> 321: assert(agent != nullptr, "invariant");

Re: RFR: 8291555: Implement alternative fast-locking scheme [v57]

2023-04-12 Thread Roman Kennke
> This change adds a fast-locking scheme as an alternative to the current > stack-locking implementation. It retains the advantages of stack-locking > (namely fast locking in uncontended code-paths), while avoiding the overload > of the mark word. That overloading causes massive problems with Li

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Serguei Spitsyn
On Tue, 4 Apr 2023 14:39:19 GMT, Markus Grönlund wrote: >> Greetings, >> >> We are adding support to let JFR report on Agents. >> >> Design >> >> An Agent is a library that uses any instrumentation or profiling APIs. Most >> agents are started and initialized on the command line, but age

Re: RFR: 8257967: JFR: Events for loaded agents [v16]

2023-04-12 Thread Serguei Spitsyn
On Tue, 4 Apr 2023 14:39:19 GMT, Markus Grönlund wrote: >> Greetings, >> >> We are adding support to let JFR report on Agents. >> >> Design >> >> An Agent is a library that uses any instrumentation or profiling APIs. Most >> agents are started and initialized on the command line, but age

RFR: 8305085: Remove finalize() from test/hotspot/jtreg/serviceability/jvmti/RedefineClasses/RedefineFinalizer.java

2023-04-12 Thread Afshin Zafari
The whole test is removed. - Commit messages: - 8305085: Remove finalize() from test/hotspot/jtreg/serviceability/jvmti/RedefineClasses/RedefineFinalizer.java Changes: https://git.openjdk.org/jdk/pull/13422/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=13422&range=00 I

RFR: 8305083: Remove finalize() from test/hotspot/jtreg/vmTestbase/nsk/share/ and /jpda that are used in serviceability/dcmd/framework tests

2023-04-12 Thread Afshin Zafari
The `finalize()` method is removed from base classes/interfaces and are replaced by a Cleaner callback.. - Commit messages: - 8305083: Remove finalize() from test/hotspot/jtreg/vmTestbase/nsk/share/ and /jpda that are used in serviceability/dcmd/framework tests Changes: https://gi

Re: RFR: 8304915: Create jdk.internal.util.Architecture enum and apply [v12]

2023-04-12 Thread Martin Doerr
On Tue, 11 Apr 2023 21:09:43 GMT, Roger Riggs wrote: >> Define an internal jdk.internal.util.Architecture enumeration and static >> methods to replace uses of the system property `os.arch`. >> The enumeration values are defined to match those used in the build. >> The initial values are: `X64, X

Re: RFR: 8305084: Remove the removal warnings for finalize() from test/hotspot/jtreg/serviceability/dcmd/gc/FinalizerInfoTest.java and RunFinalizationTest.java [v2]

2023-04-12 Thread Afshin Zafari
On Tue, 11 Apr 2023 12:07:32 GMT, Afshin Zafari wrote: >> The `removal` warnings are suppressed out. >> Test: >> `FinalizerInfoTest` and `RunFinalizationTest` are executed locally. > > Afshin Zafari has updated the pull request incrementally with one additional > commit since the last revision:

Re: RFR: 8291555: Implement alternative fast-locking scheme [v56]

2023-04-12 Thread Milind Mantri
On Thu, 6 Apr 2023 11:59:45 GMT, Roman Kennke wrote: >> This change adds a fast-locking scheme as an alternative to the current >> stack-locking implementation. It retains the advantages of stack-locking >> (namely fast locking in uncontended code-paths), while avoiding the overload >> of the

Re: RFR: 8305341: Alignment should be enforced by alignas instead of compiler specific attributes [v4]

2023-04-12 Thread Julian Waters
On Wed, 12 Apr 2023 07:12:10 GMT, Julian Waters wrote: >> C11 has been stable for a long time on all platforms, so native code can use >> the standard alignas operator for alignment requirements > > Julian Waters has updated the pull request incrementally with four additional > commits since th

Re: RFR: 8305341: Alignment should be enforced by alignas instead of compiler specific attributes [v4]

2023-04-12 Thread Julian Waters
> C11 has been stable for a long time on all platforms, so native code can use > the standard alignas operator for alignment requirements Julian Waters has updated the pull request incrementally with four additional commits since the last revision: - Restore visCPP - Restore gcc attribute -