On Fri, 14 Apr 2023 19:23:05 GMT, Kevin Walls wrote:
> This test is failing often since 8304725 added a call to
> Thread::current_in_asgct(). This can end up being called e.g. when resolving
> calls, and then the OS last error value is lost.
>
> The test is reliable with a single warm-up call
On Fri, 14 Apr 2023 13:27:37 GMT, Fredrik Bredberg wrote:
> Added the missing java.lang.Thread.beforeSleep and java.lang.afterSleep to
> expectedSystemTrace.
> Tested on my local machine.
This change is not sufficient. You also have:
# ERROR: Length of the stack trace is 206, but expected to b
On Tue, 10 Jan 2023 20:55:12 GMT, Justin King wrote:
> Remove abstraction that is a holdover from Solaris. Direct usages of
> `MmapArrayAllocator` have been switched to normal `malloc`. The justification
> is that none of the code paths are called from signal handlers, so using
> `mmap` direct
> This refactoring to separate ThreadStart/ThreadEnd events posting code in the
> JVMTI VTMS transitions is needed for future work on JVMTI scalability and
> performance improvements. It is to easier put this code on slow path.
>
> Testing: mach5 tiers 1-6 were successful.
Serguei Spitsyn has u
On Fri, 14 Apr 2023 09:20:18 GMT, Markus Grönlund wrote:
>> src/hotspot/share/prims/jvmtiExport.cpp line 717:
>>
>>> 715: jvmtiEventVMInit callback = env->callbacks()->VMInit;
>>> 716: if (callback != nullptr) {
>>> 717: JvmtiAgent* const agent = lookup_uninitialized_agent(en
This refactoring to separate ThreadStart/ThreadEnd events posting code in the
JVMTI VTMS transitions is needed for future work on JVMTI scalability and
performance improvements. It is to easier put this code on slow path.
Testing: mach5 tiers 1-6 were successful.
-
Commit messages:
On Fri, 14 Apr 2023 21:20:46 GMT, Chris Plummer wrote:
> I guess I don't understand the purpose of having this test if it is just
> going to work around the underlying issue it is suppose to be testing for.
> Does it serve a purpose still? Does it still correctly detect the fix that
> was done
On Fri, 14 Apr 2023 17:08:10 GMT, Erik Joelsson wrote:
>> make/modules/java.base/gensrc/GensrcMisc.gmk line 72:
>>
>>> 70: endif
>>> 71:
>>> 72: $(eval $(call SetupTextFileProcessing, BUILD_PLATFORMPROPERTIES_JAVA, \
>>
>> @erikj79 Is there a better/good way to do these mappings, or select "lo
On Fri, 14 Apr 2023 19:23:05 GMT, Kevin Walls wrote:
> This test is failing often since 8304725 added a call to
> Thread::current_in_asgct(). This can end up being called e.g. when resolving
> calls, and then the OS last error value is lost.
>
> The test is reliable with a single warm-up call
On Wed, 12 Apr 2023 23:35:02 GMT, Jiangli Zhou wrote:
> Rename 'jmm_' to 'jmm__management_ext'
> in libmanagement_ext to resolve related linker errors when statically linking
> with both libmanagement and libmanagement_ext.
This pull request has now been integrated.
Changeset: 314bad36
Author
On Fri, 14 Apr 2023 19:23:05 GMT, Kevin Walls wrote:
> This test is failing often since 8304725 added a call to
> Thread::current_in_asgct(). This can end up being called e.g. when resolving
> calls, and then the OS last error value is lost.
>
> The test is reliable with a single warm-up call
This test is failing often since 8304725 added a call to
Thread::current_in_asgct(). This can end up being called e.g. when resolving
calls, and then the OS last error value is lost.
The test is reliable with a single warm-up call to getLastError.invoke() before
the loop.
The test was introdu
On Tue, 11 Apr 2023 09:03:49 GMT, Afshin Zafari wrote:
> The warning message is suppressed out.
This pull request has now been integrated.
Changeset: 2cc4bf1a
Author:Afshin Zafari
Committer: Chris Plummer
URL:
https://git.openjdk.org/jdk/commit/2cc4bf1a9d00dc24ec150e0e39bfdd374eb6e
On Fri, 14 Apr 2023 05:20:48 GMT, David Holmes wrote:
>> src/jdk.management/share/native/libmanagement_ext/management_ext.c line 34:
>>
>>> 32: #define ERR_MSG_SIZE 128
>>> 33:
>>> 34: const JmmInterface* jmm_interface_management_ext = NULL;
>>
>> Can you add a comment before declaring the two
On Wed, 12 Apr 2023 23:35:02 GMT, Jiangli Zhou wrote:
> Rename 'jmm_' to 'jmm__management_ext'
> in libmanagement_ext to resolve related linker errors when statically linking
> with both libmanagement and libmanagement_ext.
Thanks for the review and discussion.
-
PR Comment: http
> Rename 'jmm_' to 'jmm__management_ext'
> in libmanagement_ext to resolve related linker errors when statically linking
> with both libmanagement and libmanagement_ext.
Jiangli Zhou has updated the pull request incrementally with one additional
commit since the last revision:
Add comment su
On Fri, 14 Apr 2023 14:31:31 GMT, Roger Riggs wrote:
>> Roger Riggs has updated the pull request incrementally with one additional
>> commit since the last revision:
>>
>> Fixed isPPC64().
>> Consolidated switch cases in ArchTest.
>> Moved mapping of build TARGET_OS and TARGET_CPU to the
On Fri, 14 Apr 2023 07:50:39 GMT, Serguei Spitsyn wrote:
> Markus, It looks good to me. Overall, it is a nice consolidation of the agent
> code, good move in general! Thank you for your patience. I've posted one
> minor request though. Thanks, Serguei
Thanks for taking a look Serguei, apprecia
On Wed, 12 Apr 2023 17:31:49 GMT, Roger Riggs wrote:
>> Define an internal jdk.internal.util.Architecture enumeration and static
>> methods to replace uses of the system property `os.arch`.
>> The enumeration values are defined to match those used in the build.
>> The initial values are: `X64, X
On Fri, 14 Apr 2023 13:27:37 GMT, Fredrik Bredberg wrote:
> Added the missing java.lang.Thread.beforeSleep and java.lang.afterSleep to
> expectedSystemTrace.
> Tested on my local machine.
Looks good. Apologies we missed this test when updating j.l.Thread, I'm quite
sure I didn't see this test
On Fri, 14 Apr 2023 13:27:37 GMT, Fredrik Bredberg wrote:
> Added the missing java.lang.Thread.beforeSleep and java.lang.afterSleep to
> expectedSystemTrace.
> Tested on my local machine.
Marked as reviewed by rehn (Reviewer).
Looks good to me!
-
PR Review: https://git.openjdk.or
Added the missing java.lang.Thread.beforeSleep and java.lang.afterSleep to
expectedSystemTrace.
Tested on my local machine.
-
Commit messages:
- 8306006: strace001.java fails due to unknown methods on stack
Changes: https://git.openjdk.org/jdk/pull/13476/files
Webrev: https://webr
> This change adds a fast-locking scheme as an alternative to the current
> stack-locking implementation. It retains the advantages of stack-locking
> (namely fast locking in uncontended code-paths), while avoiding the overload
> of the mark word. That overloading causes massive problems with Li
On Fri, 14 Apr 2023 07:43:23 GMT, Serguei Spitsyn wrote:
>> Markus Grönlund has updated the pull request incrementally with one
>> additional commit since the last revision:
>>
>> line breaks
>
> src/hotspot/share/prims/jvmtiExport.cpp line 717:
>
>> 715: jvmtiEventVMInit callback = en
On Thu, 13 Apr 2023 12:16:16 GMT, Markus Grönlund wrote:
>> Greetings,
>>
>> We are adding support to let JFR report on Agents.
>>
>> Design
>>
>> An Agent is a library that uses any instrumentation or profiling APIs. Most
>> agents are started and initialized on the command line, but ag
On Thu, 13 Apr 2023 12:16:16 GMT, Markus Grönlund wrote:
>> Greetings,
>>
>> We are adding support to let JFR report on Agents.
>>
>> Design
>>
>> An Agent is a library that uses any instrumentation or profiling APIs. Most
>> agents are started and initialized on the command line, but ag
On Thu, 13 Apr 2023 11:31:05 GMT, Afshin Zafari wrote:
>> The warning message is suppressed out.
>
> Afshin Zafari has updated the pull request incrementally with one additional
> commit since the last revision:
>
> 8305085: Remove finalize() from
> test/hotspot/jtreg/serviceability/jvmti/R
On Thu, 13 Apr 2023 12:16:16 GMT, Markus Grönlund wrote:
>> Greetings,
>>
>> We are adding support to let JFR report on Agents.
>>
>> Design
>>
>> An Agent is a library that uses any instrumentation or profiling APIs. Most
>> agents are started and initialized on the command line, but ag
On Thu, 13 Apr 2023 18:28:27 GMT, Chris Plummer wrote:
> > The whole test is removed.
>
> I just noticed that the PR description also needs to be updated.
Thanks for your comment. It is updated.
-
PR Comment: https://git.openjdk.org/jdk/pull/13422#issuecomment-1508061117
29 matches
Mail list logo