Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-10 Thread Albert Mingkun Yang
> It's probably easier to read the new code directly. The two classes in > `serialVMOperations` serve as entrance points to invoke young/full GCs. Some > previously hidden decisions are made more obvious, e.g. if a young-gc fails > (or will probablly fail), fallback to full-gc. > > Additionally

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-16 Thread Ivan Walulya
On Fri, 10 May 2024 08:55:36 GMT, Albert Mingkun Yang wrote: >> It's probably easier to read the new code directly. The two classes in >> `serialVMOperations` serve as entrance points to invoke young/full GCs. Some >> previously hidden decisions are made more obvious, e.g. if a young-gc fails

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Albert Mingkun Yang
On Fri, 17 May 2024 06:02:31 GMT, Ivan Walulya wrote: >> Albert Mingkun Yang has updated the pull request with a new target base due >> to a merge or a rebase. The pull request now contains seven commits: >> >> - Merge branch 'master' into s1-do-collect >> - review >> - Merge branch 'master'

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Ivan Walulya
On Fri, 17 May 2024 07:17:13 GMT, Albert Mingkun Yang wrote: >> src/hotspot/share/gc/serial/serialHeap.cpp line 907: >> >>> 905: >>> 906: void SerialHeap::print_tracing_info() const { >>> 907: // Nothing >> >> What is the `Nothing` supposed to convey here? > > To emphasize that this empty met

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Albert Mingkun Yang
On Fri, 17 May 2024 07:22:36 GMT, Ivan Walulya wrote: >> How about calling them `try_x` and `x` for the public and private API, >> respectively, e.g. `try_do_full_collection` and `do_full_collection`? > > I prefer that to the "no_gc_locker" emphasizing names I can do that for `try_collect_at_sa

Re: RFR: 8331557: Serial: Refactor SerialHeap::do_collection [v6]

2024-05-17 Thread Ivan Walulya
On Fri, 17 May 2024 07:39:39 GMT, Albert Mingkun Yang wrote: >> I prefer that to the "no_gc_locker" emphasizing names > > I can do that for `try_collect_at_safepoint`, but > `SerialHeap::do_full_collection` is an API from `CollectedHeap`. yeah, i only meant change those that are not "override"