Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-26 Thread Brent Royal-Gordon via swift-evolution
> On Jul 25, 2016, at 1:11 PM, Dave Abrahams via swift-evolution > wrote: > > I'm giving the overall idea a +0 and the specific proposal as currently > written a -1, because I think this is a much more complicated bikeshed > than it appears to be on the surface and the proposal doesn't begin to

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Dave Abrahams via swift-evolution
on Mon Jul 25 2016, Jacob Bandes-Storch wrote: > On Mon, Jul 25, 2016 at 1:11 PM, Dave Abrahams via swift-evolution < > swift-evolution@swift.org> wrote: > >> >> I'm giving the overall idea a +0 and the specific proposal as currently >> written a -1, because I think this is a much more complicat

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Jacob Bandes-Storch via swift-evolution
On Mon, Jul 25, 2016 at 2:09 PM, David Rönnqvist wrote: > > Haskell calls the general *m (m a) -> m a* function for "join", but also > has a specialized *[[a]] -> [a]* function called "concat". (The function > corresponding to "flatMap" is called "bind" in Haskell (although used as an > operator),

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread David Rönnqvist via swift-evolution
>* What is your evaluation of the proposal? -1. I think that there might be something to this idea, but am against the proposal in its current form for the same reasons that have already been stated: flatten has a broader use than just joining sequences/collections, and flatten as a name is

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Jacob Bandes-Storch via swift-evolution
On Mon, Jul 25, 2016 at 1:11 PM, Dave Abrahams via swift-evolution < swift-evolution@swift.org> wrote: > > I'm giving the overall idea a +0 and the specific proposal as currently > written a -1, because I think this is a much more complicated bikeshed > than it appears to be on the surface and the

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Dave Abrahams via swift-evolution
on Sun Jul 24 2016, Chris Lattner wrote: > Hello Swift community, > > The review of "SE-0133: Rename `flatten()` to `joined()`" begins now > and runs through July 26. Apologies for the short review cycle, but > we’re right up against the end of source breaking changes for Swift 3. > The proposa

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Daniel Duan via swift-evolution
> On Jul 24, 2016, at 11:10 PM, Chris Lattner via swift-evolution > wrote: > > * What is your evaluation of the proposal? -1. I find the motivation section troubling. It’s simply an assertion that this “should” happen. From reading the rest of the proposed text as well as others review

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Yuta Koshizawa via swift-evolution
> What is your evaluation of the proposal? -1 - Certainly `flatten` and `joined` work similarly. I think, however, the concepts behind them are different. When I use `flatten`, I want to make nested monads flat. When I use `joined`, I want to concatenate sequences, mainly `String`s, with a separa

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Jose Cheyo Jimenez via swift-evolution
> On Jul 24, 2016, at 11:10 PM, Chris Lattner via swift-evolution > wrote: > > Hello Swift community, > > The review of "SE-0133: Rename `flatten()` to `joined()`" begins now and runs > through July 26. Apologies for the short review cycle, but we’re right up > against the end of source br

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread David Hart via swift-evolution
> * What is your evaluation of the proposal? +1 This makes total sense. I was going to voice my disagreement until I saw that I did not understand what the APIs did because of their names :D The renaming makes things much clearer. > * Is the problem being addressed significant enou

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Pyry Jahkola via swift-evolution
> On 25 Jul 2016, at 09:10, Chris Lattner via swift-evolution > wrote: > > The review of "SE-0133: Rename `flatten()` to `joined()`" begins now and runs > through July 26. Apologies for the short review cycle, but we’re right up > against the end of source breaking changes for Swift 3. The

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Rod Brown via swift-evolution
* What is your evaluation of the proposal? +1. It's consistent with the new language guidelines, and though 'flatten' seemed a term-of-art there are multiple arguments here that would clear up things, like the string combination. * Is the problem being addressed significant enough to warra

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Jacob Bandes-Storch via swift-evolution
I wasn't explicit about that in the proposal, but I was intending that these should be renamed too. There's a minor snag: JoinedSequence already exists. I haven't taken a close look at both implementations yet, but it's possible we could just combine them. On Mon, Jul 25, 2016 at 12:46 AM, Charlie

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-25 Thread Charlie Monroe via swift-evolution
Shouldn't the proposal also mention renaming FlattenCollection, FlattenBidirectionalCollection and FlattenSequence to Joined*(Collection|Sequence)? Or are these going to keep their name? > On Jul 25, 2016, at 8:10 AM, Chris Lattner via swift-evolution > wrote: > > Hello Swift community, > >

Re: [swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-24 Thread Xiaodi Wu via swift-evolution
On Mon, Jul 25, 2016 at 1:10 AM, Chris Lattner via swift-evolution < swift-evolution@swift.org> wrote: > Hello Swift community, > > The review of "SE-0133: Rename `flatten()` to `joined()`" begins now and > runs through July 26. Apologies for the short review cycle, but we’re > right up against t

[swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`

2016-07-24 Thread Chris Lattner via swift-evolution
Hello Swift community, The review of "SE-0133: Rename `flatten()` to `joined()`" begins now and runs through July 26. Apologies for the short review cycle, but we’re right up against the end of source breaking changes for Swift 3. The proposal is available here: https://github.com/a