this uses the refcnt api to do the heavy lifting.
i think we have all the if_get/if_put calls we need, so this should
be safe at this point.
if anyone wants to test, can you try detaching or destroying
interfaces and check that the ifconfig call that does it doesnt end
up blocking forever?
ok?
> On 18 Sep 2015, at 10:10 pm, Stuart Henderson wrote:
>
> On 2015/09/18 13:36, Martin Pieuchot wrote:
>> On 18/09/15(Fri) 15:55, David Gwynne wrote:
>>> hashing bits of packet headers to tie connections to particular
>>> physical interfaces within a trunk turns out to be fairly expensive.
>>> i
> On 25 Sep 2015, at 7:38 pm, Martin Pieuchot wrote:
>
> As discussed in Calgary I don't think we need 6 different files for
> gif(4). None of them are standalone. Since all our other pseudo-
> drivers are self-contained, let's do the same! This will prevent
> new pseud-drivers to copy this p
On Fri, Jul 17, 2015 at 03:24:17PM -0300, Rafael Zalamena wrote:
> This diff adds support for detection of pseudowires inside of MPLS tagged
> packets. Basically it teaches MPLS to look for ethernet headers when there
> is no sign of IP headers.
>
> --- SNIPPED OLD DIFF ---
This is an updated dif
On Sat, Sep 26, 2015 at 09:58:59PM +0200, Stefan Sperling wrote:
> On Sat, Sep 26, 2015 at 03:51:25PM -0400, Michael McConville wrote:
> > Stefan Sperling wrote:
> > > On Sat, Sep 26, 2015 at 03:29:07PM -0400, Michael McConville wrote:
> > > > I see some preproc conditions in usr.sbin/snmpctl/snmpc
On Fri, Sep 25, 2015 at 02:23:21PM -0400, Michael Reed wrote:
> Hi Fritjof,
>
Hi Michael,
> I left one comment inline.
>
thanks.
> On 09/25/15 08:18, Fritjof Bornebusch wrote:
> > Hi,
> >
> > change atoi(3) -> strtonum(3) in lpr(1) and lprm(1).
> > lprm(1) avoids negative numbers to be the f
On Sat, Sep 26, 2015 at 03:51:25PM -0400, Michael McConville wrote:
> Stefan Sperling wrote:
> > On Sat, Sep 26, 2015 at 03:29:07PM -0400, Michael McConville wrote:
> > > I see some preproc conditions in usr.sbin/snmpctl/snmpclient.c. I
> > > only bothered to check the first two. Are you sure they
Stefan Sperling wrote:
> On Sat, Sep 26, 2015 at 03:29:07PM -0400, Michael McConville wrote:
> > I see some preproc conditions in usr.sbin/snmpctl/snmpclient.c. I
> > only bothered to check the first two. Are you sure they still
> > compile in all circumstances? If I understand correctly, compiling
On Sat, Sep 26, 2015 at 03:29:07PM -0400, Michael McConville wrote:
> I see some preproc conditions in usr.sbin/snmpctl/snmpclient.c. I only
> bothered to check the first two. Are you sure they still compile in all
> circumstances? If I understand correctly, compiling without warning only
> implies
Stefan Sperling wrote:
> I was looking for ifmedia bits to fix in here, but found nothing
> except a few unused if_media.h includes.
>
> Turns out snmpd compiles (on i386) without warnings with a lot
> less headers included.
>
> Is this a safe change?
>
> I've left sys/types.h alone since I gues
I was looking for ifmedia bits to fix in here, but found nothing
except a few unused if_media.h includes.
Turns out snmpd compiles (on i386) without warnings with a lot
less headers included.
Is this a safe change?
I've left sys/types.h alone since I guess removing it might
break builds using ol
The `clean' target takes optional arguments, so denote that in
the item header. Additionally, the subtargets are fixed strings,
not variables, so change the use of Va to Cm to reflect that.
Index: bsd.port.mk.5
===
RCS file: /cvs/sr
As done for bgpd recently, rename media_type to if_type.
Rationale: if_type values come from the IFT_ namespace in if_types.h,
not from the IFM_ namespace in if_media.h. This change prevents
confusion between uint8_t interface types and uint64_t media types.
Some ifmedia64 fixes here as well.
In
As done for bgpd recently, rename media_type to if_type.
Rationale: if_type values come from the IFT_ namespace in if_types.h,
not from the IFM_ namespace in if_media.h. This change prevents
confusion between uint8_t interface types and uint64_t media types.
This touches OSPF for IPv4 and for IPv
As done for bgpd recently, rename media_type to if_type.
Rationale: if_type values come from the IFT_ namespace in if_types.h,
not from the IFM_ namespace in if_media.h. This change prevents
confusion between uint8_t interface types and uint64_t media types.
In this daemon, confusion has already
As done for bgpd recently, rename if_mediatype to if_type.
Rationale: if_type values come from the IFT_ namespace in if_types.h,
not from the IFM_ namespace from if_media.h. This change prevents
confusion between uint8_t interface types and uint64_t media types.
Remove get_ifms_type() from dvmrpc
On Sat, Sep 26, 2015 at 11:42:11AM +0100, Raf Czlonka wrote:
> On Sat, Sep 26, 2015 at 09:52:39AM BST, Stuart Henderson wrote:
> > On 2015/09/26 07:44, Raf Czlonka wrote:
> > > On Fri, Sep 25, 2015 at 10:14:03PM BST, Rob Pierce wrote:
> > >
> > > > Update diff below referencing the correct man pag
On 09/25/15 12:57, Kevin Zhang wrote:
> Using >, & in raw text is invalid HTML.
Not according to validator.w3.org.
And unless you can point to an actual PROBLEM...this makes the page a
lot more of a pain to maintain.
There was an actual validation problem, which you prompted me to test
for and, s
On 2015-09-24 08:11, Jason McIntyre wrote:
> On Wed, Sep 23, 2015 at 07:42:54PM -0400, Michael Reed wrote:
>> banner(1) without arguments works fine, so denote it as such
>> in the manual.
>>
>
> in the context of banner(1), define "works fine". i mean, technically
> maybe it does but, practically
Hi,
Stuart Henderson wrote on Sat, Sep 26, 2015 at 10:14:46AM +0100:
> On 2015/09/25 21:12, Michael Reed wrote:
>> Sentences should start on a new line; not sure if it makes a
>> difference in mandoc's output, but it's done in the vast majority
>> of manuals (perhaps a stylistic choice).
Right n
Hi,
please find below a diff which adds a new driver called asmc(4) for the
Apple System Management Controller (SMC), as found in Intel based Apple
devices.
A similar driver is available in Linux[1], FreeBSD[2], and NetBSD[3].
The diff below was motivated by an earlier attempt[4] of Volker Nowarr
- Original Message -
> From: "Raf Czlonka"
> To: "tech"
> Sent: Saturday, September 26, 2015 6:42:11 AM
> Subject: Re: update: afterboot.8 to reference ntpd(8) by default
> On Sat, Sep 26, 2015 at 09:52:39AM BST, Stuart Henderson wrote:
>> On 2015/09/26 07:44, Raf Czlonka wrote:
>> > On
On Sat, Sep 26, 2015 at 09:52:39AM BST, Stuart Henderson wrote:
> On 2015/09/26 07:44, Raf Czlonka wrote:
> > On Fri, Sep 25, 2015 at 10:14:03PM BST, Rob Pierce wrote:
> >
> > > Update diff below referencing the correct man page sections and with
> > > sentenced
> > > starting on a new line.
> >
On 2015/09/25 21:12, Michael Reed wrote:
> Sentences should start on a new line; not sure if it makes a difference in
> mandoc's output, but it's done in the vast majority of manuals (perhaps a
> stylistic choice).
It doesn't make a difference in output, but it reduces the amount of
reformatting d
On 2015/09/25 19:34, Michael McConville wrote:
> Assuming that what's described applies to the most recent releases. You
> could also argue that this disclaimer is old enough to be deleted.
Thanks - I've deleted it.
On 2015/09/26 07:44, Raf Czlonka wrote:
> On Fri, Sep 25, 2015 at 10:14:03PM BST, Rob Pierce wrote:
>
> > Update diff below referencing the correct man page sections and with
> > sentenced
> > starting on a new line.
>
> Hi Rob,
>
> > Index: afterboot.8
> > =
26 matches
Mail list logo