Re: Set prio when bypassing pf(4)

2016-06-08 Thread Martin Pieuchot
On 08/06/16(Wed) 21:18, Vincent Gross wrote: > On Wed, 8 Jun 2016 15:12:23 +0200 > Martin Pieuchot wrote: > > > On 07/06/16(Tue) 22:02, Stuart Henderson wrote: > > > On 2016/06/07 21:49, Vincent Gross wrote: > > > > > > > > It's how henning@ set things up when integrating

Re: No need to second guess SXIE_ROUNDUP

2016-06-08 Thread Artturi Alm
On Thu, Jun 09, 2016 at 12:04:02AM +0100, Tom Cosgrove wrote: > If (pktlen & 3) == 0, SXIE_ROUNDUP returns pktlen anyway (that's its job): > it's defined as > > #define SXIE_ROUNDUP(size, unit) (((size) + (unit) - 1) & ~((unit) - 1)) > > Thanks > > Tom > Hi, starting w/bikeshed i'd go

Re: No need to second guess SXIE_ROUNDUP

2016-06-08 Thread David Gwynne
why not roundup() from src/sys/sys/param.h? > On 9 Jun 2016, at 09:04, Tom Cosgrove > wrote: > > If (pktlen & 3) == 0, SXIE_ROUNDUP returns pktlen anyway (that's its job): > it's defined as > >#define SXIE_ROUNDUP(size, unit) (((size) + (unit) - 1) &

No need to second guess SXIE_ROUNDUP

2016-06-08 Thread Tom Cosgrove
If (pktlen & 3) == 0, SXIE_ROUNDUP returns pktlen anyway (that's its job): it's defined as #define SXIE_ROUNDUP(size, unit) (((size) + (unit) - 1) & ~((unit) - 1)) Thanks Tom Index: sys/arch/armv7/sunxi/sxie.c === RCS file:

Re: sqlite3 update

2016-06-08 Thread James Turner
On Wed, Jun 08, 2016 at 11:33:42PM +0100, Stuart Henderson wrote: > On 2016/06/03 20:17, James Turner wrote: > > On Fri, Jun 03, 2016 at 11:24:15PM +0100, Stuart Henderson wrote: > > > On 2016/06/01 11:22, Stuart Henderson wrote: > > > > On 2016/06/01 09:09, Landry Breuil wrote: > > > > > And most

Re: sqlite3 update

2016-06-08 Thread Stuart Henderson
On 2016/06/03 20:17, James Turner wrote: > On Fri, Jun 03, 2016 at 11:24:15PM +0100, Stuart Henderson wrote: > > On 2016/06/01 11:22, Stuart Henderson wrote: > > > On 2016/06/01 09:09, Landry Breuil wrote: > > > > And most importantly, 47 (released next week) requires 3.11. > > > >

Re: `rt_addr' or the end of `rt_ifa'

2016-06-08 Thread Stuart Henderson
On 2016/06/08 16:23, Martin Pieuchot wrote: > Being able to remove the requirement of an configured address for every > route entry would have multiple benefit: > > . We could add route before the interface gets an address (useful in > some p2p configurations) > . The kernel wouldn't have

Re: Set prio when bypassing pf(4)

2016-06-08 Thread Mike Belopuhov
On Mon, Jun 06, 2016 at 23:52 +0200, Vincent Gross wrote: > On Mon, 6 Jun 2016 17:33:36 +0100 > Stuart Henderson wrote: > > > On 2016/06/06 16:15, Vincent Gross wrote: > > > When sending ARP requests, or when writing to a bpf handle (as when > > > sending DHCP Discover), we

Re: Set prio when bypassing pf(4)

2016-06-08 Thread Mike Belopuhov
On Tue, Jun 07, 2016 at 22:02 +0100, Stuart Henderson wrote: > On 2016/06/07 21:49, Vincent Gross wrote: > > > > It's how henning@ set things up when integrating the new queuing mechanism. > > http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sys/kern/uipc_mbuf.c#rev1.160 > > > > > Is there any use

Uninitialised variable in sys/arch/armv7/exynos/crosec.c

2016-06-08 Thread Tom Cosgrove
Hi I can't test this :) but it might bite someone who was trying to hack in this area. Thanks Tom Index: sys/arch/armv7/exynos/crosec.c === RCS file: /home/OpenBSD/cvs/src/sys/arch/armv7/exynos/crosec.c,v retrieving revision 1.1

Re: lockmgr() api removal

2016-06-08 Thread Christian Weisgerber
On 2016-06-08, Stuart Henderson wrote: > That's still testing server side for the contents of the ports tree, > isn't it? Not as heavily stressed as putting it on the server would > be, but it still gives it a bit of a workout. I have now put the patch on the central

Re: Set prio when bypassing pf(4)

2016-06-08 Thread Vincent Gross
On Wed, 8 Jun 2016 15:12:23 +0200 Martin Pieuchot wrote: > On 07/06/16(Tue) 22:02, Stuart Henderson wrote: > > On 2016/06/07 21:49, Vincent Gross wrote: > > > > > > It's how henning@ set things up when integrating the new queuing > > > mechanism. > > >

Re: using srp inside art

2016-06-08 Thread Sebastian Benoit
Martin Pieuchot(m...@openbsd.org) on 2016.06.08 20:50:29 +0200: > On 08/06/16(Wed) 19:51, Sebastian Benoit wrote: > > [...] > > i dont see why this would be a problem > > > > however: > > > > + ... if we were going to use > > +* the last available route, but it got

Re: using srp inside art

2016-06-08 Thread Martin Pieuchot
On 08/06/16(Wed) 19:51, Sebastian Benoit wrote: > [...] > i dont see why this would be a problem > > however: > > + ... if we were going to use > +* the last available route, but it got removed, we'll hit > +* the end of the list and then pick the

Re: using srp inside art

2016-06-08 Thread Sebastian Benoit
Jonathan Matthew(jonat...@d14n.org) on 2016.06.06 17:14:53 +1000: > We've finally got srp and art to the point where we can use srp to manage the > internal links in the art data structures. This allows us to do route lookups > without holding any locks, which is kind of nice. > > As we're not

Re: lockmgr() api removal

2016-06-08 Thread Stuart Henderson
On 2016/06/08 14:48, Christian Weisgerber wrote: > On 2016-06-07, Theo de Raadt wrote: > > > Did I miss a report about nfs server and client? I know I have not tested > > this diff. > > I put it on the amd64 package building machines and ran two bulk > builds with it.

Re: lockmgr() api removal

2016-06-08 Thread Christian Weisgerber
On 2016-06-07, Theo de Raadt wrote: > Did I miss a report about nfs server and client? I know I have not tested > this diff. I put it on the amd64 package building machines and ran two bulk builds with it. That qualifies as a successful client test. I haven't gotten

`rt_addr' or the end of `rt_ifa'

2016-06-08 Thread Martin Pieuchot
Being able to remove the requirement of an configured address for every route entry would have multiple benefit: . We could add route before the interface gets an address (useful in some p2p configurations) . The kernel wouldn't have to manage stale ifas . The network data structures

Re: Set prio when bypassing pf(4)

2016-06-08 Thread Martin Pieuchot
On 07/06/16(Tue) 22:02, Stuart Henderson wrote: > On 2016/06/07 21:49, Vincent Gross wrote: > > > > It's how henning@ set things up when integrating the new queuing mechanism. > > http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/sys/kern/uipc_mbuf.c#rev1.160 > > > > > Is there any use for this apart

MBIM Patch (Round 3)

2016-06-08 Thread Gerhard Roth
Here comes the next version of the MBIM driver. Changes since last version: - incorporated suggestions from mpi@ - renamed to "umb" Only file "mbim.h" which contains MBIM protocol related stuff continues to use "mbim" as prefix. - No longer takes fake addresses nor does it try

Re: MBIM Patch (Round 2)

2016-06-08 Thread Martin Pieuchot
On 08/06/16(Wed) 12:44, Gerhard Roth wrote: > On Wed, 8 Jun 2016 11:31:41 +0100 Stuart Henderson > wrote: > > On 2016/06/08 11:59, Gerhard Roth wrote: > > > On Wed, 8 Jun 2016 10:54:00 +0100 Stuart Henderson > > > wrote: > > > > On 2016/06/08 11:48,

Re: 'continue' to appease style gods in i386,amd64 libsa

2016-06-08 Thread Tom Cosgrove
Hi > Two nits inline: Thanks for the feedback. Updated diff below. Tom >>> 8-Jun-16 11:52 >>> > > Hi Tom, > > Two nits inline: > > On Tue, Jun 7, 2016 at 9:47 PM, Tom Cosgrove > wrote: > > Tom Cosgrove 6-Jun-16 21:07 >>> > >> > >>

Re: MBIM Patch (Round 2)

2016-06-08 Thread Gerhard Roth
On Wed, 8 Jun 2016 11:31:41 +0100 Stuart Henderson wrote: > On 2016/06/08 11:59, Gerhard Roth wrote: > > On Wed, 8 Jun 2016 10:54:00 +0100 Stuart Henderson > > wrote: > > > On 2016/06/08 11:48, Gerhard Roth wrote: > > > > > > > > Currently I do this

Re: MBIM Patch (Round 2)

2016-06-08 Thread Stuart Henderson
On 2016/06/08 11:59, Gerhard Roth wrote: > On Wed, 8 Jun 2016 10:54:00 +0100 Stuart Henderson > wrote: > > On 2016/06/08 11:48, Gerhard Roth wrote: > > > > > > Currently I do this to get the interface up and running as my default > > > route: > > > > > > # ifconfig umb0

Re: MBIM Patch (Round 2)

2016-06-08 Thread Stuart Henderson
On 2016/06/08 11:48, Gerhard Roth wrote: > > Currently I do this to get the interface up and running as my default > route: > > # ifconfig umb0 pin apn > # ifconfig umb0 inet 0.0.0.1 0.0.0.2 > # route delete default > # route add -ifp umb0 default 0.0.0.2 >

Re: MBIM Patch (Round 2)

2016-06-08 Thread Gerhard Roth
On Wed, 8 Jun 2016 10:54:00 +0100 Stuart Henderson wrote: > On 2016/06/08 11:48, Gerhard Roth wrote: > > > > Currently I do this to get the interface up and running as my default > > route: > > > > # ifconfig umb0 pin apn > > # ifconfig umb0 inet 0.0.0.1

armv7 _AFLT

2016-06-08 Thread Artturi Alm
Hi, i wish you would consider this: diff --git a/sys/arch/arm/arm/cpufunc.c b/sys/arch/arm/arm/cpufunc.c index 00c683e..924cf67 100644 --- a/sys/arch/arm/arm/cpufunc.c +++ b/sys/arch/arm/arm/cpufunc.c @@ -575,7 +575,6 @@ armv7_setup() | CPU_CONTROL_AFE; cpuctrl =

Re: MBIM Patch (Round 2)

2016-06-08 Thread Stuart Henderson
On 2016/06/08 09:54, Gerhard Roth wrote: > On Tue, 7 Jun 2016 16:31:21 +0100 Stuart Henderson > wrote: > > On 2016/06/07 14:39, Gerhard Roth wrote: > > > > > Now I get an IP address from my provider, I want something like this: > > > > > > > > > > inet 10.75.178.41

Re: afterboot(8) ethernet device name

2016-06-08 Thread Mark Kettenis
> Date: Wed, 8 Jun 2016 11:10:56 +0200 > From: Stefan Sperling > > I find le0 and lo0 too close to be easily distinguishable, especially > with a small font. This way, the difference should be more obvious. ok kettenis@ > Index: afterboot.8 >

afterboot(8) ethernet device name

2016-06-08 Thread Stefan Sperling
I find le0 and lo0 too close to be easily distinguishable, especially with a small font. This way, the difference should be more obvious. Index: afterboot.8 === RCS file: /cvs/src/share/man/man8/afterboot.8,v retrieving revision

Re: MBIM Patch (Round 2)

2016-06-08 Thread Gerhard Roth
On Tue, 7 Jun 2016 16:31:21 +0100 Stuart Henderson wrote: > On 2016/06/07 14:39, Gerhard Roth wrote: > > > > Now I get an IP address from my provider, I want something like this: > > > > > > > > inet 10.75.178.41 --> 10.75.178.42 netmask 0xfffc > > > > > > > >

Re: 'continue' to appease style gods in i386,amd64 libsa

2016-06-08 Thread Tom Cosgrove
>>> Tom Cosgrove 6-Jun-16 21:07 >>> > > As per subject, a couple of empty loop bodies in the i396 and amd64 boot > blocks. > > Diff below. > > Tom Subsequently found a few more, and a handful of trailing whitespaces. Updated diff below. Thanks Tom Index: