Re: armv7 -pmap_prefer

2017-07-20 Thread Artturi Alm
On Thu, Jul 20, 2017 at 11:50:55PM +0300, Artturi Alm wrote: > Hi, > > one of the removals of mine i never understood why it was there to > begin w/, given it's not in our pmap.9, nor really doing anything. > > -Artturi > Took a better look, and this might actually be considered a bug fix, if

armv7 cpu_switchto

2017-07-20 Thread Artturi Alm
Hi, i think w/this it'll be more readable w/o the unnecessary branch and associated legacy fat. comments? 6 files changed, 35 insertions(+), 146 deletions(-) from teh optimizing 'less is more'-diff dept.. -Artturi diff --git a/sys/arch/arm/arm/cpufunc.c b/sys/arch/arm/arm/cpufunc.c index

cwm.1: use key names from /usr/X11R6/include/X11/keysymdef.h

2017-07-20 Thread Michael Reed
While trying to unbind C-/ in cwm, it took me a while to realize that you can't do "unbind-key C-/", as the key "/" is not defined in /usr/X11R6/include/X11/keysymdef.h. Instead you must do "unbind-key C-slash", as "slash" is defined there. Considering this, I think that the cwm man page is

Re: Fix for clang-provoked relocation errors

2017-07-20 Thread Stuart Henderson
On 2017/07/20 20:56, Christian Weisgerber wrote: > Mark Kettenis: > > > The diff below fixes the > > > > /usr/bin/ld: /tmp/BC-10602a.o: relocation R_X86_64_PC32 against `xxx' can > > not be used when making a shared object; recompile with -fPIC > > > > errors that we see with some ports when

Re: armv7 mmap(2) SIGBUS fix

2017-07-20 Thread Alexander Bluhm
On Thu, Jul 20, 2017 at 11:03:18PM +0200, Mark Kettenis wrote: > Already had the SEGV_ACCERR/SEGV_MAPERR bits right. So this just > fixes the SIGBUS of access beyond the mapped object. Tried to follow > amd64 since it was already close. > > ok? OK bluhm@ > Index: arch/arm/arm/fault.c >

armv7 mmap(2) SIGBUS fix

2017-07-20 Thread Mark Kettenis
Already had the SEGV_ACCERR/SEGV_MAPERR bits right. So this just fixes the SIGBUS of access beyond the mapped object. Tried to follow amd64 since it was already close. ok? Index: arch/arm/arm/fault.c === RCS file:

armv7 -pmap_prefer

2017-07-20 Thread Artturi Alm
Hi, one of the removals of mine i never understood why it was there to begin w/, given it's not in our pmap.9, nor really doing anything. -Artturi diff --git a/sys/arch/arm/arm/pmap7.c b/sys/arch/arm/arm/pmap7.c index f99ee582e00..d47d8058736 100644 --- a/sys/arch/arm/arm/pmap7.c +++

Re: arm64 SIGBUS/SIGSEGV fixes

2017-07-20 Thread Alexander Bluhm
On Thu, Jul 20, 2017 at 09:26:23PM +0200, Mark Kettenis wrote: > This brings arm64 in line with amd64/i386. Makes the siginfo-fault > regress test pass. > > ok? OK bluhm@ > Index: arch/arm64/arm64/trap.c > === > RCS file:

arm64 SIGBUS/SIGSEGV fixes

2017-07-20 Thread Mark Kettenis
This brings arm64 in line with amd64/i386. Makes the siginfo-fault regress test pass. ok? Index: arch/arm64/arm64/trap.c === RCS file: /cvs/src/sys/arch/arm64/arm64/trap.c,v retrieving revision 1.7 diff -u -p -r1.7 trap.c ---

Re: Fix for clang-provoked relocation errors

2017-07-20 Thread Christian Weisgerber
Mark Kettenis: > The diff below fixes the > > /usr/bin/ld: /tmp/BC-10602a.o: relocation R_X86_64_PC32 against `xxx' can not > be used when making a shared object; recompile with -fPIC > > errors that we see with some ports when compiled with clang. That's great news! > should go through a

Re: SIGBUS short mmap object

2017-07-20 Thread Mark Kettenis
> Date: Thu, 20 Jul 2017 18:18:58 +0200 > From: Alexander Bluhm > > On Thu, Jul 20, 2017 at 02:03:10PM +0200, Mark Kettenis wrote: > > If you can make the BUS_ADRERR -> BUS_OBJERR change (both here and in > > the regress test), this is ok kettenis@ > > This passes on

Re: SIGBUS short mmap object

2017-07-20 Thread Alexander Bluhm
On Thu, Jul 20, 2017 at 02:03:10PM +0200, Mark Kettenis wrote: > If you can make the BUS_ADRERR -> BUS_OBJERR change (both here and in > the regress test), this is ok kettenis@ This passes on amd64 and i386. ok? bluhm Index: sys/arch/amd64/amd64/trap.c

Re: Add machdep.lidaction=3 - powerdown laptop upon lid closing

2017-07-20 Thread Marco Bonetti
- On Jul 17, 2017, at 6:20 PM, Kevin Chadwick m8il1i...@gmail.com wrote: > What about powerup? Currently if u boot say an access point and close the > lid to save a watt. I *believe*? you have to wait for sysctl.conf to be > read before closing to avoid sleeping? sysctl.conf values are

Re: Add machdep.lidaction=3 - powerdown laptop upon lid closing

2017-07-20 Thread Marco Bonetti
- On Jul 17, 2017, at 7:19 AM, Jason McIntyre j...@kerhand.co.uk wrote: > On Mon, Jul 17, 2017 at 02:08:31AM +0200, Marco Bonetti wrote: >> Hello tech@, >> This is a diff that implements a new value (3) for machdep.lidaction to >> allow a >> laptop powerdown with a lid close. Since this

Re: login_skey crash

2017-07-20 Thread Todd C. Miller
On Thu, 20 Jul 2017 17:26:59 +0200, Alexander Bluhm wrote: > When login_skey is called for a user without skey it crashes with > NULL pointer dereference. It tries to pass a file descriptor that > does not exist. This has to be done conditionally. OK millert@ - todd

login_skey crash

2017-07-20 Thread Alexander Bluhm
Hi, When login_skey is called for a user without skey it crashes with NULL pointer dereference. It tries to pass a file descriptor that does not exist. This has to be done conditionally. ok? bluhm Index: libexec/login_skey/login_skey.c

Remove BUGS reference to SunOS <3.0 from rpcinfo.8

2017-07-20 Thread Kurt Mosiejczuk
While reading up on portmap and rpcinfo, I noticed the BUGS section of rpcinfo.8 talked about problems interacting with NFS on SunOS versions < 3.0. While I suppose that fact might win a UNIX trivia contest for someone some day, I'd think we can do without it. Index: rpcinfo.8

Re: armv7 static vectors

2017-07-20 Thread Artturi Alm
On Wed, Jul 19, 2017 at 05:37:49AM +0300, Artturi Alm wrote: > On Mon, Jul 10, 2017 at 04:19:12PM +0300, Artturi Alm wrote: > > Hi, > > > > > > this diff does seem bigger than it is, because this does move the exception > > handler entrys from arm/exceptions.S to arm/vectors.S, while removing >

Re: SIGBUS short mmap object

2017-07-20 Thread Mark Kettenis
> Date: Mon, 17 Jul 2017 23:36:17 +0200 > From: Alexander Bluhm > > Hi, > > The tests regress/sys/kern/siginfo-fault accesses an mmap(2)ed file > behind its end. Then it expects an SIGBUS, but gets an SIGSEGV. As you found it, this was a bit controversial. Theo and I

Re: TCP support for snmpd(8)

2017-07-20 Thread Stuart Henderson
On 2017/07/20 11:56, Marco Pfatschbacher wrote: > > We also have fd accounting in a few daemons to pause accept when > > we're out of fds (ENFILE or EMFILE), but this can be implemented in > > a separate commit. > > Not sure what that solves. sshd has MaxStartups and it's very > easy to DoS it.

Re: TCP support for snmpd(8)

2017-07-20 Thread Marco Pfatschbacher
On Wed, Jul 19, 2017 at 11:15:45AM +0200, Reyk Floeter wrote: > > > On 19.07.2017, at 10:16, Marco Pfatschbacher wrote: > > > > This adds TCP support to snmpd. > > I've added a tcp option to the "listen on" statement. > > The trap receiver will continue to bind to UDP addresses

Re: install.sub: zap space between function name and parens

2017-07-20 Thread Robert
OK Am 20. Juli 2017 10:50:24 MESZ schrieb Anton Lindqvist : >Hi, >Minor inconsistency noticed in install.sub. No intended functional >change. > >Comments? OK? > >Index: install.sub >=== >RCS file:

install.sub: zap space between function name and parens

2017-07-20 Thread Anton Lindqvist
Hi, Minor inconsistency noticed in install.sub. No intended functional change. Comments? OK? Index: install.sub === RCS file: /cvs/src/distrib/miniroot/install.sub,v retrieving revision 1.1024 diff -u -p -r1.1024 install.sub ---

Re: [PATCH] ure improvement

2017-07-20 Thread Martin Pieuchot
On 18/07/17(Tue) 13:43, sc dying wrote: > On 2017/07/18 09:12, Martin Pieuchot wrote: > > On 17/07/17(Mon) 15:24, sc dying wrote: > >> On 2017/07/17 08:24, Martin Pieuchot wrote: > >>> On 15/07/17(Sat) 21:16, sc dying wrote: > - Call usbd_set_config before configuring endpoints in ure_init to

Re: Reduce NET_LOCK() contention part 2

2017-07-20 Thread Martin Pieuchot
On 18/07/17(Tue) 16:28, Mark Kettenis wrote: > > Date: Tue, 18 Jul 2017 16:08:04 +0200 > > From: Martin Pieuchot > > > > As long as most of the Network Stack run under the NET_LOCK() we want to > > avoid grabbing the lock from different contexts. Because when multiple > >