inteldrm: Use "the flush page mechanism" only on chips having it.

2019-05-08 Thread Alexandre Ratchov
In the intel_gtt_chipset_setup() routine, called at initialization, the driver maps pci space for certain chip models only, but later in intel_gtt_chipset_flush() it calls bus_space_write() on it in cases it's not initialized. This results in crashes during boot with "Pineview" generation chips, w

less discriminatory battlestar

2019-05-08 Thread Ted Unangst
there are lists of annointed usernames in battlestar. this creates an unfair playing field! worse, there is a list of "bad" people! and i'm almost one of them! -static const char *const badguys[] = { - "wnj", - "root", - "ted", - 0 -}; Index: com1.c ==

Re: [PATCH] Parallelize sysupgrade downloads

2019-05-08 Thread Christian Weisgerber
On 2019-05-09, Christian Weisgerber wrote: >> Does unpriv do anything if you don't give it a command to run? > > It should return an error code and abort the script. And actually that's what it does. (Sorry, I confused myself there for a moment.) -- Christian "naddy" Weisgerber

Re: iwm: fix ADD_STA status check

2019-05-08 Thread Kevin Lo
On Wed, May 08, 2019 at 03:26:00PM -0400, Stefan Sperling wrote: > > Correctly mask status bits in ADD_STA command response; remaining > bits are used by firmware to return the baid for a BA session. > > Dragonfly 74d41163ddac72b0d7ea7b7873d53fe134723a12 > Linux 837c4da98481d4e504b2aba077c8528fee

Re: iwm: rx interrupt paranoia

2019-05-08 Thread Kevin Lo
On Wed, May 08, 2019 at 02:54:50PM -0400, Stefan Sperling wrote: > > Add two sanity checks to iwm's firmware notification interrupt handler: > > 1) Clamp the firmware-provided index into the rx ring to the size of the ring. > Linux started doing this, too, to work around HW bugs in the 9000 serie

sysupgrade: don't re-verify sets in the installer

2019-05-08 Thread Christian Weisgerber
Currently we verify all sets, reboot into bsd.upgrade, and there the installer re-verifies them all over. The diff below eliminates this redundant check. In the installer, verification is triggered by the presence of SHA256.sig. Later, SHA256.sig is saved, so sysupgrade can exit early if no newe

Re: [PATCH] Parallelize sysupgrade downloads

2019-05-08 Thread Christian Weisgerber
On 2019-05-08, Jarkko Oranen wrote: >> -unpriv -f $f ftp -Vmo ${f} ${URL}${f} >> +unpriv -f $f > > Does unpriv do anything if you don't give it a command to run? It should return an error code and abort the script. I need to investigate why that doesn't happen. -- Christian "naddy" We

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Reyk Floeter wrote: > I meant: could you use /* */ instead of //? oh, sure. done. > Yes, it looks slightly better. > > grumble OK reyk thanks. Matthew, thanks.

Re: ftpd(8): rm dead code and simplifies popen clone

2019-05-08 Thread Jan Klemkow
On Wed, May 08, 2019 at 07:10:37PM -0400, Ted Unangst wrote: > Jan Klemkow wrote: > > - * Special version of popen which avoids call to shell. This ensures noone > > + * Special version of popen which avoids call to shell. This ensures none > > If we don't like noone, the correct spelling is no

Chromebook serial

2019-05-08 Thread Mark Kettenis
Modern chromebooks expose a debugging interface on one of their USB Type-C connectors. Part of this interface are *three* USB serial devices that connect to microcontrollers and a serial port on the SoC. It all works nicely with ucom(4) but we need a bit of glue to actually make that attach. What

Re: Avoid system(3) in ikectl

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 07:05:24PM -0400, Ted Unangst wrote: > Reyk Floeter wrote: > > On Wed, May 08, 2019 at 06:44:32PM -0400, Ted Unangst wrote: > > > Ted Unangst wrote: > > > > Matthew Martin wrote: > > > > > I did that originally [1], but Reyk preferred the varargs approach > > > > > [2], > >

Re: ftpd(8): rm dead code and simplifies popen clone

2019-05-08 Thread Ted Unangst
Jan Klemkow wrote: > - * Special version of popen which avoids call to shell. This ensures noone > + * Special version of popen which avoids call to shell. This ensures none If we don't like noone, the correct spelling is no one. Rest of the diff seems like a good improvement.

Re: Avoid system(3) in ikectl

2019-05-08 Thread Theo de Raadt
Ted Unangst wrote: > ca_exec or ca_system I could go either way, but there's no longer sh involved, > so that's why I went back to exec. Even more accurate to name it ca_execv(), since this is a argv[] interface.

Re: relayd websocket

2019-05-08 Thread Sebastian Benoit
ok benno@ Reyk Floeter(r...@openbsd.org) on 2019.05.08 20:35:46 +0200: > On Wed, May 08, 2019 at 07:07:43PM +0200, Reyk Floeter wrote: > > On Wed, May 08, 2019 at 06:26:45PM +0200, Reyk Floeter wrote: > > > On Wed, Mar 06, 2019 at 05:36:32PM +0100, Sebastian Benoit wrote: > > > > Rivo Nurges(riv

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Reyk Floeter wrote: > On Wed, May 08, 2019 at 06:44:32PM -0400, Ted Unangst wrote: > > Ted Unangst wrote: > > > Matthew Martin wrote: > > > > I did that originally [1], but Reyk preferred the varargs approach [2], > > > > so I changed the patch to match. > > > > > > Sorry, only wading into the thr

ftpd(8): rm dead code and simplifies popen clone

2019-05-08 Thread Jan Klemkow
Hi, This diff removes dead code from ftpd(8). In the past ftpd executes ls(1) for directory listings. But, quite a while now It justs calls the main function of the linked in ls(1) directly. The code path to the main function of ls(1) as well as the read-only mode are hard coded in the current

Re: Avoid system(3) in ikectl

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 06:44:32PM -0400, Ted Unangst wrote: > Ted Unangst wrote: > > Matthew Martin wrote: > > > I did that originally [1], but Reyk preferred the varargs approach [2], > > > so I changed the patch to match. > > > > Sorry, only wading into the thread at this point. Seems not every

Re: Avoid system(3) in ikectl

2019-05-08 Thread Theo de Raadt
This feels approximately right to me.

Re: iwm: move mbuf hacks down in iwm_rx_rx_mpdu()

2019-05-08 Thread Stefan Sperling
On Thu, May 09, 2019 at 08:31:29AM +1000, Jonathan Matthew wrote: > On Wed, May 08, 2019 at 03:01:05PM -0400, Stefan Sperling wrote: > > Don't write to mbuf memory before we've actually completed all > > sanity checks and iwm_rx_addbuf() has succcessfully put a new > > buffer on the ring. > > > >

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Ted Unangst wrote: > Matthew Martin wrote: > > I did that originally [1], but Reyk preferred the varargs approach [2], > > so I changed the patch to match. > > Sorry, only wading into the thread at this point. Seems not everybody has the > same taste in code... Well, we have the original. Let me b

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Matthew Martin wrote: > I did that originally [1], but Reyk preferred the varargs approach [2], > so I changed the patch to match. Sorry, only wading into the thread at this point. Seems not everybody has the same taste in code... Well, we have the original. Let me bring that back.

Re: iwm: move mbuf hacks down in iwm_rx_rx_mpdu()

2019-05-08 Thread Jonathan Matthew
On Wed, May 08, 2019 at 03:01:05PM -0400, Stefan Sperling wrote: > Don't write to mbuf memory before we've actually completed all > sanity checks and iwm_rx_addbuf() has succcessfully put a new > buffer on the ring. > > Same as dragonfly commit 96eaecf93d9f731459a0df8efc72cfad034320bd > "Avoids le

Re: Avoid system(3) in ikectl

2019-05-08 Thread Theo de Raadt
Matthew Martin wrote: > On Wed, May 08, 2019 at 04:22:16PM -0600, Theo de Raadt wrote: > > Isn't something like better -- to avoid marshalling code to convert > > arguments -> array? > > > > char *pkcs_args[] = > > PATH_OPENSSL, > > "pkcs12", > > "-export", > > "-caname", > >

Re: Avoid system(3) in ikectl

2019-05-08 Thread Matthew Martin
On Wed, May 08, 2019 at 04:22:16PM -0600, Theo de Raadt wrote: > Isn't something like better -- to avoid marshalling code to convert > arguments -> array? > > char *pkcs_args[] = > PATH_OPENSSL, > "pkcs12", > "-export", > "-caname", > ca->caname, > "-name", >

Re: Avoid system(3) in ikectl

2019-05-08 Thread Theo de Raadt
Ted Unangst wrote: > Theo de Raadt wrote: > > Isn't something like better -- to avoid marshalling code to convert > > arguments -> array? > > this requires mixing declarations and code, but all our compilers are c99 > compliant now, and this does make ca_system simpler. I dislike mixing decl an

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Theo de Raadt wrote: > Isn't something like better -- to avoid marshalling code to convert > arguments -> array? this requires mixing declarations and code, but all our compilers are c99 compliant now, and this does make ca_system simpler. > > char *pkcs_args[] = > PATH_OPENSSL, >

Re: Avoid system(3) in ikectl

2019-05-08 Thread Theo de Raadt
Ted Unangst wrote: > Matthew Martin wrote: > > ping > > > > On Thu, Apr 25, 2019 at 11:21:00PM -0500, Matthew Martin wrote: > > > On Thu, Apr 25, 2019 at 08:59:56PM -0600, Theo de Raadt wrote: > > > > > + argv = alloca((n + 1) * sizeof(*argv)); > > > > > > > > Our source tree is exceeding

Re: httpd rewrite support and REQUEST_URI

2019-05-08 Thread Theo Buehler
On Tue, Jul 31, 2018 at 06:27:39AM -0500, Tim Baumgard wrote: > I was testing the new rewrite support in httpd in conjunction with the > "fastcgi" > option and noticed that the REQUEST_URI CGI variable is set to the rewritten > path and query string instead of the requested URI and query string. T

SMR lists for bridge(4)

2019-05-08 Thread Martin Pieuchot
Diff below pushes the KERNEL_LOCK() further down into bridge(4). With it bridge_enqueue() now only takes the lock for rules. Rules could easily be protected by a mutex but I wanted to keep this change small. The list of interface and span interfaces are now using SMR list. Removing a `bif' from

Re: update to PF pfctl(8) and pf.conf(5) manpages

2019-05-08 Thread Klemens Nanni
On Wed, May 08, 2019 at 05:31:37PM +0200, Ingo Schwarze wrote: > Thank you again for doing this work. +1 > Either way, this seems mature enough for getting it in. > IMHO, no need to resend it again. I concur; Ingo's nits are fine. Feel free to go ahead and commit with OK kn.

Re: enable pfctl to flush all rules and tables

2019-05-08 Thread Alexandr Nedvedicky
Hello, diff 3/3 makes patch complete. It uses pfctl_recurse() introduced in 2/3 to implement operations as follows: pfctl -a "*" -Fa(applies pfctl_call_clearanchors()) pfctl -a "*" -Fr(applies pfctl_call_clearrules()) pfctl -a "*" -FT(applies pfctl_call_cleartables()) All

Re: relayd websocket

2019-05-08 Thread Rivo Nurges
Hi! Seems to work fine. Rivo On 2019-05-08 21:37, Reyk Floeter wrote: > On Wed, May 08, 2019 at 07:07:43PM +0200, Reyk Floeter wrote: >> On Wed, May 08, 2019 at 06:26:45PM +0200, Reyk Floeter wrote: >>> On Wed, Mar 06, 2019 at 05:36:32PM +0100, Sebastian Benoit wrote: Rivo Nurges(rivo.nur..

[2/3] enable pfctl to flush all rules and tables

2019-05-08 Thread Alexandr Nedvedicky
Hello, second diff makes current implementation of 'pfctl -vsA' (show rules) more generic. It changes current pfctl_show_anchors() to pfctl_walk_anchors() which accepts a callback as argument (pfctl_show_anchor()) to show anchor found in kernel. So existing pfctl_show_anchors() is changed to this:

Re: vm.conf: boot-device

2019-05-08 Thread Mike Larkin
On Wed, May 08, 2019 at 09:41:42PM +0200, Anton Lindqvist wrote: > On Wed, May 08, 2019 at 07:19:45PM +0200, Reyk Floeter wrote: > > On Wed, May 08, 2019 at 06:47:53PM +0200, Anton Lindqvist wrote: > > > Hi, > > > A first stab at adding support for option `-B device' to vm.conf(5). > > > With the d

[1/3] Re: enable pfctl to flush all rules and tables

2019-05-08 Thread Alexandr Nedvedicky
Hello, looks like the diff is too big for review. so let me slice it to smaller chunks. I've tested the complete diff I have not tested the partial diffs. no issues were discovered by running regress on pfctl. furthermore doing 'pfctl -a "*" -Fa' with my changes in did expected thing: it removed

Re: vm.conf: boot-device

2019-05-08 Thread Anton Lindqvist
On Wed, May 08, 2019 at 07:19:45PM +0200, Reyk Floeter wrote: > On Wed, May 08, 2019 at 06:47:53PM +0200, Anton Lindqvist wrote: > > Hi, > > A first stab at adding support for option `-B device' to vm.conf(5). > > With the diff below, I'm able to add a dedicated VM to be used with > > autoinstall(5

iwm: fix ADD_STA status check

2019-05-08 Thread Stefan Sperling
Correctly mask status bits in ADD_STA command response; remaining bits are used by firmware to return the baid for a BA session. Dragonfly 74d41163ddac72b0d7ea7b7873d53fe134723a12 Linux 837c4da98481d4e504b2aba077c8528fee1b6d13 Not sure if this matters for us yet, but it will likely matter when we

Re: Avoid system(3) in ikectl

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 01:06:30PM -0500, Matthew Martin wrote: > ping > The diff looks good now. I otherwise agree with tedu. OK reyk@ > On Thu, Apr 25, 2019 at 11:21:00PM -0500, Matthew Martin wrote: > > On Thu, Apr 25, 2019 at 08:59:56PM -0600, Theo de Raadt wrote: > > > > + argv = al

iwm: rx interrupt paranoia

2019-05-08 Thread Stefan Sperling
Add two sanity checks to iwm's firmware notification interrupt handler: 1) Clamp the firmware-provided index into the rx ring to the size of the ring. Linux started doing this, too, to work around HW bugs in the 9000 series. 2) Don't call iwm_cmd_done() if the firmware response in the Rx buffer i

iwm: move mbuf hacks down in iwm_rx_rx_mpdu()

2019-05-08 Thread Stefan Sperling
Don't write to mbuf memory before we've actually completed all sanity checks and iwm_rx_addbuf() has succcessfully put a new buffer on the ring. Same as dragonfly commit 96eaecf93d9f731459a0df8efc72cfad034320bd "Avoids leaving the mbuf in a weird state when dropping a packet." ok? diff 74c6ffce7

Re: relayd websocket

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 07:07:43PM +0200, Reyk Floeter wrote: > On Wed, May 08, 2019 at 06:26:45PM +0200, Reyk Floeter wrote: > > On Wed, Mar 06, 2019 at 05:36:32PM +0100, Sebastian Benoit wrote: > > > Rivo Nurges(rivo.nur...@smit.ee) on 2019.03.05 22:42:13 +: > > > > Hi! > > > > > > > > On 3/

Re: Avoid system(3) in ikectl

2019-05-08 Thread Ted Unangst
Matthew Martin wrote: > ping > > On Thu, Apr 25, 2019 at 11:21:00PM -0500, Matthew Martin wrote: > > On Thu, Apr 25, 2019 at 08:59:56PM -0600, Theo de Raadt wrote: > > > > + argv = alloca((n + 1) * sizeof(*argv)); > > > > > > Our source tree is exceedingly sparing in the use of alloca(). >

Re: Avoid system(3) in ikectl

2019-05-08 Thread Matthew Martin
ping On Thu, Apr 25, 2019 at 11:21:00PM -0500, Matthew Martin wrote: > On Thu, Apr 25, 2019 at 08:59:56PM -0600, Theo de Raadt wrote: > > > + argv = alloca((n + 1) * sizeof(*argv)); > > > > Our source tree is exceedingly sparing in the use of alloca(). > > This will not do. > > Was staying

Re: vm.conf: boot-device

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 06:47:53PM +0200, Anton Lindqvist wrote: > Hi, > A first stab at adding support for option `-B device' to vm.conf(5). > With the diff below, I'm able to add a dedicated VM to be used with > autoinstall(5): > > vm "amd64-install" { > disable > boot $sna

Re: ld.so speedup (part 1)

2019-05-08 Thread Nathanael Rensen
On Mon 6, May 2019 at 00:16:57, Nathanael Rensen wrote: > On Sun, 5 May 2019 at 06:41, Martin Pieuchot wrote: [snip] > > Do I understand correctly that you're not recursing if not object is > > inserted? > > Yes. > > You have probably also noticed that using a single recurse flag is not > optim

Re: relayd websocket

2019-05-08 Thread Reyk Floeter
On Wed, May 08, 2019 at 06:26:45PM +0200, Reyk Floeter wrote: > On Wed, Mar 06, 2019 at 05:36:32PM +0100, Sebastian Benoit wrote: > > Rivo Nurges(rivo.nur...@smit.ee) on 2019.03.05 22:42:13 +: > > > Hi! > > > > > > On 3/5/19 10:36 PM, Claudio Jeker wrote: > > > > I guess that this would need s

vm.conf: boot-device

2019-05-08 Thread Anton Lindqvist
Hi, A first stab at adding support for option `-B device' to vm.conf(5). With the diff below, I'm able to add a dedicated VM to be used with autoinstall(5): vm "amd64-install" { disable boot $snapshots "bsd.rd" disk $home "amd64.qcow2" boot-device net

Re: relayd websocket

2019-05-08 Thread Reyk Floeter
On Wed, Mar 06, 2019 at 05:36:32PM +0100, Sebastian Benoit wrote: > Rivo Nurges(rivo.nur...@smit.ee) on 2019.03.05 22:42:13 +: > > Hi! > > > > On 3/5/19 10:36 PM, Claudio Jeker wrote: > > > I guess that this would need strcasestr() instead of strcasecmp(), since > > > you > > > are looking fo

Re: arm64: fix DEBUG_AGINTC

2019-05-08 Thread Mark Kettenis
> Date: Wed, 8 May 2019 07:21:06 -0700 > From: Carlos Cardenas > > Fix kernel compile with DEBUG_AGINTC. > > OK? Sure! > +--+ > Carlos > > [2:text/plain Hide] > > Index: agintc.c > === > RCS file: /cvs/src/sys/arch/arm64/dev/agi

Re: [PATCH] Parallelize sysupgrade downloads

2019-05-08 Thread Jarkko Oranen
On 5/7/19 10:39 PM, Ville Valkonen wrote: Hello, thanks for the great new tool, sysupgrade. Works like a charm. While on it, I came with this patch to speed up the downloading. It uses xargs -P to parallelize downloads (max 6, chosen from top of my head). Also, removed trailing spaces in two l

Re: update to PF pfctl(8) and pf.conf(5) manpages

2019-05-08 Thread Ingo Schwarze
Hi Alexandr, Alexandr Nedvedicky wrote on Wed, May 08, 2019 at 04:55:57PM +0200: > below is third iteration of pf.conf.5 manpage. OK schwarze@ A few final nits inline. Thank you again for doing this work. Ingo > diff --git a/share/man/man5/pf.conf.5 b/share/man/man5/pf.conf.5 [...] > @@ -1

Re: update to PF pfctl(8) and pf.conf(5) manpages

2019-05-08 Thread Alexandr Nedvedicky
Hello, below is third iteration of pf.conf.5 manpage. The new addresses issues as follows: all excessive "'pfctl -F Reset' ..." are gone. I've added simple sentence/paragraph at the end of OPTIONS section: +.Pp +.Dq pfctl -F Reset +restores default values for t

relayd: fix filter rules with forward to statement

2019-05-08 Thread Reyk Floeter
Hi, the attached diff fixes filter rules with "forward to" statement in persistent (keep-alive) connections. See the XXX comment below. ```relayd.conf log connection table { 127.0.0.1 } table { 127.0.0.1 } table { 127.0.0.1 } http protocol pathfwd { return erro

less(1) UTF-8 cleanup: cvt.c

2019-05-08 Thread Ingo Schwarze
Hi Todd, Todd C. Miller wrote on Wed, May 08, 2019 at 06:36:30AM -0600: > On Tue, 07 May 2019 23:32:20 +0200, Ingo Schwarze wrote: >> Here is basic cleanup of the last major function in line.c, pshift(). > Looks good. OK millert@ Thanks for checking, i will commit the line.c patch later today

arm64: fix DEBUG_AGINTC

2019-05-08 Thread Carlos Cardenas
Fix kernel compile with DEBUG_AGINTC. OK? +--+ Carlos Index: agintc.c === RCS file: /cvs/src/sys/arch/arm64/dev/agintc.c,v retrieving revision 1.15 diff -u -p -r1.15 agintc.c --- agintc.c7 Dec 2018 21:33:28 - 1.15 +++ a

Re: relayd websocket

2019-05-08 Thread Rivo Nurges
Hi! Anyone? Rivo On 2019-03-12 21:50, Rivo Nurges wrote: > Hi! > > Bump... > > Rivo > > On 3/6/19 10:57 PM, Rivo Nurges wrote: >> Hi! >> >> >> On 3/6/19 10:20 PM, Rivo Nurges wrote: >>> On 3/6/19 6:36 PM, Sebastian Benoit wrote: > Does something like this make sense? i think the

Re: less(1) UTF-8 cleanup: pshift()

2019-05-08 Thread Todd C . Miller
On Tue, 07 May 2019 23:32:20 +0200, Ingo Schwarze wrote: > Here is basic cleanup of the last major function in line.c, pshift(). > Several minor issues still remain in the file, but those are for later. > > This gets rid of two LWCHAR variables, one call to utf_len(), > get_wchar(), is_composing_c