[U-Boot] [patch] replace mkimage.c write() calls with full_write()

2014-03-20 Thread Andrew Cann
This patch adds a function to mkimage.c called full_write() which calls write() in a loop until all the data has been written or write errors. I was getting an error with mkimage running out of space on the device it was writing to, but instead of printing a useful error message it was printing:

[U-Boot] iMX6 IPU display interface definition

2014-03-20 Thread Andreas Geisreiter
Hi, we are working at the moment with i.MX6DL. I tried to setup new display support (RGB interface) in Bootloader U-Boot. There is a structure available, where I can define all the display timings: .mode = { .name = "wvga-rgb", .refresh

Re: [U-Boot] [PATCH v4 1/6] part_efi: move uuid<->string conversion functions into lib/uuid.c

2014-03-20 Thread Przemyslaw Marczak
Hello, On 03/19/2014 08:19 PM, Wolfgang Denk wrote: Dear Przemyslaw Marczak, In message <1395251911-26540-1-git-send-email-p.marc...@samsung.com> you wrote: Changes: - move uuid<->string conversion functions into lib/uuid.c so they can be used by code outside part_efi.c. - rename uuid_strin

Re: [U-Boot] [patch] replace mkimage.c write() calls with full_write()

2014-03-20 Thread Wolfgang Denk
Dear Andrew, In message <20140320034408.ga20...@canndrew.org> you wrote: > > This patch adds a function to mkimage.c called full_write() which calls > write() > in a loop until all the data has been written or write errors. > > I was getting an error with mkimage running out of space on the dev

Re: [U-Boot] [PATCH] 4xx: cleanup ethernet phy initialization on PMC440 boards

2014-03-20 Thread Stefan Roese
Hi Matthias, On 19.03.2014 21:30, Matthias Fuchs wrote: This patch moves phy initialization for VSC8601 ethernet phys that are used on early board revisions into a separate setup function. Thanks for working on this. Some additional comments though. Signed-off-by: Matthias Fuchs --- board

[U-Boot] [PATCH] sun5i: Add A13-OLinuXinoM support

2014-03-20 Thread Tom Rini
Tested-by: Matt Porter Signed-off-by: Tom Rini --- board/sunxi/Makefile |1 + board/sunxi/dram_a13_oli_micro.c | 32 boards.cfg |1 + 3 files changed, 34 insertions(+) create mode 100644 board/sunxi/dram_a13_oli_micro.

Re: [U-Boot] [RFC PATCH 04/17] kconfig: add defconfig files for all boards

2014-03-20 Thread Daniel Schwierzeck
2014-03-20 1:11 GMT+01:00 Masahiro Yamada : > > Basicly I think it's a good idea, but I am afraid there are some > problems. > > [1] > First, in this case, how can we select the target board? > > Like this? > > choice > prompt "Board select" > default BOARD_SANDBOX > > config BOARD_

Re: [U-Boot] iMX6 IPU display interface definition

2014-03-20 Thread Eric Nelson
Hi Andreas, On 03/20/2014 01:41 AM, Andreas Geisreiter wrote: Hi, we are working at the moment with i.MX6DL. I tried to setup new display support (RGB interface) in Bootloader U-Boot. There is a structure available, where I can define all the display timings: .mode = {

Re: [U-Boot] [PATCH 1/3] TI: Add, use a DEFAULT_LINUX_BOOT_ENV environment string

2014-03-20 Thread Dennis Gilmore
On Tue, 11 Mar 2014 15:42:01 -0400 Tom Rini wrote: > To deal with a reoccurring problem properly we need to specify > addresses for the Linux kernel, Flatted Device Tree and ramdisk that > obey the constraints within the kernel's Documentation/arm/Booting > file but also make sure that we relocat

Re: [U-Boot] [PATCH 2/3] am335x_evm: Update the ramdisk args, we pass things in just fine via DT

2014-03-20 Thread Dennis Gilmore
On Tue, 11 Mar 2014 15:42:02 -0400 Tom Rini wrote: > Signed-off-by: Tom Rini > --- > include/configs/am335x_evm.h |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/include/configs/am335x_evm.h > b/include/configs/am335x_evm.h index 6bd8aec..11088b3 100644 > --- a/incl

Re: [U-Boot] [PATCH 3/3] am43xx_evm: Update the ramdisk args, we pass things in just fine via DT

2014-03-20 Thread Dennis Gilmore
On Tue, 11 Mar 2014 15:42:03 -0400 Tom Rini wrote: > Signed-off-by: Tom Rini > --- > include/configs/am43xx_evm.h |2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/include/configs/am43xx_evm.h > b/include/configs/am43xx_evm.h index 2c5..2d9825b 100644 > --- a/incl

Re: [U-Boot] iMX6 IPU display interface definition

2014-03-20 Thread Andreas Geisreiter
Hi Eric, Thanks for your help. In the header files which you mentioned I found the following: V-Sync: Active high or low = FB_SYNC_VERT_HIGH_ACT H-Sync: Active high or low = FB_SYNC_HOR_HIGH_ACT Output enable: Active high or low = FB_SYNC_OE_LOW_ACT Data lines: inverted or not = FB_SYNC_DATA_INV

Re: [U-Boot] iMX6 IPU display interface definition

2014-03-20 Thread Eric Bénard
Hi Andreas, Le Thu, 20 Mar 2014 16:13:53 +, Andreas Geisreiter a écrit : > Thanks for your help. In the header files which you mentioned I found the > following: > > V-Sync: Active high or low = FB_SYNC_VERT_HIGH_ACT > H-Sync: Active high or low = FB_SYNC_HOR_HIGH_ACT > Output enable: Activ

[U-Boot] [PATCH] kbuild/makefile: allow building host tools separately

2014-03-20 Thread Alexey Brodkin
Sometimes it is required to build only host U-Boot tools without building U-Boot itself for either board. For example: * In "buildroot" "uboot-tools" could be built for host just to have an ability to create uImage. * Linux distributions ship "mkimage" utility as a separate substance. This p

[U-Boot] [PATCH v3 1/4] lib: rand: introduce new configs: CONFIG_LIB_RAND CONFIG_LIB_HW_RAND

2014-03-20 Thread Przemyslaw Marczak
New configs: - CONFIG_LIB_RAND- to enable implementation of rand library in lib/rand.c - CONFIG_LIB_HW_RAND - to enable hardware based implementations of lib rand Other changes: - add CONFIG_LIB_RAND to boards configs which needs rand() - put only one rand.o dependency in lib/Makefile CONFIG_

[U-Boot] [PATCH v3 3/4] drivers: crypto: ace_sha: add implementation of hardware based lib rand

2014-03-20 Thread Przemyslaw Marczak
This patch adds implementation of rand library based on hardware random number generator of security subsystem in Exynos SOC. This library includes: - srand() - used for seed hardware block - rand() - returns random number - rand_r() - the same as above with given seed which depends on CONFIG_

[U-Boot] [PATCH v3 4/4] trats/trats2: enable exynos ace sha subsystem and hardware based lib rand

2014-03-20 Thread Przemyslaw Marczak
This allows to use exynos random number generator. Signed-off-by: Przemyslaw Marczak Acked-by: Lukasz Majewski cc: Piotr Wilczek cc: Minkyu Kang --- Changes v2: - none Changes v3: - change config name CONFIG_RAND_HW_ACCEL to CONFIG_HW_RAND include/configs/trats.h | 4 include/configs

[U-Boot] [PATCH v3 2/4] cpu: exynos4: add ace sha base address

2014-03-20 Thread Przemyslaw Marczak
Signed-off-by: Przemyslaw Marczak Cc: Minkyu Kang --- Changes v3: - new commit - after separate changes from next commit arch/arm/include/asm/arch-exynos/cpu.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/arm/include/asm/arch-exynos/cpu.h b/arch/arm/include/asm

Re: [U-Boot] [PATCH v3 1/4] lib: rand: introduce new configs: CONFIG_LIB_RAND CONFIG_LIB_HW_RAND

2014-03-20 Thread Przemyslaw Marczak
Dear all, On 03/20/2014 06:23 PM, Przemyslaw Marczak wrote: New configs: - CONFIG_LIB_RAND- to enable implementation of rand library in lib/rand.c - CONFIG_LIB_HW_RAND - to enable hardware based implementations of lib rand Other changes: - add CONFIG_LIB_RAND to boards configs which needs r

Re: [U-Boot] [PATCH 07/11] ARM: tegra: pinmux naming consistency fixes

2014-03-20 Thread Stephen Warren
On 03/14/2014 02:15 PM, Simon Glass wrote: > Hi Stephen, > > On 13 March 2014 11:42, Stephen Warren wrote: >> From: Stephen Warren >> >> Clean up the naming of pinmux-related objects: >> * Refer to drive groups rather than pad groups to match the Linux kernel. >> * Ensure all pinmux API types ar

Re: [U-Boot] [PATCH 05/11] ARM: tegra: pinctrl: remove duplication

2014-03-20 Thread Stephen Warren
On 03/14/2014 01:37 PM, Simon Glass wrote: > Hi Stephen, > > On 13 March 2014 11:42, Stephen Warren wrote: >> From: Stephen Warren >> >> Much of arch/arm/cpu/tegra*-common/pinmux.c is identical. Remove the >> duplication by creating pinmux-common.c for all the identical code. >> >> This leaves:

Re: [U-Boot] [PATCH v1 8/9] sunxi: non-FEL SPL boot support for sun7i

2014-03-20 Thread Ian Campbell
On Mon, 2014-03-17 at 15:33 -0400, Tom Rini wrote: > > So, I'm confused about what to do here ;-) > > And I've not made things clearer with a mis-recollection of things. I > don't know why I keep saying "bootm_low" when I mean "bootm_size" like > I've done in later patches (and thankfully, when p

Re: [U-Boot] [PATCH v3 1/4] lib: rand: introduce new configs: CONFIG_LIB_RAND CONFIG_LIB_HW_RAND

2014-03-20 Thread Michael Walle
Am Donnerstag, 20. März 2014, 18:36:17 schrieb Przemyslaw Marczak: > Dear all, > > On 03/20/2014 06:23 PM, Przemyslaw Marczak wrote: > > New configs: > > - CONFIG_LIB_RAND- to enable implementation of rand library in > > lib/rand.c - CONFIG_LIB_HW_RAND - to enable hardware based > > implementa

[U-Boot] [PATCH 0/6] unified boot environment

2014-03-20 Thread Dennis Gilmore
Hi All, The attached patches build on the work for generic distro config, as well as Stephen Warrens implementation for tegra. They depend on Toms Patches to move ti to using DEFAULT_LINUX_BOOT_ENV on TI systems. There is a README file to describe how to convert a system. I have added a header to

[U-Boot] [PATCH 1/6] add README.distro file

2014-03-20 Thread Dennis Gilmore
Add documentation on how to setup a system to use the generic distro configs and boot commands. This spells out what is needed to make a system conformant, but does not limit the board to only the defaults. Signed-off-by: Dennis Gilmore --- doc/README.distro | 76

[U-Boot] [PATCH 5/6] move pandaboard over to use the generic distro configuation and environment

2014-03-20 Thread Dennis Gilmore
port pandaboard to use the generic distro configuation. remove duplicated config options, clean up the environment, include new environment. Signed-off-by: Dennis Gilmore --- include/configs/omap4_panda.h | 2 -- include/configs/ti_omap4_common.h | 37 +++--

[U-Boot] [PATCH 2/6] add header with a generic set of boot commands defined.

2014-03-20 Thread Dennis Gilmore
As the next step in a generic config we are introducing a set of generic boot paramaters. Depending on the hardwares configuration, booting from supported hardware will be enabled, mmc, usb, sata, scsi, ide, pxe and dhcp. There is nothing to stop this being extended to support nand and any other t

[U-Boot] [PATCH 4/6] move beagleboard over to use the generic distro configuation and environment

2014-03-20 Thread Dennis Gilmore
port beagleboard to use the generic distro configuation. remove duplicated config options, clean up the environment, include new environment. Signed-off-by: Dennis Gilmore --- include/configs/am335x_evm.h | 62 +-- include/configs/ti_armv7_common.h | 32 +

[U-Boot] [PATCH 6/6] pxe: additionaly check for fdt_file env variable

2014-03-20 Thread Dennis Gilmore
some boards have used fdt_file while others have used fdtfile to define the name of the fdt file. If we do notget a fdtfile environment variable, additionally check for fdt_file. Signed-off-by: Dennis Gilmore --- common/cmd_pxe.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/common/

[U-Boot] [PATCH 3/6] move wandboard over to use the generic distro configuation and environment

2014-03-20 Thread Dennis Gilmore
port wandboard to use the generic distro configuation. remove duplicated config options, clean up the environment, include new environment. Signed-off-by: Dennis Gilmore --- include/configs/wandboard.h | 92 +++-- 1 file changed, 14 insertions(+), 78 delet

Re: [U-Boot] [PATCH 05/11] ARM: tegra: pinctrl: remove duplication

2014-03-20 Thread Simon Glass
Hi Stephen, On 20 March 2014 12:57, Stephen Warren wrote: > > On 03/14/2014 01:37 PM, Simon Glass wrote: > > Hi Stephen, > > > > On 13 March 2014 11:42, Stephen Warren wrote: > >> From: Stephen Warren > >> > >> Much of arch/arm/cpu/tegra*-common/pinmux.c is identical. Remove the > >> duplicatio

Re: [U-Boot] [RFC PATCH 0/17] Version 0 of Kconfig for U-Boot

2014-03-20 Thread Simon Glass
Hi Masahiro, On 17 March 2014 01:52, Masahiro Yamada wrote: > > Several weeks have passed since Kbuild series was merged to the > code base at 2014.01-rc1. > > I think now is a good time to start to discuss the next stage. > Yes, our promised land, Kconfig. Great! I have a few general comments b

Re: [U-Boot] [PATCH 05/11] ARM: tegra: pinctrl: remove duplication

2014-03-20 Thread Stephen Warren
On 03/20/2014 07:25 PM, Simon Glass wrote: > Hi Stephen, > > On 20 March 2014 12:57, Stephen Warren wrote: >> >> On 03/14/2014 01:37 PM, Simon Glass wrote: >>> Hi Stephen, >>> >>> On 13 March 2014 11:42, Stephen Warren wrote: From: Stephen Warren Much of arch/arm/cpu/tegra*-commo