Re: [U-Boot] [PATCH 03/20] cros_ec: Handle the single duplex requirement in cros_ec

2015-05-02 Thread Simon Glass
On 17 February 2015 at 15:29, Simon Glass wrote: > With several chips using the SPI protocol it seems better to put the single > duplex functionality in the EC rather than the SPI driver. > > Signed-off-by: Simon Glass > --- > > drivers/misc/cros_ec_spi.c | 23 --- > 1 file c

Re: [U-Boot] [PATCH 02/20] cros_ec: Show the protocol version in the debug message

2015-05-02 Thread Simon Glass
On 17 February 2015 at 15:29, Simon Glass wrote: > When starting up, show the protocol version that has been negotiated with > the EC. > > Signed-off-by: Simon Glass > --- > > drivers/misc/cros_ec.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) Applied to u-boot-dm.

Re: [U-Boot] [RESEND PATCH v3 00/13] Add Marvell Armada A38x 88F6820 SoC support

2015-05-02 Thread Simon Glass
Hi Stefan, On 24 April 2015 at 22:29, Stefan Roese wrote: > > This patch series adds support for the Marvell Armada A38x SoC's. Specifically > the 88F6820 / 88F6828. > > Basic support for the DB-88F6820-GP evaluation board is added. Supporting the > following interfaces: > - UART > - SPI (includi

Re: [U-Boot] [PATCH 01/20] dm: spi: Avoid setting the speed with every transfer

2015-05-02 Thread Simon Glass
On 17 February 2015 at 15:29, Simon Glass wrote: > > Only set the speed if it has changed from last time. Since the speed will > be 0 when the device is probed it will always be changed on the first > transfer after the device is probed. > > Signed-off-by: Simon Glass > --- > > drivers/spi/spi-u

Re: [U-Boot] [PATCH 1/2] test: Add a simple time test

2015-05-02 Thread Simon Glass
+Masahiro On 2 May 2015 at 09:25, Simon Glass wrote: > Sometimes the time functions are incorrect due to bad time support on a > board. Add a unit test which tries to detect this. > > Signed-off-by: Simon Glass > --- > > test/Kconfig | 8 > test/Makefile | 1 + > test/time_ut.c | 1

[U-Boot] [PATCH 2/2] sandbox: Enable time unit test command

2015-05-02 Thread Simon Glass
Enable this command for sandbox. Signed-off-by: Simon Glass --- configs/sandbox_defconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/configs/sandbox_defconfig b/configs/sandbox_defconfig index 5de7fbe..1a8da8d 100644 --- a/configs/sandbox_defconfig +++ b/configs/sandbox_defconfig @@ -2

[U-Boot] [PATCH 1/2] test: Add a simple time test

2015-05-02 Thread Simon Glass
Sometimes the time functions are incorrect due to bad time support on a board. Add a unit test which tries to detect this. Signed-off-by: Simon Glass --- test/Kconfig | 8 test/Makefile | 1 + test/time_ut.c | 137 + 3 files ch

Re: [U-Boot] [PATCH 3/3] test: dm: eth: Skip timeouts on ping tests

2015-05-02 Thread Simon Glass
On 23 April 2015 at 22:14, Simon Glass wrote: > On 21 April 2015 at 12:57, Joe Hershberger wrote: >> Indicate to the emulated sandbox Ethernet driver when we expect a >> timeout and tell it to leap forward. >> >> Signed-off-by: Joe Hershberger >> --- >> >> test/dm/eth.c | 2 ++ >> 1 file change

Re: [U-Boot] [PATCH 2/3] sandbox: eth: Add a function to skip ping timeouts

2015-05-02 Thread Simon Glass
On 23 April 2015 at 22:13, Simon Glass wrote: > On 21 April 2015 at 12:57, Joe Hershberger wrote: >> When called, the next call to receive will trigger a 10-second leap >> forward in time to avoid waiting for time to pass when tests are >> evaluating timeout behavior. >> >> Signed-off-by: Joe Her

Re: [U-Boot] [PATCH 1/3] sandbox: Add test function to advance time

2015-05-02 Thread Simon Glass
On 23 April 2015 at 22:13, Simon Glass wrote: > On 21 April 2015 at 12:57, Joe Hershberger wrote: >> Add a function that maintains an offset to include in the system timer >> values returned from the lib/time.c APIs. >> >> This will allow timeouts to be skipped instantly in tests >> >> Signed-off

Re: [U-Boot] [PATCH v2 1/2] stv0991: fdt: add stv0991 device tree

2015-05-02 Thread Simon Glass
Hi Vikas, On 1 May 2015 at 18:07, Vikas Manocha wrote: > This patch adds device tree for the ST Micro stv0991 board & enables > device tree control. Progressively device tree support for the drivers > being used will also be added. > > Signed-off-by: Vikas Manocha > --- > > Changes in v2: > - ad

Re: [U-Boot] [PATCH 5/5] nand: sunxi: And a20_nandread command utilizing spl nand read driver

2015-05-02 Thread Ian Campbell
On Wed, 2015-04-29 at 17:03 +0200, Daniel Kochmański wrote: > This patch adds a20_nandread command. It is simple function utilizing > function from SPL nand driver `nand_spl_load_image`. > > Usage: a20_nandread This stuff should really be integrated with cmd_nand.c rather than adding an adhoc

Re: [U-Boot] [PATCH 4/5] nand: sunxi: Add multiimage preload option

2015-05-02 Thread Ian Campbell
On Wed, 2015-04-29 at 17:03 +0200, Daniel Kochmański wrote: > Patch adds support in spl_nand for preloading multiimage before > loading u-boot into memory. It might be used in example to put in > memory single image containing boot script, kernel and device > tree. > > Behavior is triggered, if CO

Re: [U-Boot] [PATCH 3/5] nand: sunxi: Add secondary U-Boot offset on second syndrome partition

2015-05-02 Thread Ian Campbell
On Wed, 2015-04-29 at 17:02 +0200, Daniel Kochmański wrote: > Introduces CONFIG_SYS_NAND_U_BOOT_BACKUP_OFFS, pointing to backup > U-Boot instance in nand memory. In case if first header doesn't match, > tries to load bootloader from this offset. In case of both failing, > hang() is called. > > Add

Re: [U-Boot] [PATCH 2/5] nand: sunxi: Add support for booting from internal NAND memory

2015-05-02 Thread Ian Campbell
On Wed, 2015-04-29 at 17:02 +0200, Daniel Kochmański wrote: > diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig > index 88e3358..1a30684 100644 > --- a/board/sunxi/Kconfig > +++ b/board/sunxi/Kconfig > @@ -239,6 +239,18 @@ config MMC_SUNXI_SLOT_EXTRA > slot or emmc on mmc1 - mmc3. Settin

Re: [U-Boot] mx6cuboxi: PHY/FEC detection

2015-05-02 Thread Fabio Estevam
Hi Stefano and Vagrant, On Sat, May 2, 2015 at 5:54 AM, Stefano Babic wrote: > Good work ! I apply V2, then. Can you also send to a ML the two > additional patches from your previous e-mail ? They are not tracked > properly by patchwork. Thanks for testing the patches, Vagrant. I will submit t

Re: [U-Boot] [PATCH 1/5] nand: sunxi: change BLOCK_SIZE in mksunxiboot to match NAND block size

2015-05-02 Thread Ian Campbell
On Wed, 2015-04-29 at 17:02 +0200, Daniel Kochmański wrote: > This change is necessary to calculate correct checksum for NAND > boot. Works both for MMC and NAND. Without it BROM rejects boot image > as invalid (bad checksum). (Changes block size from 0x200 to 0x2000). I'm inferring here that for

Re: [U-Boot] [PATCH 8/8] sunxi: ehci: Convert to the driver-model

2015-05-02 Thread Ian Campbell
On Sat, 2015-05-02 at 15:03 +0100, Ian Campbell wrote: I see I missed v2, oh well, this bit of code looks the same AFAICT. > On Thu, 2015-04-30 at 16:35 +0200, Hans de Goede wrote: > > + if (hccr == (void *)SUNXI_USB1_BASE) { > > + priv->ahb_gate_mask = 1 << AHB_GATE_OFFSET_USB_EHCI0;

Re: [U-Boot] [PATCH 8/8] sunxi: ehci: Convert to the driver-model

2015-05-02 Thread Ian Campbell
On Thu, 2015-04-30 at 16:35 +0200, Hans de Goede wrote: > + if (hccr == (void *)SUNXI_USB1_BASE) { > + priv->ahb_gate_mask = 1 << AHB_GATE_OFFSET_USB_EHCI0; > + priv->phy_index = 1; Inferring these from the base address is a bit unfortunate, should we not get told this

Re: [U-Boot] [PATCH v2 6/6] sunxi: axp: Remove non driver-model support from the axp gpio code

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Now that all sunxi boards are using driver-model for gpio (*), we can remove > the non driver-model support from the axp gpio code, and the glue to call > into the axp gpio code from the sunxi_gpio non driver-model code. > > *) For the regu

Re: [U-Boot] [PATCH v2 5/6] sunxi: axp: Add driver-model support to the axp_gpio code

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Add driver-model support to the axp_gpio code, note that this needs a small > tweak to the driver-model version of sunxi_name_to_gpio to deal with the > vbus detect and enable pins which are not standard numbered gpios. > > Signed-off-by: H

Re: [U-Boot] [PATCH v2 4/6] sunxi: axp: Move axp gpio code to a separate axpi-gpio driver

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Move the axp-gpio code out of the drivers/power/axp*.c code, and into > a new separate axpi-gpio driver. > > This change drops supports for the gpio3 pin on the axp209, as that requires > special handling, and no boards are using it. > > B

Re: [U-Boot] [PATCH v2 3/6] sunxi: axp: Add support for i2c based PMICs to the pmic-bus helpers

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Add support for the axp152 and axp209 PMICs to the pmic register access > helpers. This is a preparation patch for moving the axp gpio code to a > separate gpio driver. > > Signed-off-by: Hans de Goede Acked-by: Ian Campbell __

Re: [U-Boot] [PATCH v2 2/6] sunxi: axp: Move axp pmic register helpers to a separate file

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Move the register helpers used to access the registers via p2wi resp. > rsb bus on the otherwise identical axp221 and axp223 pmics to a separate > file, so that they can be used by the upcoming standalone axp gpio driver > too. > > Signed-o

Re: [U-Boot] [PATCH v2 1/6] sunxi: axp: Change axp_gpio_foo prototypes to match gpio uclass ops

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:51 +0200, Hans de Goede wrote: > Change the axp_gpio_foo function prototypes to match the gpio uclass op > prototypes, this is a preparation patch for moving the axp gpio code to > a separate driver-model gpio driver. > > Note that the ugly calls with a NULL udev pointer i

Re: [U-Boot] [PATCH 20/21] sunxi: Move all boards to the device-model

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 12:06 +0200, Hans de Goede wrote: > I would be happy to see this fixed, but for now I've just copied what the > sandbox code is doing. OK, since Simon is happy with it I have no objections: Acked-by: Ian Campbell ___ U-Boot mail

Re: [U-Boot] [PATCH 18/21] sunxi: dts: Add minimal dts files for board which lack a dts sofar

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 11:57 +0200, Hans de Goede wrote: > Hi, > > On 26-04-15 05:30, Ian Campbell wrote: > > On Fri, 2015-04-24 at 15:48 +0200, Hans de Goede wrote: > >> u-boot has support for a number of boards for which a dts file still needs > >> to be written, add minimal dts files for these b

Re: [U-Boot] [PATCH 5/6] sunxi: usb: Do not call phy_probe from hcd code

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > The 2/3 usb-phys on the sunxi SoCs are really a single separate functional > block, and are modelled as such in devicetree. So once we've moved all the > sunxi usb code to the driver-model then phy_probe will be called once > for the entire

Re: [U-Boot] [PATCH 6/6] sunxi: usb: Protect phy-init and phy-power-on against multiple calls

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > Once we add support for the ohci controller the phy-init and phy-power-on > functions may be called twice (once by the ehci code and once by the ohci > code) protect them against this. > > Signed-off-by: Hans de Goede Acked-by: Ian Campbe

Re: [U-Boot] [PATCH 4/6] sunxi: usb: Rename the usbc.? files to usb_phy.?

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > The usbc.? files now only contain usb-phy related code, rename them to make > this clear. > > Signed-off-by: Hans de Goede Acked-by: Ian Campbell ___ U-Boot mailing list U-Boot@lists.denx.de

Re: [U-Boot] [PATCH 3/6] sunxi: usb: Rename sunxi_usbc_foo functions to sunxi_usb_phy_bar

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > Rename the sunxi_usbc_foo functions to sunxi_usb_phy_bar to make it clear > that these are usb-phy functions. Also change the verbs & nouns in the suffix > to match the verbs & nouns used in the Linux kernels generic phy framework. > > This

Re: [U-Boot] [PATCH 2/6] sunxi: usb: Remove sunxi_usbc_get_io_base function

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > This is the only function left in sunxi/usbc.c which is not phy related, > so remove it. > > This is a preparation patch for turning the usbc.c code into a proper > usb phy driver. > > Signed-off-by: Hans de Goede Acked-by: Ian Campbell

Re: [U-Boot] [PATCH 1/6] sunxi: usb: Move setup of host controller clocks to the host controller drivers

2015-05-02 Thread Ian Campbell
On Tue, 2015-04-28 at 08:41 +0200, Hans de Goede wrote: > The sunxi "usbc" code is mostly about phy setup, but currently also sets up > the host controller clocks, which is something which really belongs in the > host controller drivers, so move it there. > > This is a preparation patch for moving

Re: [U-Boot] [PATCH 06/10] sunxi: Add a33 dram init code

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 20:31 +0200, Hans de Goede wrote: > Ok, so I've gone over the entire dram init code another time, and I've > not been able to find a single place where I can add a define with a > meaningful name to replace the magic values. OK, thanks for double checking. > So no v2 for thi

Re: [U-Boot] [PATCH v2 08/10] sunxi: Add basic A33 basic support

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 20:52 +0200, Hans de Goede wrote: > From: Vishnu Patekar > > Enable full support for the A33 SoC including display, otg-usb, etc. > > Signed-off-by: Vishnu Patekar > Signed-off-by: Hans de Goede Acked-by: Ian Campbell > -#if defined(CONFIG_MACH_SUN8I_A23) > +#if define

Re: [U-Boot] [PATCH v2 03/10] sunxi: Introduce a hidden SUNXI_GEN_SUNxI Kconfig bool

2015-05-02 Thread Ian Campbell
On Sun, 2015-04-26 at 17:21 +0200, Hans de Goede wrote: > sun6i and newer (derived) SoCs such as the sun8i-a23, sun8i-a33 and sun9i > have a various things in common, like having separate ahb reset control > registers, the SID living inside the pmic, custom pmic busses, new style > watchdog, etc. >

Re: [U-Boot] [PATCH] sunxi: display: Align end of memory to work around a linux-4.0 bug

2015-05-02 Thread Ian Campbell
On Fri, 2015-04-24 at 20:39 +0200, Hans de Goede wrote: > Linux-4.0 as shipped has a bug causing it to not boot if the end of memory > is not aligned to a multiple of 2 MiB. For details see the linux-arm > mailing list post titled: > "Memory size unaligned to section boundary" > http://www.spinics.

Re: [U-Boot] [PATCH v2 4/4] logos: Add Solidrun's logo

2015-05-02 Thread Stefano Babic
Hi Fabio, On 30/04/2015 03:28, Fabio Estevam wrote: > From: Fabio Estevam > > Let Solidrun's logo appear on Cuboxi and Hummingboard by default. > > Signed-off-by: Rabeeh Khoury > Signed-off-by: Fabio Estevam > Reviewed-by: Tom Rini > --- Applied to u-boot-imx, thanks ! I was not able to fi

Re: [U-Boot] [PATCH v2 3/4] mx6cuboxi: Allow HDMI and USB keyboard to be stdout/stdin

2015-05-02 Thread Stefano Babic
On 30/04/2015 03:28, Fabio Estevam wrote: > From: Fabio Estevam > > There are users of Cuboxi and Hummingboard that use these boards without > connecting them to a USB/serial adapter. > > Allow such usage by allowing the HDMI port to act as stdout and USB keyboard > as stdin. > > The serial con

Re: [U-Boot] [PATCH v2 2/4] mx6cuboxi: Add USB host support

2015-05-02 Thread Stefano Babic
On 30/04/2015 03:28, Fabio Estevam wrote: > From: Fabio Estevam > > Enable USB Host1 port. > > Signed-off-by: Rabeeh Khoury > Signed-off-by: Fabio Estevam > --- Applied to u-boot-imx, thanks ! Best regards, Stefano Babic -- ==

Re: [U-Boot] [PATCH v2 1/4] mx6cuboxi: Add HDMI output support

2015-05-02 Thread Stefano Babic
On 30/04/2015 03:28, Fabio Estevam wrote: > From: Fabio Estevam > > Add HDMI output using PLL5 as the source for the IPU clocks, > and accurate VESA timings. > > These settings are based on the patch from Soeren Moch > submitted for the tbs2910 mx6 based board. > > It allows the display to wor

Re: [U-Boot] [PATCH] Fix mxc_hab documenation

2015-05-02 Thread Stefano Babic
On 20/04/2015 20:47, ulises.carde...@freescale.com wrote: > From: Ulises Cardenas > > It is necessary to modify the configuration file for the target > board. It wasn't well documented that to enable any of the secure > boot modes, it is required to add CONFIG_SECURE_BOOT to the board > configura

Re: [U-Boot] mx6cuboxi: PHY/FEC detection

2015-05-02 Thread Stefano Babic
Hi Fabio, Vagrant, On 02/05/2015 02:07, Vagrant Cascadian wrote: > On 2015-05-01, Fabio Estevam wrote: >> On Fri, May 1, 2015 at 5:20 PM, Fabio Estevam wrote: >> >>> Looking at Solid-run's tree they have the following commit that may be >>> related to this PHY issue: >> >> I applied Rabeeh's patc