Re: [U-Boot] [PATCH 2/3] common: env_flags: include common.h even for HOST_CC

2016-02-16 Thread Tom Rini
On Tue, Feb 16, 2016 at 11:19:43AM +, Peter Robinson wrote: > >> When compiling with gcc 6 we get the following error due to ARRAY_SIZE > >> being > >> defined elsewhere. > >> > >> common/env_flags.c:155: undefined reference to `ARRAY_SIZE' > >> > >> Signed-off-by: Peter Robinson > > > > I'm

Re: [U-Boot] [PATCH 00/26] spl: Support loading a FIT image containing U-Boot

2016-02-16 Thread Tom Rini
On Tue, Feb 16, 2016 at 08:34:59PM +0900, Masahiro Yamada wrote: > Hi Simon, > > > 2016-01-29 1:39 GMT+09:00 Simon Glass : > > We need a way to support more than one board per binary in U-Boot with > > device tree. Various methods have been discussed. The one that seems to make > > the most sense

[U-Boot] [PATCH] test/py: only check for SPL signature if SPL uses serial output

2016-02-16 Thread Heiko Schocher
check for U-Boot SPL signature only if SPL really has a serial output. So check if CONFIG_SPL_SERIAL_SUPPORT is active in board config. Signed-off-by: Heiko Schocher --- found this while trying test/py on the smartweb board, which has SPL but no SPL serial output. test/py/u_boot_console_base.py

[U-Boot] test/py main_signon

2016-02-16 Thread Michal Simek
Hi Stephen, trying to run the latest testing on zynq board and getting this main_signon error. This is what I am running ./test/py/test.py --bd zynq_zc702 --build --board-identity zc702 and getting below. Thanks, Michal U-Boot 2016.03-rc2 (Feb 16 2016 - 13:10:03 +0100) Model: Zynq ZC702 Devel

Re: [U-Boot] [PATCH 00/26] spl: Support loading a FIT image containing U-Boot

2016-02-16 Thread Masahiro Yamada
Hi Simon, 2016-01-29 1:39 GMT+09:00 Simon Glass : > We need a way to support more than one board per binary in U-Boot with > device tree. Various methods have been discussed. The one that seems to make > the most sense is to adjust SPL so that it can load a FIT which contains > U-Boot and several

Re: [U-Boot] [PATCH 2/3] common: env_flags: include common.h even for HOST_CC

2016-02-16 Thread Peter Robinson
>> When compiling with gcc 6 we get the following error due to ARRAY_SIZE being >> defined elsewhere. >> >> common/env_flags.c:155: undefined reference to `ARRAY_SIZE' >> >> Signed-off-by: Peter Robinson > > I'm going to take http://patchwork.ozlabs.org/patch/582527/ to fix this > instead as I don

Re: [U-Boot] [PATCH 08/30] dm: blk: Add comments to a few functions

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > The block interface is not well documented in the code. Pick two important > functions and add comments. > > Signed-off-by: Simon Glass > --- > > include/part.h | 30 ++ > 1 file changed, 30 insertions(+) > Revie

Re: [U-Boot] [PATCH 09/30] dm: blk: Rename get_dev() to blk_get_dev()

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > The current name is too generic. Add a 'blk_' prefix to aid searching and > make its purpose clearer. > > Signed-off-by: Simon Glass > --- > > api/api_storage.c | 12 +++- > cmd/gpt.c | 2 +- > cmd/read.c| 2 +- > c

Re: [U-Boot] [PATCH 06/30] dm: Add a new header for block devices

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > At present block devices are tied up with partitions. But not all block > devices have partitions within them. They are in fact separate concepts. > > Create a separate blk.h header file for block devices. > > Signed-off-by: Simon Glass > ---

Re: [U-Boot] [PATCH 07/30] dm: blk: Convert interface type to an enum

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > Since these are sequentially numbered it makes sense to use an enum. It > avoids having to maintain the maximum value, and provides a type we can use > if it useful. if it *is* useful? > > In fact the maximum value is not used. Re

Re: [U-Boot] [PATCH 05/30] dm: part: Drop the common.h header

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > We should not include in header files. Each C file should include > it if needed. > > Signed-off-by: Simon Glass > --- > > include/part.h | 1 - > 1 file changed, 1 deletion(-) > Reviewed-by: Bin Meng _

Re: [U-Boot] [PATCH 01/30] dm: Drop the block_dev_desc_t typedef

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > Use 'struct' instead of a typdef. Also since 'struct block_dev_desc' is long > and causes 80-column violations, rename it to struct blk_desc. > > Signed-off-by: Simon Glass > --- > > api/api.c | 2 +- > api/api_storage.c

Re: [U-Boot] [PATCH 03/30] dm: part: Correct a sandbox build warning

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > Adjust the cast to avoid a warning when stdint.h is used. > > Signed-off-by: Simon Glass > --- > > disk/part_efi.c | 10 ++ > 1 file changed, 6 insertions(+), 4 deletions(-) > > diff --git a/disk/part_efi.c b/disk/part_efi

Re: [U-Boot] [PATCH 02/30] dm: pci: Break out the common region display code

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass wrote: > Each region is displayed in almost the same way. Break out this common code > into its own function. > > Signed-off-by: Simon Glass > --- > > drivers/pci/pci_auto_common.c | 51 > +++ > 1 f

Re: [U-Boot] [PATCH 1/2] dm: core: Add uclass_first_device_err() to return a valid device

2016-02-16 Thread Bin Meng
Hi Simon, On Fri, Feb 12, 2016 at 4:23 AM, Simon Glass wrote: > A common pattern is to call uclass_first_device() and then check if it > actually returns a device. Add a new function which does this, returning > an error if there are no devices in that uclass. > > Signed-off-by: Simon Glass > --

Re: [U-Boot] [PATCH 12/16] sandbox: Enable the early timer

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > Enable this so that tracing works with sandbox. > > Signed-off-by: Simon Glass > --- > > configs/sandbox_defconfig | 1 + > 1 file changed, 1 insertion(+) > Reviewed-by: Bin Meng ___ U-Boot mailin

Re: [U-Boot] [PATCH 10/16] sandbox: timer: Support the early timer

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > Add support for the early timer so we can use tracing with sandbox again. > > Signed-off-by: Simon Glass > --- > > drivers/timer/sandbox_timer.c | 14 -- > 1 file changed, 12 insertions(+), 2 deletions(-) > > diff --git

Re: [U-Boot] [PATCH 07/16] timer: Support tracing fully

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > A few of the functions in the timer uclass are not marked with 'notrace'. Fix > this so that tracing can be used with CONFIG_TRACE. > > Signed-off-by: Simon Glass > --- > > drivers/timer/timer-uclass.c | 6 +++--- > 1 file changed,

Re: [U-Boot] [PATCH 08/16] timer: Provide an early timer

2016-02-16 Thread Bin Meng
Hi Simon, On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > In some cases the timer must be accessible before driver model is active. > Examples include when using CONFIG_TRACE to trace U-Boot's execution before > driver model is set up. Enable this option to use an early timer. These > funct

Re: [U-Boot] [PATCH 09/16] timer: Set up the real timer after driver model is available

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > When using the early timer, we need to manually trigger setting up the > real timer. This will not happen automatically. Do this immediately after > starting driver model. > > Signed-off-by: Simon Glass > --- > > common/board_f.c | 6 ++

Re: [U-Boot] [PATCH 04/16] trace: Fix compiler warnings in trace

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > With min() we must use the same type for each parameter. Fix two problems > in trace.c which produce compiler warnings. > > Signed-off-by: Simon Glass > --- > > cmd/trace.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > Review

Re: [U-Boot] [PATCH 05/16] lib: Don't instrument the div64 function

2016-02-16 Thread Bin Meng
On Mon, Feb 15, 2016 at 9:36 AM, Simon Glass wrote: > This function can be called from the timer code on instrumented functions. > Mark it as 'notrace' so that it doesn't cause infinite recursion. > > Signed-off-by: Simon Glass > --- > > lib/div64.c | 3 ++- > 1 file changed, 2 insertions(+), 1

[U-Boot] [PATCH] fixup! gpio: uniphier: add driver for UniPhier GPIO controller

2016-02-16 Thread Masahiro Yamada
Signed-off-by: Masahiro Yamada --- doc/README.uniphier | 1 + 1 file changed, 1 insertion(+) diff --git a/doc/README.uniphier b/doc/README.uniphier index 47b4d78..5ac52bd 100644 --- a/doc/README.uniphier +++ b/doc/README.uniphier @@ -110,6 +110,7 @@ Supported devices - SD/eMMC - USB 2.0 (EH

Re: [U-Boot] [PATCH] fastboot: update error and warning messages

2016-02-16 Thread Lukasz Majewski
Hi Marek, > On 02/16/2016 02:20 AM, Steve Rae wrote: > > ping -- Thanks! > > > > On 16-01-27 03:42 PM, Marek Vasut wrote: > >> On Thursday, January 28, 2016 at 12:02:41 AM, Steve Rae wrote: > >>> Fix the formatting in error messages, and demote one error message > >>> to a warning, as it is only

Re: [U-Boot] [PATCH v2] ARM: at91: sama5d2: configure the L2 cache memory

2016-02-16 Thread Yang, Wenyou
> -Original Message- > From: Samuel Mescoff [mailto:samuel.mesc...@mobile-devices.fr] > Sent: 2016年2月16日 16:45 > To: u-boot@lists.denx.de > Cc: Samuel Mescoff ; > andreas.de...@googlemail.com; Yang, Wenyou ; > Ferre, Nicolas > Subject: [U-Boot] [PATCH v2] ARM: at91: sama5d2: configure th

[U-Boot] [PATCH v2] ARM: at91: sama5d2: configure the L2 cache memory

2016-02-16 Thread Samuel Mescoff
The SAMA5D2 has a second internal SRAM that can be reassigned as a L2 cache memory. Make sure it is configured as a L2 cache memory when booting from a SPL image. Based on the commit b5ea95ef2b5b from the at91bootstrap repository. Signed-off-by: Samuel Mescoff --- Changes for v2: - removed use

Re: [U-Boot] [PATCH v2 1/3] mmc: uniphier: add driver for UniPhier SD/MMC host controller

2016-02-16 Thread Masahiro Yamada
Hi Marek, 2016-02-10 22:45 GMT+09:00 Marek Vasut : > On 02/10/2016 02:28 PM, Masahiro Yamada wrote: >> Add a driver for the on-chip SD/eMMC host controller used by >> UniPhier SoC family. >> >> Signed-off-by: Masahiro Yamada > > 前略 山田さん, > > [...] > >> +#include >> +#include >> +#include >> +

[U-Boot] [PATCH 3/4] ARM: uniphier: add emmcupdate command

2016-02-16 Thread Masahiro Yamada
The Boot ROM expects the boot image (SPL) in the Boot Partition 1. So, updating images involves the hardware partition switch. It might be a bit advanced for some users. To be user-friendly, this commit adds a useful command to update the images; just put SPL and U-Boot proper into the public dir

[U-Boot] [PATCH 2/4] ARM: uniphier: add a command to find the first MMC (non-SD) device

2016-02-16 Thread Masahiro Yamada
UniPhier SoC family supports both (e)MMC boot and SD card boot; however, both of them are handled in the same uclass. When booting from the eMMC, we want to know the device number of the (e)MMC, not SD. This command is useful to find the first MMC (non-SD) device. Signed-off-by: Masahiro Yamada

[U-Boot] [PATCH 1/4] ARM: uniphier: add eMMC boot support

2016-02-16 Thread Masahiro Yamada
Export device nodes needed for eMMC boot (eMMC node, pinctrl, and clock) to the SPL DTB. CONFIG_SUPPORT_EMMC_BOOT is also necessary to use "mmc partconf" command. Signed-off-by: Masahiro Yamada --- arch/arm/dts/uniphier-ph1-pro4-sanji.dts | 12 arch/arm/dts/uniphier-proxstream

[U-Boot] [PATCH 0/4] ARM: uniphier: eMMC boot support

2016-02-16 Thread Masahiro Yamada
Masahiro Yamada (4): ARM: uniphier: add eMMC boot support ARM: uniphier: add a command to find the first MMC (non-SD) device ARM: uniphier: add emmcupdate command ARM: uniphier: default to environment in eMMC arch/arm/dts/uniphier-ph1-pro4-sanji.dts | 12 + arch/arm/dts/uniphier

[U-Boot] [PATCH 4/4] ARM: uniphier: default to environment in eMMC

2016-02-16 Thread Masahiro Yamada
Of the several boot devices supported, it looks like the eMMC is the most commonly used. Enable CONFIG_ENV_IS_IN_MMC by default. Signed-off-by: Masahiro Yamada --- arch/arm/mach-uniphier/boot-mode/boot-mode.c | 5 + include/configs/uniphier.h | 12 ++-- 2 files c

[U-Boot] [PATCH v3 1/3] mmc: uniphier: add driver for UniPhier SD/MMC host controller

2016-02-16 Thread Masahiro Yamada
Add a driver for the on-chip SD/eMMC host controller used by UniPhier SoC family. Signed-off-by: Masahiro Yamada --- Changes in v3: - Use dev_err/dev_dbg instead of pr_err/pr_debug - Tidy up uniphier_sd_set_ios() - Allow to use DMA even in SPL if the target address is DMA'able Changes in

[U-Boot] [PATCH v3 3/3] ARM: dts: uniphier: add SD/MMC host controller nodes

2016-02-16 Thread Masahiro Yamada
This host controller is available for all UniPhier SoCs. Signed-off-by: Masahiro Yamada --- Changes in v3: None Changes in v2: None arch/arm/dts/uniphier-ph1-ld4-ref.dts| 4 +++ arch/arm/dts/uniphier-ph1-ld4.dtsi | 25 +++ arch/arm/dts/uniphier-ph1-ld6b-ref.d

[U-Boot] [PATCH v3 0/3] UniPhier SD/eMMC controller driver

2016-02-16 Thread Masahiro Yamada
Changes in v3: - Use dev_err/dev_dbg instead of pr_err/pr_debug - Tidy up uniphier_sd_set_ios() - Allow to use DMA even in SPL if the target address is DMA'able Changes in v2: - Fix the divisor bug on the older IP (on PH1-LD4, PH1-sLD8, PH1-Pro4) - Increase time out because "mmc erase"

[U-Boot] [PATCH v3 2/3] ARM: uniphier: enable UniPhier SD/MMC host driver

2016-02-16 Thread Masahiro Yamada
Enable the driver in all UniPhier defconfig files and add some needed defines to the common files. Signed-off-by: Masahiro Yamada --- Changes in v3: None Changes in v2: None arch/arm/Kconfig | 1 + configs/uniphier_ld4_sld8_defconfig | 1 + configs/uniphier_pro4_defconfig

[U-Boot] [PATCH v4 0/4] UniPhier: add GPIO support

2016-02-16 Thread Masahiro Yamada
Changes in v4: - set uc_priv->bank_name Changes in v3: - one gpio bank per register Changes in v2: - Do not use "ngpio" property to specify the number of GPIO pins. Instead, use .data field of OF match table. Masahiro Yamada (4): gpio: uniphier: add driver for UniPhier GPIO control

[U-Boot] [PATCH v4 3/4] ARM: uniphier: enable GPIO command and driver for UniPhier SoCs

2016-02-16 Thread Masahiro Yamada
This allows to use the "gpio" command. Signed-off-by: Masahiro Yamada Acked-by: Simon Glass --- Changes in v4: None Changes in v3: None Changes in v2: None arch/arm/Kconfig | 1 + configs/uniphier_ld4_sld8_defconfig | 2 ++ configs/uniphier_pro4_defconfig | 2 ++ con

[U-Boot] [PATCH v4 4/4] ARM: dts: uniphier: add GPIO controller nodes

2016-02-16 Thread Masahiro Yamada
Make the GPIO driver really active. Signed-off-by: Masahiro Yamada --- Changes in v4: None Changes in v3: None Changes in v2: None arch/arm/dts/uniphier-ph1-ld4.dtsi | 112 ++ arch/arm/dts/uniphier-ph1-pro4.dtsi| 203 + arch/arm/dts/uniph

[U-Boot] [PATCH v4 1/4] gpio: uniphier: add driver for UniPhier GPIO controller

2016-02-16 Thread Masahiro Yamada
This GPIO controller device is used on UniPhier SoCs. Signed-off-by: Masahiro Yamada Acked-by: Simon Glass --- Changes in v4: - set uc_priv->bank_name Changes in v3: - one gpio bank per register Changes in v2: - Do not use "ngpio" property to specify the number of GPIO pins. Instead

[U-Boot] [PATCH v4 2/4] gpio: do not include for UniPhier

2016-02-16 Thread Masahiro Yamada
I implemented a GPIO driver based on Driver Model for the UniPhier SoC family, but I could not find any good reason why such SoC specific GPIO headers are needed. Signed-off-by: Masahiro Yamada Acked-by: Simon Glass --- Changes in v4: None Changes in v3: None Changes in v2: None arch/arm/incl

[U-Boot] [PATCH] ARM: dts: uniphier: rework System Bus nodes

2016-02-16 Thread Masahiro Yamada
Follow the changes of DTS in Linux. Signed-off-by: Masahiro Yamada --- arch/arm/dts/uniphier-common32.dtsi | 19 ++- arch/arm/dts/uniphier-ph1-sld3.dtsi | 20 ++-- 2 files changed, 20 insertions(+), 19 deletions(-) diff --git a/arch/arm/dts/uniphier-common32.dts

<    1   2