[U-Boot] [PATCH v3] pci: Device scanning range fix

2016-04-24 Thread Yoshinori Sato
The terminal condition in the area where a PCI device is scanned is wrong, and 1f.7 isn't scanned. Signed-off-by: Yoshinori Sato --- drivers/pci/pci-uclass.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/pci/pci-uclass.c b/drivers/pci/pci-uclass.c index c7fbf7b..325

Re: [U-Boot] [PATCH] dfu: ram: fix number base of RAM entity parameters

2016-04-24 Thread Mugunthan V N
On Saturday 23 April 2016 01:04 AM, Stephen Warren wrote: > From: Stephen Warren > > U-Boot typically interprets unprefixed numbers as base 16, and DFU RAM > entity parsing has historically done so. Reverse the change to default > to base 10, so that values in previously working command-lines are

[U-Boot] [PATCH 1/9] dm: fsl_i2c: Rename I2C register structure

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- arch/m68k/include/asm/fsl_i2c.h | 2 +- arch/powerpc/include/asm/fsl_i2c.h| 2 +- arch/powerpc/include/asm/immap_85xx.h | 4 +- arch/powerpc/include/asm/immap_86xx.h | 4 +- board/keymile/km83xx/km83xx_i2c.c | 28 drivers/i2c/fsl_i2c.c

Re: [U-Boot] [PATCH v2] pci: Device scanning range fix.

2016-04-24 Thread Yoshinori Sato
On Mon, 25 Apr 2016 15:27:19 +0900, Bin Meng wrote: > > Hi Yoshinori, > > On Mon, Apr 25, 2016 at 2:14 PM, Yoshinori Sato > wrote: > > The terminal condition in the area where a PCI device is scanned is wrong, > > and 1f.7 isn't scanned. > > > > Changes v2: > > - update commit message. > > Plea

[U-Boot] [PATCH 9/9] dm: fsl_i2c: Enable DM for FSL I2C

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- arch/powerpc/include/asm/fsl_i2c.h | 10 drivers/i2c/Kconfig| 7 +++ drivers/i2c/fsl_i2c.c | 103 + 3 files changed, 120 insertions(+) diff --git a/arch/powerpc/include/asm/fsl_i2c.h b/arch/pow

[U-Boot] [PATCH 7/9] dm: fsl_i2c: Prepare compatibility functions

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 47 +++ 1 file changed, 39 insertions(+), 8 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index b838afd..06f1db4 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fsl_i2c

[U-Boot] [PATCH 5/9] dm: fsl_i2c: Rename probe method

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index 4bc1dda..3a38713 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fsl_i2c.c @@ -494,7 +494,7 @@ fsl_i2c_write(s

[U-Boot] [PATCH 6/9] dm: fsl_i2c: Rename methods for reading/writing data

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index 3a38713..b838afd 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fsl_i2c.c @@ -366,7 +366,7 @@ i2c_write

[U-Boot] [PATCH 8/9] dm: fsl_i2c: Factor out adap parameter

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 116 +- 1 file changed, 49 insertions(+), 67 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index 06f1db4..7d99f48 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fs

[U-Boot] [PATCH 2/9] dm: fsl_i2c: Use clearer parameter names

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 63 ++- 1 file changed, 32 insertions(+), 31 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index 70c7cba..b0e65fc 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fs

[U-Boot] [PATCH 3/9] dm: fsl_i2c: Reword and clarify comment

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 20 ++-- 1 file changed, 6 insertions(+), 14 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index b0e65fc..18b8848 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fsl_i2c.c @@ -428,22 +428,14 @@ fs

[U-Boot] [PATCH 4/9] dm: fsl_i2c: Remove unnecessary variable

2016-04-24 Thread Mario Six
Signed-off-by: Mario Six --- drivers/i2c/fsl_i2c.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c index 18b8848..4bc1dda 100644 --- a/drivers/i2c/fsl_i2c.c +++ b/drivers/i2c/fsl_i2c.c @@ -423,7 +423,6 @@ fsl_i2c_read(struct i

[U-Boot] [PATCH 0/9] dm: fsl_i2c: Make FSL I2C driver compatible with DM

2016-04-24 Thread Mario Six
This patch series implements DM for the Freescale I2C driver (as used on MPC8XXX processors) and does some minor refactoring of some functions. Mario Six (9): dm: fsl_i2c: Rename I2C register structure dm: fsl_i2c: Use clearer parameter names dm: fsl_i2c: Reword and clarify comment dm: fsl

Re: [U-Boot] [PATCH v2] pci: Device scanning range fix.

2016-04-24 Thread Bin Meng
Hi Yoshinori, On Mon, Apr 25, 2016 at 2:14 PM, Yoshinori Sato wrote: > The terminal condition in the area where a PCI device is scanned is wrong, > and 1f.7 isn't scanned. > > Changes v2: > - update commit message. Please hide this "changes v2" from the commit message. Also nits: please remove

[U-Boot] [PATCH v2] pci: Device scanning range fix.

2016-04-24 Thread Yoshinori Sato
The terminal condition in the area where a PCI device is scanned is wrong, and 1f.7 isn't scanned. Changes v2: - update commit message. Signed-off-by: Yoshinori Sato --- drivers/pci/pci-uclass.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/pci/pci-uclass.c b/drive

Re: [U-Boot] [PATCH] mtd, ubi: set free_count to zero before walking through erase list

2016-04-24 Thread Heiko Schocher
Hello Boris, Am 22.04.2016 um 14:21 schrieb Boris Brezillon: On Fri, 22 Apr 2016 13:53:00 +0200 Heiko Schocher wrote: An alternative approach would be not executing work directly while scheduling it but in produce_free_peb(). UBI is designed to work with the worker being disabled. All UBI w

[U-Boot] Pull request: u-boot-ubi/master

2016-04-24 Thread Heiko Schocher
Hello Tom, please pull from u-boot-ubi.git master This pull request contains 2 bugfixes for UBI/UBIFS, so I think, they should go into the next release. The following changes since commit ee8b25fa354da7cfaafe0e6781e873c74c29bbad: Prepare v2016.05-rc2 (2016-04-21 09:37:33 -0400) are availabl

[U-Boot] [PATCH] dm: at91: Add driver model support for the spi driver

2016-04-24 Thread Wenyou Yang
Add driver model support while retaining the existing legacy code. This allows the driver to support boards that have converted to driver model as well as those that have not. Signed-off-by: Wenyou Yang --- drivers/spi/Kconfig | 9 ++ drivers/spi/atmel_spi.c | 254

[U-Boot] [PATCH] ARM: dts: zynq: describe SLCR as simple-mfd rather than simple-bus

2016-04-24 Thread Masahiro Yamada
Commit 9f56917ab88a ("dm: core: make simple-bus compatible to simple-mfd") made possible to import the following commit: Linux commit: bc5ba9b98435bf76d92e0954da1784695aa449f1 The SLCR (System-Level Control Registers) block is an MFD (Multi Function Device) rather than a bus. "simple-mfd" seems

Re: [U-Boot] SAMA5D2 xplained SD/eMMC boot

2016-04-24 Thread Yang, Wenyou
Hi Marek, > -Original Message- > From: Marek Vasut [mailto:ma...@denx.de] > Sent: 2016年4月22日 20:18 > To: Yang, Wenyou > Cc: u-boot@lists.denx.de > Subject: Re: SAMA5D2 xplained SD/eMMC boot > > On 04/22/2016 02:54 AM, Yang, Wenyou wrote: > > Hi Marek, > > Hi! > > >> -Original Messa

[U-Boot] [PATCH V4, 1/6] dm: gpio: add a default gpio xlate routine

2016-04-24 Thread Eric Nelson
Many drivers use a common form of offset + flags for device tree nodes. e.g.: <&gpio1 2 GPIO_ACTIVE_LOW> This patch adds a common implementation of this type of parsing and calls it when a gpio driver doesn't supply its' own xlate routine. This will allow removal of the driver-specific ve

Re: [U-Boot] [RESEND PATCH V3 1/6] dm: gpio: add a default gpio xlate routine

2016-04-24 Thread Eric Nelson
Thanks Stephen, On 04/21/2016 10:03 AM, Stephen Warren wrote: > On 04/20/2016 09:37 AM, Eric Nelson wrote: >> Many drivers use a common form of offset + flags for device >> tree nodes. e.g.: >> <&gpio1 2 GPIO_ACTIVE_LOW> >> >> This patch adds a common implementation of this type of parsing >>

[U-Boot] [PATCH v3 2/2] m68k: add DM model serial driver

2016-04-24 Thread Angelo Dureghello
Boards can now use DM serial driver, or still legacy mcf uart driver version. Signed-off-by: Angelo Dureghello --- Changes for v2: - remove while loops in putc and getc, replacing with return -EAGAIN - remove unneeded ifdef Changes for v3: - no changes --- drivers/serial/mcfuart.c | 188

[U-Boot] [PATCH v3 1/2] m68k: add malloc memory for early malloc

2016-04-24 Thread Angelo Dureghello
To use serial uclass and DM, CONFIG_SYS_MALLOC_F must be used. So CONFIG_SYS_GENERIC_GLOBAL_DATA has been undefined and call to board_init_f_mem() is added for all cpu's. Signed-off-by: Angelo Dureghello --- Changes for v2: - none Changes for v3: - fix start.S using new board_init_f_alloc_

[U-Boot] [U-BOOT] [RFC PATCH] EMAC driver for H3/A64

2016-04-24 Thread Amit Singh Tomar
Hello I wanted to contribute and in the process trying to add support for the driver for EMAC controller found on H3/A64 based SoC. Sorry, I don't want to post it at this moment but I am kind of stuck from last few days. What is working: - Able to establish the link between hos

[U-Boot] Problem: loading U-Boot from NAND while running SPL from SRAM

2016-04-24 Thread Ahmed Samir
Hello, Please, I'd like to ask for help/suggestions regarding the following problem that I have: The problem is regarding making SPL (in SRAM) to booting U-boot from 16 bit NAND. While configuring & debugging, I did run SPL from address in the SDRAM, & it worked fine & loaded U-boot successfully.

[U-Boot] [PATCH 2/4] configs: Re-sync CONFIG_USB_MUSB_HOST

2016-04-24 Thread Tom Rini
With CONFIG_USB_MUSB_HOST being in Kconfig, move to defconfig files. Signed-off-by: Tom Rini --- configs/am335x_baltos_defconfig | 1 + configs/am335x_boneblack_defconfig | 1 + configs/am335x_boneblack_vboot_defconfig | 1 + configs/am335x_evm_defconfig | 1 + configs

[U-Boot] [PATCH 0/4] configs and cmd/Kconfig: Re-sync

2016-04-24 Thread Tom Rini
Hey all, The following series will be applied by me in about 24 hours (to give folks a chance to scream). At the end of this series, we have the current contents of cmd/Kconfig being entirely removed from include/configs* and done in the defconfig files. This shows a few things which do need to

[U-Boot] [PATCH] imx: mx6: mx6sl_pins: add GPIO variant for SD1_DAT5

2016-04-24 Thread Eric Nelson
This patch adds the IOMUX setting for using SD1_DAT5 as GPIO5:9. Signed-off-by: Eric Nelson --- arch/arm/include/asm/arch-mx6/mx6sl_pins.h | 1 + 1 file changed, 1 insertion(+) diff --git a/arch/arm/include/asm/arch-mx6/mx6sl_pins.h b/arch/arm/include/asm/arch-mx6/mx6sl_pins.h index 6ba1034..9

Re: [U-Boot] [PATCH 02/60] mmc: tegra: move pad init into MMC driver

2016-04-24 Thread Wolfgang Denk
Dear Stephen, In message <1461099580-3866-3-git-send-email-swar...@wwwdotorg.org> you wrote: > > /* > + * Copyright 2011-2016 NVIDIA Corporation > * (C) Copyright 2009 SAMSUNG Electronics > * Minkyu Kang > * Jaehoon Chung > - * Portions Copyright 2011-2015 NVIDIA Corporation > * > *

Re: [U-Boot] [PATCH 13/60] ARM: tegra: sort some board file include directives

2016-04-24 Thread Wolfgang Denk
Dear Stephen, In message <1461099580-3866-14-git-send-email-swar...@wwwdotorg.org> you wrote: > > --- a/board/avionic-design/common/tamonten-ng.c > +++ b/board/avionic-design/common/tamonten-ng.c > @@ -1,18 +1,19 @@ > /* > * (C) Copyright 2013 > * Avionic Design GmbH > + * Copyright (c) 201

Re: [U-Boot] [PATCH 05/60] pwm: tegra: move header file to driver directory

2016-04-24 Thread Wolfgang Denk
Dear Stephen, In message <1461099580-3866-6-git-send-email-swar...@wwwdotorg.org> you wrote: > > Tegra's pwm.h only contains private definitions for use inside the Tegra > PWM driver. Move it out of the global include directory since nothing > needs to access it there. If I understand correctly,

Re: [U-Boot] [PATCH 01/60] ARM: tegra: remove unused definitions in headers

2016-04-24 Thread Wolfgang Denk
Dear Stephen, In message <1461099580-3866-2-git-send-email-swar...@wwwdotorg.org> you wrote: > ... > /* > * Copyright (c) 2011 The Chromium OS Authors. > + * Copyright (c) 2016, NVIDIA CORPORATION. All rights reserved. Can you please get rid of this "All rights reserved." ? Please fix this g