[U-Boot] [PATCH 1/2][v2] board: freescale: ls1012a: Enable secure DDR on LS1012A platforms

2016-12-29 Thread Prabhakar Kushwaha
PPA binary needs to be relocated on secure DDR, hence marking out a portion of DDR as secure if CONFIG_SYS_MEM_RESERVE_SECURE flag is set Signed-off-by: Hou Zhiqiang Signed-off-by: Abhimanyu Saini Signed-off-by: Prabhakar Kushwaha

[U-Boot] eeprom with i2c (instead spi)

2016-12-29 Thread Ran Shalit
Hello, I'm trying to use eeprom with u-boot. I've added CONFIG_CMD_EEPROM, But then I see that the file uses spi eeprom (because config use CONFIG_SPI for other devices - not eeprom). Does it mean I just need to #undef CONFIG_SPI at the start of cmd_eeprom.c file ? Thank you! Ran

Re: [U-Boot] [PATCH 00/11] mmc: clean the sdhci host controller

2016-12-29 Thread Jaehoon Chung
Hi Kever, On 12/30/2016 03:55 PM, Kever Yang wrote: > Hi Jaehoon, > > > On 12/30/2016 02:30 PM, Jaehoon Chung wrote: >> It's cleaned the condes related to SDHCI host controller. >> Move the callback function into sdhci_ops structure. >> And removed the unnecessary things. >> >> My next step

Re: [U-Boot] [PATCH 00/11] mmc: clean the sdhci host controller

2016-12-29 Thread Kever Yang
Hi Jaehoon, On 12/30/2016 02:30 PM, Jaehoon Chung wrote: It's cleaned the condes related to SDHCI host controller. Move the callback function into sdhci_ops structure. And removed the unnecessary things. My next step should be more clearly than now. - Support DM feature than now. - Make

Re: [U-Boot] [PATCHv2] power: change from meaningless value to error number

2016-12-29 Thread Jaehoon Chung
Hi all, On 12/18/2016 07:48 AM, Simon Glass wrote: > On 15 December 2016 at 04:49, Jaehoon Chung wrote: >> '-1' is absolutely meaningless value. >> This patch changed from meaningless value to error number. >> >> Signed-off-by: Jaehoon Chung >>

[U-Boot] [PATCH 11/11] mmc: sdhci: combine the Host controller v3.0 feature into one condition

2016-12-29 Thread Jaehoon Chung
It doesn't need to seperate the condition. Signed-off-by: Jaehoon Chung --- drivers/mmc/sdhci.c | 17 +++-- 1 file changed, 7 insertions(+), 10 deletions(-) diff --git a/drivers/mmc/sdhci.c b/drivers/mmc/sdhci.c index 5d8969a..3a1f4f7 100644 ---

[U-Boot] [PATCH 10/11] mmc: sdhci: remove the SDHCI_QUIRK_NO_SIMULT_VDD_AND_POWER

2016-12-29 Thread Jaehoon Chung
Ther is no usage anywhere. It doesn't need to maintain this bit. Signed-off-by: Jaehoon Chung --- drivers/mmc/sdhci.c | 3 --- include/sdhci.h | 1 - 2 files changed, 4 deletions(-) diff --git a/drivers/mmc/sdhci.c b/drivers/mmc/sdhci.c index 6ce5e8f..5d8969a 100644

[U-Boot] [PATCH 09/11] mmc: sdhci: use the bitops APIs in sdhci.h

2016-12-29 Thread Jaehoon Chung
The using the bitops is too easy controlling than now. Signed-off-by: Jaehoon Chung --- include/sdhci.h | 112 1 file changed, 56 insertions(+), 56 deletions(-) diff --git a/include/sdhci.h b/include/sdhci.h index

[U-Boot] [PATCH 03/11] mmc: sdhci: remove the unused code about testing Card detect

2016-12-29 Thread Jaehoon Chung
This code is dead code..There is no usage anywhere. Signed-off-by: Jaehoon Chung --- drivers/mmc/sdhci.c | 11 --- 1 file changed, 11 deletions(-) diff --git a/drivers/mmc/sdhci.c b/drivers/mmc/sdhci.c index 853c268..c512a4c 100644 --- a/drivers/mmc/sdhci.c +++

[U-Boot] [PATCH 08/11] mmc: sdhci: move the callback function into sdhci_ops

2016-12-29 Thread Jaehoon Chung
callback function should be moved into sdhci_ops struct. Other controller can use these ops for controlling clock or their own specific register. Signed-off-by: Jaehoon Chung --- drivers/mmc/s5p_sdhci.c | 9 ++--- drivers/mmc/sdhci.c | 8

[U-Boot] [PATCH 07/11] mmc: s5p_sdhci: add the s5p_set_clock function

2016-12-29 Thread Jaehoon Chung
Add the s5p_set_clock function. It's not good that "set_mmc_clk" is assigned directly. In future, it should be changed to use the clock framework. Signed-off-by: Jaehoon Chung --- drivers/mmc/s5p_sdhci.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff

[U-Boot] [PATCH 05/11] mmc: sdhci: remove the SDHCI_QUIRK_NO_CD

2016-12-29 Thread Jaehoon Chung
This quirk doesn't need anymore. It's replaced to get_cd callback function. Signed-off-by: Jaehoon Chung --- drivers/mmc/pic32_sdhci.c | 2 +- drivers/mmc/sdhci.c | 7 ++- include/sdhci.h | 1 - 3 files changed, 3 insertions(+), 7 deletions(-) diff

[U-Boot] [PATCH 02/11] mmc: sdhci: add the get_cd callback function in sdhci_ops

2016-12-29 Thread Jaehoon Chung
Some SoCs can have their own card dect scheme. Then they may use this get_cd callback function after implementing init in their drivers. Signed-off-by: Jaehoon Chung --- include/sdhci.h | 1 + 1 file changed, 1 insertion(+) diff --git a/include/sdhci.h b/include/sdhci.h

[U-Boot] [PATCH 06/11] mmc: change the set_ios return type from void to int

2016-12-29 Thread Jaehoon Chung
To maintain consistency, set_ios type of legacy mmc_ops changed to int. Signed-off-by: Jaehoon Chung --- drivers/mmc/dw_mmc.c | 5 ++--- drivers/mmc/sdhci.c | 5 ++--- include/mmc.h| 2 +- 3 files changed, 5 insertions(+), 7 deletions(-) diff --git

[U-Boot] [PATCH 01/11] mmc: sdhci: disable the 8bit mode when host doesn't support it

2016-12-29 Thread Jaehoon Chung
Buswidth is depeneded on Hardware schematic. Evne though host can support the 8bit buswidth, if hardware doesn't support 8bit mode, it doesn't work fine. So the buswidth mode selection leaves a matter in each SoC drivers. On the contrary to this, hardware supports 8bit mode, but host doesn't

[U-Boot] [PATCH 00/11] mmc: clean the sdhci host controller

2016-12-29 Thread Jaehoon Chung
It's cleaned the condes related to SDHCI host controller. Move the callback function into sdhci_ops structure. And removed the unnecessary things. My next step should be more clearly than now. - Support DM feature than now. - Make driver model for controller that unused driver mode. Jaehoon

[U-Boot] [PATCH 04/11] mmc: pic32_sdhci: move the code to pic32_sdhci.c

2016-12-29 Thread Jaehoon Chung
This code is used for only pic32_sdhci controller. To remove the "#ifdef", moves to pic32_sdhci.c. And use the get_cd callback function. Signed-off-by: Jaehoon Chung --- drivers/mmc/pic32_sdhci.c | 13 + drivers/mmc/sdhci.c | 9 +++-- 2 files

[U-Boot] [PATCH 2/2][v2] armv8: ls1012a: Add support of PPA

2016-12-29 Thread Prabhakar Kushwaha
The PPA implements PSCI which requires for power managment. Added support of PPA for LS1012AQDS, LS1012ARDB and LS1012AFRDM. Signed-off-by: Hou Zhiqiang Signed-off-by: Abhimanyu Saini Signed-off-by: Prabhakar Kushwaha

Re: [U-Boot] [RESEND PATCH v3 1/2] mmc: rockchip_sdhci: add clock init for mmc

2016-12-29 Thread Jaehoon Chung
Hi Stefan, On 12/30/2016 12:41 AM, Stefan Herbrechtsmeier wrote: > Hi, > > Am 29.12.2016 um 08:44 schrieb Jaehoon Chung: >> Hi >> >> On 12/29/2016 09:53 AM, Kever Yang wrote: >>> Hi Stefan, >>> >>> Thanks for your review comment. >>> On 12/29/2016 02:35 AM, Stefan Herbrechtsmeier wrote:

Re: [U-Boot] [U-Boot, v2, 6/6] mmc: move MMC_SDHCI_IO_ACCESSORS to Kconfig

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:30PM +0900, Masahiro Yamada wrote: > This is a user-unconfigurable option that is selected by the > drivers that need to overwrite SDHCI IO memory accessors. > (BCM2835 SDHCI seems the only driver that needs to do so.) > > Signed-off-by: Masahiro Yamada

Re: [U-Boot] [U-Boot, v2, 5/6] mmc: move some SDHCI related options to Kconfig

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:29PM +0900, Masahiro Yamada wrote: > While I moved the options, I also renamed them so that they are all > prefixed with MMC_SDHCI_. > > This commit was created in the following steps. > > [1] Rename with the following command > find . -name .git -prune -o ! -path

Re: [U-Boot] [U-Boot, v2, 4/6] mmc: move CONFIG_SDHCI to Kconfig, renaming to CONFIG_MMC_SDHCI

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:28PM +0900, Masahiro Yamada wrote: > Move CONFIG_SDHCI to Kconfig and rename it to CONFIG_MMC_SDHCI. > My motivation for the rename is, ultimately, to make all the MMC > options prefixed with MMC_ and SDHCI options with MMC_SDHCI_, > like Linux. > > This commit was

[U-Boot] [PATCH] i2c: mux: Allow muxes to work as children of i2c bus without i2c-parent

2016-12-29 Thread Moritz Fischer
For mux check if the parent is already a device of UCLASS_I2C and if yes just use that. Otherwise see if someone specified an i2c-parent phandle. This mimics the behavior found in the Kernel, as it removes the requirement to explicitly specify a i2c-parent phandle. Signed-off-by: Moritz Fischer

Re: [U-Boot] [U-Boot, v2, 3/6] mmc: make MMC driver entries dependent on MMC

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:27PM +0900, Masahiro Yamada wrote: > Currently, CONFIG_MMC is not related to any other options by > "depends on" or "select". One of big advantages of using Kconfig > is automatic dependency tracking, but the current state is lacking > it. As the first step, make

Re: [U-Boot] [U-Boot, v2, 2/6] mmc: complete unfinished move of CONFIG_MMC

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:26PM +0900, Masahiro Yamada wrote: > Commit 7a777f6d6f35 ("mmc: Add generic Kconfig option") created > a Kconfig entry for this option without any actual moves, then > commit 44c798799f66 ("sunxi: Use Kconfig CONFIG_MMC") moved > instances only for SUNXI. > > We

Re: [U-Boot] [U-Boot,v2,1/6] Sync defconfig files by savedefconfig

2016-12-29 Thread Tom Rini
On Wed, Dec 07, 2016 at 10:10:25PM +0900, Masahiro Yamada wrote: > Generated by "tools/moveconfig -s". > > This will make config moves easier. > > Signed-off-by: Masahiro Yamada Applied to u-boot/master, thanks! -- Tom signature.asc Description: Digital

Re: [U-Boot] imx: mx6sllevk: add MAINTAINERS file

2016-12-29 Thread Tom Rini
On Tue, Dec 27, 2016 at 08:19:07PM +0800, Peng Fan wrote: > add MAINTAINERS files > > Signed-off-by: Peng Fan > Cc: Stefano Babic Applied to u-boot/master, thanks! -- Tom signature.asc Description: Digital signature

Re: [U-Boot] board: samsung: update the MAINTAINERS file

2016-12-29 Thread Tom Rini
On Tue, Dec 27, 2016 at 08:08:13PM +0900, Jaehoon Chung wrote: > Update the maintainer from Przemyslaw and Lukasz to me. > > Signed-off-by: Jaehoon Chung Applied to u-boot/master, thanks! -- Tom signature.asc Description: Digital signature

Re: [U-Boot] cmd: net: fix function name in comment

2016-12-29 Thread Tom Rini
On Tue, Dec 27, 2016 at 11:03:29AM +0200, Baruch Siach wrote: > In commit 7044c6bb6 (net: cosmetic: Clean up DHCP variables and functions) > BootpCopyNetParams() was renamed to store_net_params(). Update the reference > in > comment. > > Cc: Joe Hershberger >

Re: [U-Boot] disk: Fixed capacity message

2016-12-29 Thread Tom Rini
On Fri, Dec 23, 2016 at 10:45:43AM +0100, Jean-Jacques Hiblot wrote: > With capacities getting bigger, we can see see messages with negative > numbers like "Capacity: 1907729.0 MB = 1863.0 GB (-387938128 x 512)". > Here the printed LBA is -387938128 when it should have been 3907029168. > To fix

Re: [U-Boot] fs/ext4: Initialize group descriptor size for revision level 0 filesystems

2016-12-29 Thread Tom Rini
On Tue, Dec 27, 2016 at 02:35:08AM +0100, Stefan BrĂ¼ns wrote: > genext2fs creates revision level 0 filesystems, which are not readable > by u-boot due to the initialized group descriptor size field. > f798b1dda1c5de818b806189e523d1b75db7e72d > > Reported-by: Kever Yang

Re: [U-Boot] Update Maintainer and Auther's email address

2016-12-29 Thread Tom Rini
On Wed, Dec 21, 2016 at 01:28:06PM +0530, Ajay Bhargav wrote: > I am not longer using my old email address > "ajay.bhar...@einfochips.com". For U-Boot development email address is > now updated to cont...@8051projects.net > > Signed-off-by: Ajay Bhargav Applied to

Re: [U-Boot] tools: mkimage: Call fclose in error path

2016-12-29 Thread Tom Rini
On Tue, Dec 20, 2016 at 09:58:31AM +0100, Michal Simek wrote: > This patch is fixing missing fclose() calls > in error patch introduced by: > "tools: mkimage: Use fstat instead of stat to avoid malicious hacks" > (sha1: ebe0f53f48e8f9ecc823e533a85b05c13638c350) > > Reported-by: Coverity (CID:

Re: [U-Boot] [U-Boot, 3/3] README: remove description about CONFIG_USE_ARCH_MEMCPY/SET

2016-12-29 Thread Tom Rini
On Mon, Dec 19, 2016 at 07:31:04PM +0900, Masahiro Yamada wrote: > These options are now described in the Kconfig help. We do not want > to maintain duplicated documentation. > > Signed-off-by: Masahiro Yamada > Reviewed-by: Fabio Estevam

Re: [U-Boot] [PATCH V2 14/20] serial: lpuart: restructure lpuart driver

2016-12-29 Thread Bhuvanchandra DV
On 12/27/2016 03:34 PM, Peng Fan wrote: Drop CONFIG_LPUART_32B_REG. Move the register structure to a common file include/fsl_lpuart.h Define lpuart_serial_platdata structure which includes the reg base and flags. For 32Bit register access, use lpuart_read32/lpuart_write32 which handles

[U-Boot] Missing SCSI block device connected to SATA adapter

2016-12-29 Thread Kostya Porotchkin
Hello, I am trying to use the new SCSI code with CONFIG_BLK=y on a Marvell board. I added CONFIG_DM_SCSI=y to my default configuration too. However "scsi reset" does not detect the connected hard disk since the execution flow never entered the "uclass_foreach_dev" loop in scsi_scan() function.

Re: [U-Boot] [RESEND PATCH v3 1/2] mmc: rockchip_sdhci: add clock init for mmc

2016-12-29 Thread Stefan Herbrechtsmeier
Hi, Am 29.12.2016 um 08:44 schrieb Jaehoon Chung: Hi On 12/29/2016 09:53 AM, Kever Yang wrote: Hi Stefan, Thanks for your review comment. On 12/29/2016 02:35 AM, Stefan Herbrechtsmeier wrote: Hi, Am 28.12.2016 um 12:01 schrieb Jaehoon Chung: On 12/28/2016 12:32 PM, Kever Yang wrote:

Re: [U-Boot] [PATCH] SPL: NOR: Add CONFIG_SPL_NOR_COPY_ENTIRE_IMAGE define to enable whole image copy from NOR

2016-12-29 Thread Tom Rini
On Thu, Dec 29, 2016 at 12:41:06AM +0100, Marek Vasut wrote: > On 12/28/2016 09:52 AM, Lukasz Majewski wrote: > > Hi Marek, > > > >> On 12/26/2016 05:36 PM, Lukasz Majewski wrote: > >>> Hi Marek, > >>> > On 11/29/2016 07:18 PM, Tom Rini wrote: > > On Tue, Nov 29, 2016 at 11:50:34AM

Re: [U-Boot] [PATCH 00/10] i.MX6: engicam: Add nandboot env and FIT support

2016-12-29 Thread Jagan Teki
Hi Stefano, On Wed, Dec 21, 2016 at 12:00 PM, Jagan Teki wrote: > From: Jagan Teki > > This patchset, add support for > - legacy image boot, with bootm > - NAND boot env support, with UBIFS as rootfs > - FIT image boot support > > on i.MX6 based

[U-Boot] [PATCH] board: freescale: ls2080a: Intergrate and enable PPA on LS2080A

2016-12-29 Thread Abhimanyu Saini
Integrate and enable PPA on LS2080ARDB, LS2080AQDS, LS2088ARDB and LS2088AQDS boards. Signed-off-by: Abhimanyu Saini --- board/freescale/ls2080aqds/ls2080aqds.c | 6 ++ board/freescale/ls2080ardb/ls2080ardb.c | 6 ++ include/configs/ls2080aqds.h|

[U-Boot] [RFC PATCH 2/3] arm64: rk3399: add ddr controller driver

2016-12-29 Thread Kever Yang
RK3399 support DDR3, LPDDR3, DDR4 sdram, this patch is porting from coreboot, support 4GB lpddr3 in this version. Signed-off-by: Kever Yang --- arch/arm/include/asm/arch-rockchip/sdram_rk3399.h | 188 +++ arch/arm/mach-rockchip/rk3399/Makefile |1 +

[U-Boot] [PATCH] rockchip: video: fix mpixelclock in rockchip HDMI

2016-12-29 Thread Nickey Yang
Correct mpixelclock errors in rockchip_phy_config[] and rockchip_mpll_cfg[]. Signed-off-by: Nickey Yang --- drivers/video/rockchip/rk_hdmi.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/video/rockchip/rk_hdmi.c

[U-Boot] [PATCH v4] rockchip: rk3288: set isp/vop qos priority level

2016-12-29 Thread Nickey Yang
Isp-camera preview image will be broken when dual screen display mode. This patch set isp/vop qos level higher to solve this problem. We have verified this patch on rk3288-miniarm board. Signed-off-by: Nickey Yang --- arch/arm/include/asm/arch-rockchip/qos_rk3288.h |

[U-Boot] [RFC PATCH 3/3] spl: add support to booting with ATF

2016-12-29 Thread Kever Yang
ATF(ARM Trust Firmware) is used by ARM arch64 SoCs, find more infomation about ATF at: SPL is consider as BL2 in ATF, it needs to load other part of ATF binary like BL31, BL32, SCP-BL30, and BL33(U-Boot). And needs to prepare the parameter for BL31 which including entry and image information for

[U-Boot] [RFC PATCH 1/3] arm64: rk3399: add SPL support

2016-12-29 Thread Kever Yang
Add spl support for rk3399. Signed-off-by: Kever Yang --- arch/arm/Kconfig| 1 + arch/arm/dts/rk3399.dtsi| 24 arch/arm/include/asm/arch-rockchip/grf_rk3399.h | 118 ++

[U-Boot] [RFC PATCH 0/3] arm64: rk3399: enable SPL with ATF support

2016-12-29 Thread Kever Yang
RK3399 SPL is not enable bacause of the lack of ATF support in SPL, after port some source code from ATF, I manage to enable the support for ATF in SPL. This patch set depends on some patch for SPL support multi binary in FIT which is from Andre. The patch of sdram controller is still not clean,

[U-Boot] [PATCH v2] doc/README.cfi: Update code snippet, and add example.

2016-12-29 Thread Robert P. J. Day
First, update the code snippet referenced in the README file. And since there are only two boards that override flash_cmd_reset(), might as well show them both. Signed-off-by: Robert P. J. Day --- figured since i was there, and there were only two boards in the entire

[U-Boot] [PATCH] digsy_mtc.c: Minor spelling/grammar fixes.

2016-12-29 Thread Robert P. J. Day
Signed-off-by: Robert P. J. Day --- diff --git a/board/intercontrol/digsy_mtc/digsy_mtc.c b/board/intercontrol/digsy_mtc/digsy_mtc.c index 37eb6c7..05d673d 100644 --- a/board/intercontrol/digsy_mtc/digsy_mtc.c +++ b/board/intercontrol/digsy_mtc/digsy_mtc.c @@ -41,7

[U-Boot] [PATCH] doc/README.cfi: Update code snippet for flash_cmd_reset()

2016-12-29 Thread Robert P. J. Day
Minor update in code snippet in the doc file to match source. Signed-off-by: Robert P. J. Day --- diff --git a/doc/README.cfi b/doc/README.cfi index 81e7cf1..6b8be41 100644 --- a/doc/README.cfi +++ b/doc/README.cfi @@ -1,7 +1,7 @@ The common CFI driver provides this