[U-Boot] [PATCH 5/6] efi_loader: rework event handling for console

2018-09-08 Thread Heinrich Schuchardt
Preread the next key in the console timer event. The EFI_SIMPLE_TEXT_INPUT_EX_PROTOCOL requires to trigger registered key notification functions based on the prefetched key. Signed-off-by: Heinrich Schuchardt --- lib/efi_loader/efi_console.c | 204 ++- 1 file

Re: [U-Boot] [PATCH v2 2/5] x86: tangier: pinmux: add API to configure protected pins

2018-09-08 Thread Simon Glass
Hi Georgii, On 5 September 2018 at 09:44, Georgii Staroselskii wrote: > > On Wed, Sep 05, 2018 at 09:24:40AM -0600, Simon Glass wrote: > > Hi Georgi, > > > > On 4 September 2018 at 07:34, Georgii Staroselskii > > wrote: > > > This API is going to be used to configure some pins that are

Re: [U-Boot] [PATCH 4/4] xtensa: use asm-generic/atomic.h

2018-09-08 Thread Max Filippov
On Sat, Sep 8, 2018 at 2:39 AM, Chris Packham wrote: > Make use of asm-generic/atomic.h. > > Signed-off-by: Chris Packham > --- > > arch/xtensa/include/asm/atomic.h | 44 +--- > 1 file changed, 1 insertion(+), 43 deletions(-) Acked-by: Max Filippov -- Thanks. --

[U-Boot] [PATCH 1/1] efi_loader: typos in efi_console.c

2018-09-08 Thread Heinrich Schuchardt
Fix a few typos. Signed-off-by: Heinrich Schuchardt --- lib/efi_loader/efi_console.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/lib/efi_loader/efi_console.c b/lib/efi_loader/efi_console.c index 6157c0251f..6ba55413cd 100644 --- a/lib/efi_loader/efi_console.c +++

[U-Boot] [PATCH V2] ARM: CPU: arm926ejs: Consolidate cache routines to common file

2018-09-08 Thread Adam Ford
Four different boards had different options for enabling cache that were virtually all the same. This consolidates these common functions into arch/arm/cpu/arm926ejs/cache.c This also has the positive side-effect of enabling cache on the Davinci (da850) boards. Signed-off-by: Adam Ford --- V2:

Re: [U-Boot] [PATCH] ARM: dts: logicpd-torpedo-37xx-devkit-u-boot: Fix MMC Card Detect

2018-09-08 Thread Adam Ford
On Wed, Sep 5, 2018 at 8:08 AM Tuomas Tynkkynen wrote: > > Hi Adam, > > On 09/03/2018 05:08 PM, Adam Ford wrote: > > When re-syncing the DTS files from the kernel, something caused > > the MMC driver to no longer detect the MMC card. Undoing the > > CD-invert appears to fix the issue. > > > >

[U-Boot] [PATCH V2 2/2] ARM: DTS: various omap3: Remove cd-inverted from u-boot.dtsi

2018-09-08 Thread Adam Ford
With the omap_mmc driver no longer supporting cd-inverted, this patch removes all these references since they are not needed. Signed-off-by: Adam Ford --- V2: No changes diff --git a/arch/arm/dts/am3517-evm-u-boot.dtsi b/arch/arm/dts/am3517-evm-u-boot.dtsi index c02beaad77..59df819f9d 100644

[U-Boot] [PATCH V2 1/2] mmc: omap_mmc: Remove invert references

2018-09-08 Thread Adam Ford
With DM_GPIO and DM_MMC translating GPIO_ACTIVE_LOW, any boards using the 'cd-invert' option will no longer need to do this. This patch removes the support for 'invert' from the MMC driver. Signed-off-by: Adam Ford --- V2: Don't include patch 1 with xlate. It is not apparently needed.

[U-Boot] [PATCH 4/4] xtensa: use asm-generic/atomic.h

2018-09-08 Thread Chris Packham
Make use of asm-generic/atomic.h. Signed-off-by: Chris Packham --- arch/xtensa/include/asm/atomic.h | 44 +--- 1 file changed, 1 insertion(+), 43 deletions(-) diff --git a/arch/xtensa/include/asm/atomic.h b/arch/xtensa/include/asm/atomic.h index

[U-Boot] [PATCH 3/4] mips: use asm-generic/atomic.h

2018-09-08 Thread Chris Packham
Make use of asm-generic/atomic.h. Signed-off-by: Chris Packham --- arch/mips/include/asm/atomic.h | 44 +- 1 file changed, 1 insertion(+), 43 deletions(-) diff --git a/arch/mips/include/asm/atomic.h b/arch/mips/include/asm/atomic.h index

[U-Boot] [PATCH 0/4] Rationalise atomic.h implementations

2018-09-08 Thread Chris Packham
This series applies on top of https://patchwork.ozlabs.org/patch/958286/ The intention is to rationalise most of the current implementations of atomic.h. x86 remains as having an arch specific implementation which I don't intend to touch. Chris Packham (4): Add include/asm-generic/atomic.h

[U-Boot] [PATCH 2/4] ARM: use asm-generic/atomic.h

2018-09-08 Thread Chris Packham
Make use of asm-generic/atomic.h retaining the smp_mb_... definitions. Signed-off-by: Chris Packham --- arch/arm/include/asm/atomic.h | 147 +- 1 file changed, 1 insertion(+), 146 deletions(-) diff --git a/arch/arm/include/asm/atomic.h

[U-Boot] [PATCH 1/4] Add include/asm-generic/atomic.h

2018-09-08 Thread Chris Packham
The arm, xtensa and mips version of atomic.h were already very similar (the mips one was a copy of xtensa). Combine these implementations together to produce a generic atomic.h that can be included by these architectures (and any others that need it in future). Signed-off-by: Chris Packham ---

[U-Boot] [BUG] efi-x86_app_defconfig does not build with gcc 8.2

2018-09-08 Thread Heinrich Schuchardt
make mrproper && make efi-x86_app_defconfig && make results in CC common/image.o {standard input}: Assembler messages: {standard input}:21662: Error: junk at end of line, first unrecognized character is `@' {standard input}:21707: Error: junk at end of line, first unrecognized character

[U-Boot] [PATCH 1/1] efi_loader: SPDX-License-Identifier for efi.h

2018-09-08 Thread Heinrich Schuchardt
Add the missing SPDX-License-Identifier based on Linux kernel commit b24413180f56 ("License cleanup: add SPDX GPL-2.0 license identifier to files with no license"). Signed-off-by: Heinrich Schuchardt --- include/efi.h | 1 + 1 file changed, 1 insertion(+) diff --git a/include/efi.h

[U-Boot] [PATCH 1/1] efi_loader: SPDX-License-Identifier for efi_api.h

2018-09-08 Thread Heinrich Schuchardt
Add the missing SPDX-License-Identifier based on Linux kernel commit b24413180f56 ("License cleanup: add SPDX GPL-2.0 license identifier to files with no license"). Correct formatting errors. Signed-off-by: Heinrich Schuchardt --- include/efi_api.h | 28 ++-- 1 file

[U-Boot] [PATCH 1/1] efi_loader: struct efi_simple_text_input_protocol

2018-09-08 Thread Heinrich Schuchardt
%s/efi_simple_input_interface/efi_simple_text_input_protocol/ We should be consistent in the naming of the EFI protocol interface structures. The protocol is called EFI_SIMPLE_TEXT_INPUT_PROTOCOL. %s/ExtendedVerification/extended_verification/ Use consistent naming of function parameters. Do