Re: [U-Boot] [PATCH v2 4/8] spi: sun4i: Access registers and bits via enum offsets

2019-02-18 Thread Jagan Teki
Hi Stefan, On Fri, Feb 15, 2019 at 12:12 PM Stefan Mavrodiev wrote: > > [snip] > >> +static const unsigned long sun4i_spi_bits[] = { > > Same here, make it uint32_t, since it describes register masks in 32 bit > > registers. > > > >> +[SPI_GCR_TP]= BIT(18), > >> +

Re: [U-Boot] [PATCH v2 4/8] spi: sun4i: Access registers and bits via enum offsets

2019-02-18 Thread Jagan Teki
On Fri, Feb 15, 2019 at 5:28 AM André Przywara wrote: > > On 14/02/2019 08:36, Jagan Teki wrote: > > Allwinner support two different SPI controllers one for A10 and > > another for A31 with minimal changes in register offsets and > > respective register bits, but the logic for accessing the SPI >

Re: [U-Boot] [PATCH 1/7] riscv: add infrastructure for calling functions on other harts

2019-02-18 Thread Auer, Lukas
On Mon, 2019-02-18 at 10:28 +0530, Anup Patel wrote: > On Tue, Feb 12, 2019 at 3:44 AM Lukas Auer > wrote: > > Harts on RISC-V boot independently and U-Boot is responsible for > > managing them. Functions are called on other harts with > > smp_call_function(), which sends inter-processor

Re: [U-Boot] [PATCH v2 22/34] sound: Add support for Intel HDA

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > The Intel High-definition Audio is a newer-generation audio system which > provides for transfer of a large number of audio stream, each containing > up to 16 channels. > > Add support for HDA as a library which can be used by other drivers.

Re: [U-Boot] [PATCH 1/7] riscv: add infrastructure for calling functions on other harts

2019-02-18 Thread Auer, Lukas
On Mon, 2019-02-18 at 09:10 +0530, Anup Patel wrote: > On Mon, Feb 18, 2019 at 8:53 AM Rick Chen > wrote: > > 於 2019年2月18日 週一 上午11:00寫道: > > > > > > > > > > -Original Message- > > > > From: Auer, Lukas [mailto:lukas.a...@aisec.fraunhofer.de] > > > > Sent: Monday, February 18, 2019 5:55

Re: [U-Boot] [PATCH v2 26/34] sound: Add a driver for the i8254 beep

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > Add a sound driver which can output simple beeps using this legacy timer. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Change the driver name to i8254_drv > > drivers/sound/Kconfig | 12 >

Re: [U-Boot] [PATCH v2 33/34] x86: sound: Add sound support for samus (broadwell)

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > Add a sound driver for samus which ties together the audio codec and > I2S controller. > > For now broadwell_sound is commented out in the makefile since we cannot > compile it without sound support enabled. The next commit fixes this. > >

Re: [U-Boot] [PATCH v2 25/34] sound: x86: Add beeping support in i8254

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > Adjust the code to allow beeping at different frequencies, using a > calculated value for timer 2. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Rename PPC_PORTB to SYSCTL_PORTB > - Use PIT_TICK_RATE instead of creating a new

Re: [U-Boot] [PATCH v2 28/34] x86: broadwell: Add support for the ADSP

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > The Application Digital Signal Processor is used for sound processing with > broadwell. Add a driver to support this. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Drop useless 'set' comment > >

Re: [U-Boot] [PATCH v2 23/34] sandbox: sound: Silence sound for testing

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > When testing the sound system we don't need the hear the beeps. The > testing works by checking the data that would be emitted. Add a > device-tree property to silence the sound, and enable it for testing. > > Signed-off-by: Simon Glass >

Re: [U-Boot] [PATCH v2 24/34] sound: x86: link: Add sound support

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > Add sound support for link, using the HDA codec implementation. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Add a note about undocumented IOMMU values > - Add comments next to verbs in the DT mentioning the HDA spec > - Fix

Re: [U-Boot] [PATCH v2 17/34] sandbox: pch: Add a test for the PCH uclass

2019-02-18 Thread Bin Meng
Hi Simon, On Sun, Feb 17, 2019 at 11:26 AM Simon Glass wrote: > > This uclass currently has no tests. Add a sandbox driver and some simple > tests to provide basic coverage. > > Signed-off-by: Simon Glass > Reviewed-by: Bin Meng > --- > > Changes in v2: > - Use "sandbox-pch" for the compatible

[U-Boot] [PATCH] mips: mt76xx: linkit: Add mtd command support

2019-02-18 Thread Stefan Roese
The new mtd is very useful so let's enable it on the LinkIt Smart 7688 as well. Signed-off-by: Stefan Roese Cc: Jiri Kastner Cc: Daniel Schwierzeck --- configs/linkit-smart-7688-ram_defconfig | 1 + configs/linkit-smart-7688_defconfig | 1 + 2 files changed, 2 insertions(+) diff --git

Re: [U-Boot] [PATCH v2 09/34] gpio: Show inactive GPIOs when explicitly requested

2019-02-18 Thread Bin Meng
Hi Simon, On Sun, Feb 17, 2019 at 11:25 AM Simon Glass wrote: > > At present the gpio command only shows GPIOs which are marked as in use. > This makes sense with 'gpio status' since we already have the '-a' flag > to indicate that all GPIOs should be shown. But when a particular GPIO is >

Re: [U-Boot] [PATCH v2 11/34] pci: Add IDs for Intel high-definition audio

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:25 AM Simon Glass wrote: > > Add a few IDs for common HDA blocks and the ADSP used on samus. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Add a PCI ID for the HD audio class > - Fix ordering of PCI IDs > > include/pci_ids.h | 5 + > 1 file changed,

Re: [U-Boot] [PATCH v2 7/8] spi: sun4: Add A31 spi controller support

2019-02-18 Thread Jagan Teki
On Fri, Feb 15, 2019 at 5:29 AM André Przywara wrote: > > On 14/02/2019 08:36, Jagan Teki wrote: > > Hi, > > > Add A31 spi controller support for existing sun4i_spi driver via driver > > data, this would simply add A31 register along with proper register bits > > via enum sets. > > > >

Re: [U-Boot] [PATCH v2 04/34] log: Allow #define LOG_DEBUG to enable logging in a file

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:25 AM Simon Glass wrote: > > At present it is possible to '#define DEBUG' at the top of a file which > causes all debug() statements in that file to become active. There is > currently no equivalent with logging, but this is a useful function. > > Add a LOG_DEBUG define

Re: [U-Boot] [PATCH v2 01/34] log: Fix up Kconfig log level names

2019-02-18 Thread Bin Meng
On Sun, Feb 17, 2019 at 11:25 AM Simon Glass wrote: > > The log level numbers in the Kconfig are not actually correct. Fix them > and also add a missing space in the header-file comment. > > Signed-off-by: Simon Glass > --- > > Changes in v2: > - Add new patch to fix up Kconfig log level names >

Re: [U-Boot] [PATCH V2 1/3] sunxi: Use clrsetbits_le32 instead of multiple instruction

2019-02-18 Thread Jagan Teki
On Thu, Feb 14, 2019 at 9:28 PM Michael Trimarchi wrote: > > Signed-off-by: Michael Trimarchi > --- > > V1->V2: none > > --- > arch/arm/mach-sunxi/dram_sun8i_a33.c | 8 ++-- > 1 file changed, 2 insertions(+), 6 deletions(-) > > diff --git a/arch/arm/mach-sunxi/dram_sun8i_a33.c >

Re: [U-Boot] [PATCH 1/1] added missing GigaDevice chips

2019-02-18 Thread Stefan Roese
Hi Jiri, On 18.02.19 10:13, Jiri Kastner wrote: --- drivers/mtd/spi/spi-nor-ids.c | 10 ++ 1 file changed, 10 insertions(+) Please always add at least a small sentence in the commit text. And Cc the maintainers / custodians, in this case: Jagan Teki Vignesh R diff --git

[U-Boot] [PATCH] usb: host: Print device name when scanning

2019-02-18 Thread Ismael Luceno Cortes
Signed-off-by: Ismael Luceno --- drivers/usb/host/usb-uclass.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/host/usb-uclass.c b/drivers/usb/host/usb-uclass.c index 611ea97a72..0575f5393b 100644 --- a/drivers/usb/host/usb-uclass.c +++

Re: [U-Boot] [PATCH v2 2/3] sunxi: Rename Sinovoip BPI M2 Plus to Bananapi M2 Plus H3

2019-02-18 Thread Jagan Teki
On Mon, Feb 18, 2019 at 2:10 PM Chen-Yu Tsai wrote: > > On Mon, Feb 18, 2019 at 4:31 PM Jagan Teki wrote: > > > > On Fri, Feb 15, 2019 at 4:35 PM Chen-Yu Tsai wrote: > > > > > > The brand Sinovoip is used for Sinovoip's original VOIP products, while > > > the Bananapi brand is for the single

[U-Boot] [PATCH] cmd: pcmcia: Build only if CONFIG_CMD_PCMCIA=y

2019-02-18 Thread Ismael Luceno Cortes
Signed-off-by: Ismael Luceno --- cmd/Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/cmd/Makefile b/cmd/Makefile index 15ae4d250f..a127a99539 100644 --- a/cmd/Makefile +++ b/cmd/Makefile @@ -104,7 +104,7 @@ obj-$(CONFIG_CMD_PART) += part.o ifdef CONFIG_PCI

Re: [U-Boot] [PATCH v2 2/3] sunxi: Rename Sinovoip BPI M2 Plus to Bananapi M2 Plus H3

2019-02-18 Thread Chen-Yu Tsai
On Mon, Feb 18, 2019 at 4:31 PM Jagan Teki wrote: > > On Fri, Feb 15, 2019 at 4:35 PM Chen-Yu Tsai wrote: > > > > The brand Sinovoip is used for Sinovoip's original VOIP products, while > > the Bananapi brand is for the single board computers they produce. This > > has been verified by Bananapi.

Re: [U-Boot] [PATCH v2 2/3] sunxi: Rename Sinovoip BPI M2 Plus to Bananapi M2 Plus H3

2019-02-18 Thread Jagan Teki
On Fri, Feb 15, 2019 at 4:35 PM Chen-Yu Tsai wrote: > > The brand Sinovoip is used for Sinovoip's original VOIP products, while > the Bananapi brand is for the single board computers they produce. This > has been verified by Bananapi. Rename the board from "Sinovoip BPI M2 > Plus" to "Bananapi M2

Re: [U-Boot] [PATCH v2 1/3] sunxi: Sync Bananapi M2+ device tree from Linux v5.0-rc1

2019-02-18 Thread Jagan Teki
On Fri, Feb 15, 2019 at 7:48 PM Chen-Yu Tsai wrote: > > On Fri, Feb 15, 2019 at 9:58 PM Jagan Teki wrote: > > > > On Fri, Feb 15, 2019 at 4:33 PM Chen-Yu Tsai wrote: > > > > > > As of commit aa8fee415f46 ("ARM: dts: sun8i: h3: Split out > > > non-SoC-specific parts of Bananapi M2 Plus") in the

Re: [U-Boot] [PATCH v4 01/20] common: spl_fit: Fix the spl_fit_image_get_os for FIT_IMAGE_TINY

2019-02-18 Thread Abel Vesa
On 19-02-16 10:23:10, Stefano Babic wrote: > Hi Abel, > > On 01/02/19 17:40, Abel Vesa wrote: > > There is not really reducing codesize here since there is only > > a call. The function is always built in if CONFIG_$(SPL_TPL_)FIT is set. > > Plus, there was a change in behavior if

Re: [U-Boot] [PATCH v4 3/3] arm: mvebu: x530: Enable watchdog in SPL and U-Boot

2019-02-18 Thread Stefan Roese
On 17.02.19 22:30, Chris Packham wrote: Enable the hardware watchdog to guard against system lock ups when running in the SPL or U-Boot. Stop the watchdog just before booting so that the OS can re-enable it if needed. Signed-off-by: Chris Packham --- Changes in v4: None Changes in v3: -

Re: [U-Boot] [PATCH v4 2/3] watchdog: orion_wdt: take timeout value in ms

2019-02-18 Thread Stefan Roese
On 17.02.19 22:30, Chris Packham wrote: The generic wdt_start API expects to be called with the timeout in milliseconds. Update the orion_wdt driver to accept a timeout in milliseconds and use the clock rate specified in the dts to convert the timeout to an appropriate value for the timer reload

<    1   2