[PATCH] mkimage: clarify error message for empty input files

2021-08-01 Thread Thomas Hebb
clear error message instead. We already bounds check the image size when listing and re-signing existing images, so we only need this check here, when opening data files going into a image. Signed-off-by: Thomas Hebb --- tools/mkimage.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/too

[PATCH] mkimage: fit: don't create image with 0700 permissions

2020-03-01 Thread Thomas Hebb
ince there doesn't seem to be any reason to make the image executable or non-group, non-other readable, change the mask to 0666 to preserve the old behavior. Fixes: 7298e422504e ("mkimage: fit: add support to encrypt image with aes") Signed-off-by: Thomas Hebb --- tools/fit_image.c

[PATCH 2/2] spl: get rid of SPL_LIBDISK_SUPPORT

2020-02-02 Thread Thomas Hebb
that seems to been authored before 91ff6865629c landed, there are absolutely no references to this in the code. Let's remove it. Signed-off-by: Thomas Hebb --- arch/arm/Kconfig | 1 - arch/arm/mach-imx/mx6/Kconfig| 1 - arch/arm/mach-mvebu/Kconfig

[PATCH 1/2] mmc: update guard for legacy part_init() call

2020-02-01 Thread Thomas Hebb
rence in the code to SPL_LIBDISK_SUPPORT, replacing it with a non-stage-specific check for CONFIG_PARTITIONS and CONFIG_HAVE_BLOCK_DEVICE. Make that same change to the guard here. Signed-off-by: Thomas Hebb --- drivers/mmc/mmc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/mmc

[RESEND PATCH] rockchip: add description for TPL_ROCKCHIP_COMMON_BOARD

2019-12-20 Thread Thomas Hebb
SPL_ROCKCHIP_COMMON_BOARD, an almost identical option, has a title but this one doesn't for some reason. Add a description to make the menu easier to read. Signed-off-by: Thomas Hebb --- arch/arm/mach-rockchip/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arc

[PATCH] stm32mp: remove redundant SYS_TEXT_BASE prompt

2019-12-20 Thread Thomas Hebb
The main prompt for this (defined in /Kconfig) is visible at all times, which means there's no reason to have an additional, machine-specific prompt to set the same option. Signed-off-by: Thomas Hebb --- arch/arm/mach-stm32mp/Kconfig | 5 - 1 file changed, 5 deletions(-) diff --git a

[PATCH] ram: rk3399: don't assume phy_io_config() uses real regs

2019-12-20 Thread Thomas Hebb
CS=2 Die BW=16 Size=2048MB Channel 1: LPDDR3, 933MHz BW=32 Col=10 Bk=8 CS0 Row=15 CS1 Row=15 CS=2 Die BW=16 Size=2048MB 256B stride 256B stride sdram_init() Finish SDRAM initialization... Signed-off-by: Thomas Hebb --- drivers/ram/rockchip/sdram_rk3399.c | 6 ++ 1 file changed

[U-Boot] [PATCH v2 2/3] rockchip: allow DRAM init in SPL

2019-11-15 Thread Thomas Hebb
t;, and "chromebook_bob" defconfigs, although since I don't have any of those devices I can't confirm they're broken now. Signed-off-by: Thomas Hebb --- arch/arm/mach-rockchip/spl.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-ro

[U-Boot] [PATCH v2 3/3] rockchip: imply instead of selecting SPL_SYS_MALLOC_SIMPLE

2019-11-15 Thread Thomas Hebb
We shouldn't force which allocator the SPL uses, since there's no platform requirement for one over the other: in fact, we currently allow selection of the TPL allocator but not the SPL one! Signed-off-by: Thomas Hebb --- arch/arm/Kconfig | 2 +- 1 file changed, 1 insertion(+),

[U-Boot] [PATCH v2 1/3] rockchip: fix ordering of DRAM init

2019-11-15 Thread Thomas Hebb
e in the common code by putting the DRAM init back after timer init. I have only tested this on the RK3399, but it wouldn't make any sense for the timer init to require DRAM be set up on any system. Signed-off-by: Thomas Hebb --- arch/arm/mach-rockchip/spl.c | 14 +++--- 1 file changed

[U-Boot] [PATCH v2] cosmetic: Fix spelling and whitespace errors

2019-11-13 Thread Thomas Hebb
Signed-off-by: Thomas Hebb --- Makefile| 2 +- README | 16 +--- arch/arm/cpu/armv8/sec_firmware.c | 2 +- arch/arm/mach-rockchip/Kconfig | 2 +- arch/arm/mach-rockchip/bootrom.c| 4 ++-- arch

[U-Boot] [PATCH 2/3] Makefile: consolidate hardcoded lists of files to clean

2019-11-10 Thread Thomas Hebb
of its rm commands. To fix this, put all hardcoded files into CLEAN_FILES. Signed-off-by: Thomas Hebb --- Makefile | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/Makefile b/Makefile index 1186a1d34c..4ac722cd44 100644 --- a/Makefile +++ b/Makefile @@ -1900,7 +1900,7 @@

[U-Boot] [PATCH 1/2] rockchip: allow DRAM init in SPL and fix ordering

2019-11-10 Thread Thomas Hebb
I can't confirm they're broken now. Signed-off-by: Thomas Hebb --- arch/arm/mach-rockchip/spl.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/arch/arm/mach-rockchip/spl.c b/arch/arm/mach-rockchip/spl.c index 92102b39e7..089f0a5258 100644 --- a/arc

[U-Boot] [PATCH 2/2] rockchip: imply instead of selecting SPL_SYS_MALLOC_SIMPLE

2019-11-10 Thread Thomas Hebb
We shouldn't force which allocator the SPL uses, since there's no platform requirement for one over the other: in fact, we currently allow selection of the TPL allocator but not the SPL one! Signed-off-by: Thomas Hebb --- arch/arm/Kconfig | 2 +- 1 file changed, 1 insertion(+),

[U-Boot] [PATCH 3/3] Kconfig: make TPL_DM_SERIAL depend on TPL_DM

2019-11-10 Thread Thomas Hebb
This missing dependency seems like an oversight, since all other TPL_DM_* options have it. Signed-off-by: Thomas Hebb --- drivers/serial/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/serial/Kconfig b/drivers/serial/Kconfig index d36a0108ea..ece7d87d4c

[U-Boot] [PATCH 3/3] Makefile: add Rockchip idbloader.img to CLEAN_FILES

2019-11-10 Thread Thomas Hebb
This file is generated in the root during Rockchip builds and so should be cleaned up. Signed-off-by: Thomas Hebb --- Makefile | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 4ac722cd44..2d172b29ef 100644 --- a/Makefile +++ b/Makefile @@ -1900,7

[U-Boot] [PATCH 1/3] Kconfig: disambiguate config names for tiny printf

2019-11-10 Thread Thomas Hebb
27084c03d36a ("spl: Allow tiny printf() to be controlled in SPL and TPL") split this option in two for TPL and SPL, but didn't change the Kconfig names, making them hard to set quickly. Signed-off-by: Thomas Hebb --- lib/Kconfig | 4 ++-- 1 file changed, 2 insertions(+), 2 del

[U-Boot] [PATCH 2/3] Kconfig: add description for TPL_ROCKCHIP_COMMON_BOARD

2019-11-10 Thread Thomas Hebb
SPL_ROCKCHIP_COMMON_BOARD, an almost identical option, has a title but this one doesn't for some reason. Add a description to make the menu easier to read. Signed-off-by: Thomas Hebb --- arch/arm/mach-rockchip/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arc

[U-Boot] [PATCH 1/3] Makefile: don't try to construct CLEAN_FILES based on config

2019-11-10 Thread Thomas Hebb
list nonexistent files, just add everything to it unconditionally to fix the issue. Signed-off-by: Thomas Hebb --- Makefile | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/Makefile b/Makefile index 5c8c4c971f..1186a1d34c 100644 --- a/Makefile +++ b/Makefile @@ -1286,7 +1

[U-Boot] [PATCH 2/2] Fix typo in macros, "FIRMEWARE" -> "FIRMWARE"

2019-11-10 Thread Thomas Hebb
Signed-off-by: Thomas Hebb --- arch/arm/cpu/armv8/Kconfig | 2 +- arch/arm/cpu/armv8/sec_firmware.c | 8 drivers/net/pfe_eth/pfe_firmware.c | 4 ++-- 3 files changed, 7 insertions(+), 7 deletions(-) diff --git a/arch/arm/cpu/armv8/Kconfig b/arch/arm/cpu/armv8/Kconfig index

[U-Boot] [PATCH 1/2] cosmetic: Fix spelling and whitespace errors

2019-11-10 Thread Thomas Hebb
Signed-off-by: Thomas Hebb --- Makefile| 2 +- README | 4 ++-- arch/arm/cpu/armv8/sec_firmware.c | 2 +- arch/arm/mach-rockchip/Kconfig | 2 +- arch/arm/mach-rockchip/bootrom.c| 4 ++-- arch/arm/mach