Similar to how the rtc_{read,write} functions fall back to
using the {read,write}8 methods, do the opposite in the
rtc_{read,write}8 functions.

This way, each driver only needs to provide either ->read8 or ->read
to make both rtc_read8() and rtc_read() work - without this, a driver
that provides ->read() would most likely just duplicate the logic here
for implementing a ->read8() method in term of its ->read()
method. The same remarks of course apply to the write case.

Reviewed-by: Simon Glass <s...@chromium.org>
Signed-off-by: Rasmus Villemoes <rasmus.villem...@prevas.dk>
---
 drivers/rtc/rtc-uclass.c | 24 ++++++++++++++++++------
 1 file changed, 18 insertions(+), 6 deletions(-)

diff --git a/drivers/rtc/rtc-uclass.c b/drivers/rtc/rtc-uclass.c
index cc5f9c7baa..3cdeb89084 100644
--- a/drivers/rtc/rtc-uclass.c
+++ b/drivers/rtc/rtc-uclass.c
@@ -80,9 +80,17 @@ int rtc_read8(struct udevice *dev, unsigned int reg)
        struct rtc_ops *ops = rtc_get_ops(dev);
 
        assert(ops);
-       if (!ops->read8)
-               return -ENOSYS;
-       return ops->read8(dev, reg);
+       if (ops->read8)
+               return ops->read8(dev, reg);
+       if (ops->read) {
+               u8 buf[1];
+               int ret = ops->read(dev, reg, buf, 1);
+
+               if (ret < 0)
+                       return ret;
+               return buf[0];
+       }
+       return -ENOSYS;
 }
 
 int rtc_write8(struct udevice *dev, unsigned int reg, int val)
@@ -90,9 +98,13 @@ int rtc_write8(struct udevice *dev, unsigned int reg, int 
val)
        struct rtc_ops *ops = rtc_get_ops(dev);
 
        assert(ops);
-       if (!ops->write8)
-               return -ENOSYS;
-       return ops->write8(dev, reg, val);
+       if (ops->write8)
+               return ops->write8(dev, reg, val);
+       if (ops->write) {
+               u8 buf[1] = { val };
+               return ops->write(dev, reg, buf, 1);
+       }
+       return -ENOSYS;
 }
 
 int rtc_read16(struct udevice *dev, unsigned int reg, u16 *valuep)
-- 
2.23.0

Reply via email to