This name conflicts with our desire to #define free() to something else on
sandbox. Rename it.

Signed-off-by: Simon Glass <s...@chromium.org>
---

Changes in v2: None

 arch/sandbox/cpu/state.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/sandbox/cpu/state.c b/arch/sandbox/cpu/state.c
index cd46e000f5..ef2e63f37a 100644
--- a/arch/sandbox/cpu/state.c
+++ b/arch/sandbox/cpu/state.c
@@ -16,14 +16,14 @@ static struct sandbox_state *state; /* Pointer to current 
state record */
 static int state_ensure_space(int extra_size)
 {
        void *blob = state->state_fdt;
-       int used, size, free;
+       int used, size, free_bytes;
        void *buf;
        int ret;
 
        used = fdt_off_dt_strings(blob) + fdt_size_dt_strings(blob);
        size = fdt_totalsize(blob);
-       free = size - used;
-       if (free > extra_size)
+       free_bytes = size - used;
+       if (free_bytes > extra_size)
                return 0;
 
        size = used + extra_size;
-- 
2.25.0.341.g760bfbb309-goog

Reply via email to