Hello,

sorry, forgot to hold the mailinglist on CC:

-------- Original-Nachricht --------
Betreff: Re: [U-Boot] PATCH 2/8 Multi-adapter multi-bus I2C
Datum: Tue, 10 Feb 2009 08:54:10 +0100
Von: Heiko Schocher <h...@denx.de>
Antwort an: h...@denx.de
Organisation: DENX GmbH
An: k...@koi8.net
Referenzen: <pine.lnx.4.64ksi.0902061703330.14...@home-gw.koi8.net> 
<4990175a.4020...@denx.de> 
<pine.lnx.4.64ksi.0902091353360.32...@home-gw.koi8.net>

Hello ksi,

k...@koi8.net wrote:
> On Mon, 9 Feb 2009, Heiko Schocher wrote:
>> Hello ksi,
>>
>> k...@koi8.net wrote:
>> [...]
>>> diff --git a/drivers/i2c/fsl_i2c.c b/drivers/i2c/fsl_i2c.c
>>> index ce646fd..f7998e3 100644
>>> --- a/drivers/i2c/fsl_i2c.c
[...]

>>> -void
>>> -i2c_init(int speed, int slaveadd)
>>> +
>>> +static void __i2c_init(int adap_no, int speed, int slaveadd)
>>>  {
>>> -   struct fsl_i2c *dev;
>>>     unsigned int temp;
>>>  
>>> -   dev = (struct fsl_i2c *) (CONFIG_SYS_IMMR + CONFIG_SYS_I2C_OFFSET);
>>> -
>>> -   writeb(0, &dev->cr);                    /* stop I2C controller */
>>> +   writeb(0, &i2c_dev[adap_no]->cr);       /* stop I2C controller */
>>>   
>> Why do you here substitute a "dev->" with "&i2c_dev[adap_no]"?
>> Why not dev =  &i2c_dev[adap_no] and you can let the dev-> unchanged.
> 
> This eliminates one variable, dev. Another reason is uniformity through the
> entire driver source.

But it is less readable (at least to me). And it distracts from
the reason of the patch, making the driver multibus able. Again,
please don't mix Codingstyle, Code optimization and functional
changes.

> Anyway, keeping that dev won't make any difference other than making the
> patch a tad shorter...

thanks.

bye
Heiko
-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany

-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to