Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-08-02 Thread Simon Schwarz
Hi Aneesh, On 08/02/2011 02:18 PM, Aneesh V wrote: Hi Simon, On Tuesday 02 August 2011 05:33 PM, Simon Schwarz wrote: Hi Aneesh, snip diff --git a/arch/arm/cpu/armv7/omap-common/spl.c b/arch/arm/cpu/armv7/omap-common/spl.c index d177652..7ec5c7c 100644 ---

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-29 Thread Aneesh V
Hi Scott, Simon, On Friday 29 July 2011 12:20 AM, Scott Wood wrote: On Thu, 28 Jul 2011 19:46:25 +0530 Aneesh Vane...@ti.com wrote: On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: +#ifdef CONFIG_SPL_NAND_SUPPORT +static void nand_load_image(void) +{ + gpmc_init(); +

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-29 Thread Simon Schwarz
Hi Scott, Aneesh, to short the discussion: I already work on the implementation of using the image header. I think a new version will be released late today. Regards thx for your reviews! Simon ___ U-Boot mailing list U-Boot@lists.denx.de

[U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Simon Schwarz
Add NAND support for the new SPL structure. Signed-off-by: Simon Schwarz simonschwarz...@gmail.com --- This patch didn't exist before V2! V2 changes: ADD Some define-barriers for OMAP3 to only use NAND ADD nand_load_image() - inits the OMAP gpmc, loads the images - parses the header CHG

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Aneesh V
Hi Simon, On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: Add NAND support for the new SPL structure. Signed-off-by: Simon Schwarzsimonschwarz...@gmail.com --- This patch didn't exist before V2! V2 changes: ADD Some define-barriers for OMAP3 to only use NAND ADD nand_load_image()

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Aneesh V
Hi Simon, On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: [snip ..] + +int do_reset(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[]) +{ + debug(resetting cpu...); + reset_cpu(0); + + return 0; +} Can you explain the need of this do_reset()? I couldn't figure

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Simon Schwarz
On 07/28/2011 11:42 AM, Aneesh V wrote: Hi Simon, On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: Add NAND support for the new SPL structure. Signed-off-by: Simon Schwarzsimonschwarz...@gmail.com --- This patch didn't exist before V2! V2 changes: ADD Some define-barriers for

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Simon Schwarz
Hi Aneesh, On 07/28/2011 11:58 AM, Aneesh V wrote: Hi Simon, On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: [snip ..] + +int do_reset(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[]) +{ + debug(resetting cpu...); + reset_cpu(0); + + return 0; +} Can you explain

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Aneesh V
Hi Simon, On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: Add NAND support for the new SPL structure. Signed-off-by: Simon Schwarzsimonschwarz...@gmail.com --- This patch didn't exist before V2! V2 changes: ADD Some define-barriers for OMAP3 to only use NAND ADD nand_load_image()

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Aneesh V
On Thursday 28 July 2011 06:14 PM, Simon Schwarz wrote: [snip ..] +#endif /* CONFIG_SPL_MMC_SUPPORT */ and here.. You start the same the #ifdef again immediately after the #endif. Why don't you club them together into just one #ifdef block. IMHO #ifdef each function makes it more readable

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Simon Schwarz
Hi Aneesh, On 07/28/2011 04:24 PM, Aneesh V wrote: On Thursday 28 July 2011 06:14 PM, Simon Schwarz wrote: [snip ..] +#endif /* CONFIG_SPL_MMC_SUPPORT */ and here.. You start the same the #ifdef again immediately after the #endif. Why don't you club them together into just one #ifdef

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Scott Wood
On Thu, 28 Jul 2011 19:46:25 +0530 Aneesh V ane...@ti.com wrote: On Thursday 28 July 2011 02:08 PM, Simon Schwarz wrote: +#ifdef CONFIG_SPL_NAND_SUPPORT +static void nand_load_image(void) +{ + gpmc_init(); + nand_init(); + nand_spl_load_image(CONFIG_SYS_NAND_U_BOOT_OFFS, +

Re: [U-Boot] [PATCH V6 2/5] omap-common: add nand spl support

2011-07-28 Thread Wolfgang Denk
Dear Scott Wood, In message 20110728135005.03c97...@schlenkerla.am.freescale.net you wrote: This is how all the other NAND SPLs do it. We're building both at the same time to create a single combination image, so it's not that bad of an assumption. An image header might simplify the