(In reply to Ben Bucksch from comment #146)
> Please note that there's a minor UI glitch here: We have 2 dropdown arrows,
> as you can see in the screenshot. They both have the same effect. When
> clicking the right one, the left one even shows a pressed state.
OK, so this is to do with the change
Created attachment 8583150
Revised patch
Now resets the From address correctly when you select the current
identity from the drop-down, adds a one-time warning dialog, and removes
the Linux/OSX CSS because that wasn't working in its current state.
--
You received this bug notification because yo
(In reply to Thomas D. from comment #151)
> Clicking at the low end of a dropdown to
> edit the current entry at the top is bad UX imo.
So, top of the dropdown then? Or do you prefer attachment 8574154?
(In reply to Ben Bucksch from comment #147)
> when I select the same identity that I originall
Created attachment 8574154
Screenshot showing the moved menuitem
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current email only (as text, not
dropd
Created attachment 8572084
Possible patch
I hid the option in the Options menu where it might be less
discoverable.
(In reply to Thomas D. from comment #132)
> - allow editing only after double-click on sender (plus first-time warning)
Probably not possible because the popup code gets in the way.
(In reply to Josiah Bruner from comment #128)
> The backend changes in this patch causes it to not apply, that's all I was
> noting. :)
Sure, but they'll get merged out when I update anyway.
> What platform have you tested this on?
Windows and Linux.
(In reply to Ben Bucksch from comment #129)
>
(In reply to Josiah Bruner from comment #125)
> - "Customize From Address" is confusing. “Enter a custom address” perhaps?
OK (but see below)
> - If you choose a custom address (which focuses the field), and then you
> deselect the field, and click it again, we should show the drop down (don't
> k
Created attachment 8562431
Fixed fix
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current email only (as text, not
dropdown)
To manage notification
Comment on attachment 8562431
Fixed fix
https://hg.mozilla.org/comm-central/rev/c3bf5c52ce41
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current ema
Comment on attachment 8551328
Backend changes
https://hg.mozilla.org/comm-central/rev/6fe2526c838f
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the curre
Created attachment 8561373
Test fix
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current email only (as text, not
dropdown)
To manage notifications
(In reply to Joshua Cranmer from comment #118)
> > + from = MimeHeaders_get(mdd->headers, HEADER_FROM, false, false);
>
> This hunk seems unnecessary?
I accidentally already checked it in without review, so this is post-
facto review, so to speak.
--
You received this bug notification
Created attachment 8553148
Possible patch
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current email only (as text, not
dropdown)
To manage notific
Created attachment 8551328
Backend changes
While you bikeshed over the UI, let me get the backend changes reviewed
(or post-facto reviewed in the case of the second hunk).
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.l
(In reply to comment #111)
> It does on sane platforms
OK that was a bit harsh but I can't reproduce your problems on Windows.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing th
(In reply to Josiah Bruner from comment #109)
> It would also be preferable to allow clicking the drop down icon to always
> bring up the list, regardless of the field's current state.
It does on sane platforms, thus the original version always had the
field editable.
Just to make sure that we're
(In reply to Josiah Bruner from comment #108)
> > + from = MimeHeaders_get(mdd->headers, HEADER_FROM, false, false);
>
> This is obsolete now (and the patch fails to apply because of it).
Whoops I accidentally checked that line in as part of bug 11039.
--
You received this bug notifica
Created attachment 8525381
Possible patch
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current email only (as text, not
dropdown)
To manage notific
Created attachment 8507858
87987.png
This is what I get locally... are you not seeing this?
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
Title:
Editing the "From" field for the current emai
(In reply to Josiah Bruner from comment #97)
> This completely removes the ability to choose from your accounts
It wasn't supposed to... what are you seeing?
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/b
Created attachment 8491619
Possible patch
This seems to work, it even remembers the address you entered if you
save a draft and reopen it later.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/357864
T
(In reply to Masatoshi Kimura from comment #82)
> Comment on attachment 8398925
> Part 2: Read charset from the channel
>
> This part is no longer needed with the follow-up patch of bug 989576.
Although, would it be nice to emit a tag if we
know that the charset is UTF-8 so that we don't have to
(In reply to aceman from comment #125)
> I knew octal literals are deprecated so somehow I extended that to hex too.
> Thanks.
The only reason old-style octal literals are deprecated is because it's
too easy to confuse them with decimal literals e.g. 160 - 060 != 100.
Hex literals and new-style oc
Comment on attachment 8377817
patch v5
>+ rv = bundle->FormatStringFromName(MOZ_UTF16("confirmDuplicateFolderRename"),
>+formatStrings, 3,
>getter_Copies(confirmString));
If you'd used MOZ_ARRAY_LENGTH(formatStrings) it would have saved you the
trouble of cha
(In reply to aceman from comment #123)
> (In reply to comment #122)
> > (From update of attachment 8374439)
> Is this issue really that important that we make tens of comments in such a
> long thread? It is not a perf critical path.
I'm after readability here, not perf, in particular I don't like
Comment on attachment 8374439
WIP patch 4
>+bool containsChild = true;
>+uint32_t i;
>+for (i = 1; ; i++) {
>+ newFolderName.Assign(folderName);
>+ if (i > 1) {
>+// This could be localizable but Toolkit is fine without it, see
>+// mozilla/toolkit/content/con
Comment on attachment 8371072
WIP patch 3
>+ nsAutoString newFolderName(EmptyString());
[Strings default to empty...]
>+while (containsChild) {
>+ rv = ContainsChildNamed(newFolderName, &containsChild);
>+ NS_ENSURE_SUCCESS(rv, rv);
>+ if (!containsChild)
>+break;
[Wei
Comment on attachment 8371072
WIP patch 3
>+newFolderName.Assign(folderName);
>+bool containsChild = true;
>+uint32_t i = 1;
>+while (containsChild) {
>+ rv = ContainsChildNamed(newFolderName, &containsChild);
>+ NS_ENSURE_SUCCESS(rv, rv);
>+ if (!containsChild)
>+
(In reply to aceman from comment #81)
> Neil is this still a wrong place to do it and can you propose a better one
> that David Bienvenu was talking about?
Well, as I see it there are two options:
1. Make moving a folder automatically rename if the destination already exists,
but allow copies to c
(In reply to aceman from comment #95)
> In nsMsgLocalMailFolder::CopyFolder it seems when we are moving folder then
> it calls CopyFolderLocal (which I am touching). If we are copying then it
> calls CopyFolderAcrossServer (which I do not touch). So if
> CopyFolderAcrossServer merges, then all is f
Comment on attachment 8370331
WIP patch 2
>+ PRUint32 i = 2;
>+ nsAutoString newFolderNameUnderTrash(folderName);
>+ while (1) {
>+rv = CheckIfFolderExists(newFolderNameUnderTrash, this, NULL);
>+if (rv == NS_MSG_FOLDER_EXISTS) {
>+ newFolderNameUnderTrash.Assign(folderName);
>+
(In reply to aceman from comment #89)
> (In reply to Irving Reid from comment #88)
> > I don't think this needs to be localizable.
> I think it should be localizable if it is not complicated.
It doesn't need to be localisable (compare uniqueFile from contentAreaUtils.js).
--
You received this bug
Comment on attachment 8337339
fix bucket groups to be based off of a calendar week concept
Sorry for the delay. The code seems reasonable but this needs to have
ui-review before I can review it properly.
>+// TODO - in the calculation for thisWeek, the + 0 should be based of off
>+// the
I still would like to know what choice this patch actually gives you.
(The string somewhat unhelpfully says "Continue?" which suggests that it
gives you the choice of using up lots of CPU and memory now or annoying
you with another prompt again in 100 minutes.)
--
You received this bug notificati
Comment on attachment 755964
updated for comments
>+ mLastModified: null,
Not sure how this change relates.
>- win.updateStatusItem("statusText", message, aErrorCode);
>+ let code = feed.url.startsWith("http") ? aErrorCode : null;
>+ win.updateStatusItem("statusText", message, cod
(In reply to alexander surkov from comment #78)
> Mounir, I assume you use @value attribute on that xul:label. Is it possible
> to switch to text node instead?
He can't *switch* to text node because he requires the crop behaviour, but I
believe the value attribute takes priority over the text node
Comment on attachment 706354
Store Master Password to Gnome Keyring patch v1
You need build system and PSM reviews, so I'll just comment on code
patterns.
>+ PRUnichar *password = nullptr;
>+ nsAutoString promptString;
>+
>+ // Get prompt message for Gnome Keyring master pass
Comment on attachment 706354
Store Master Password to Gnome Keyring patch v1
You need build system and PSM reviews, so I'll just comment on code
patterns.
>+ PRUnichar *password = nullptr;
>+ nsAutoString promptString;
>+
>+ // Get prompt message for Gnome Keyring master pass
Comment on attachment 680081
fix for gconf v1
Sorry, we can't accept a diff against the mozilla-beta part of a comm-
beta checkout. If you think the issue affects Thunderbird 17 then you
will need to submit a patch against mozilla-central and get it uplifted
to mozilla-beta.
Also I'm not a review
If I've done my sums right, you should find that it's currently
available in Firefox Aurora, will become available in Beta on the 13th,
and then released on the 24th of April. (If you think 17 weeks is a long
time to wait, don't forget that Firefox 4 came out 14 months after
Firefox 3.6!)
--
You
Fair enough, and I can put the test back too, but I might as well use
bug 714164.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/107247
Title:
Launchpad bug pages trigger caret browsing in Firefox an
Pushed changeset 4d0391866459 to mozilla-central.
(In reply to dindog from comment #56)
> Neil, would you please look into the copy menuitem too?
Yes, I'll do copy (but not select all, because it's harder) in bug 692153.
--
You received this bug notification because you are a member of Ubuntu
Bu
> warnings: 24
> failure: 15
Most of these are hidden; 3 randomorange show up on tbpl by default.
More oranges and the reds show up with noignore or via self-serve but they're
all Lion, Tegra and/or Jetpack so nobody cares about them.
--
You received this bug notification because you are
Created attachment 584062
With test fixes (for check in)
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/107247
Title:
Launchpad bug pages trigger caret browsing in Firefox and other Gecko
browsers
test_movement_by_characters.html's reliance on this bug is due to it
failing to focus the content before performing the navigation.
test_movement_by_words.html has the above bug but did also find a real
bug; with this patch, you can't move by words to the very end of a
contenteditable area, becaus
test_selection_move_commands actually tests for the broken commands.
Sigh...
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/107247
Title:
Launchpad bug pages trigger caret browsing in Firefox and oth
test_showcaret.xul: uses cmd_scrollBottom, got renamed to cmd_moveBottom
test_selection_move_commands.xul: many renames...
test_movement_by_characters/word.html: rely on the buggy behaviour!
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubun
(In reply to dindog from comment #44)
> Neil, any news about this bug?
ehsan, should I be asking someone else for review?
> It affects Fx9+(current beta), if we don't fix it in Fx11, then user have to
> wait at least 3*6=18 weeks before thay can copy text in those page again...
(In reply to dindo
Created attachment 570250
Fixed patch
So, I ended up having to separate the cursor movement commands into
their own command table so that I could append that controller for
textareas and inputs.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to
So, things didn't go quite as well as I'd hoped.
Text areas and input fields need to have the editor behaviour.
Design mode and contenteditable windows need to have the global behaviour.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
(In reply to Ehsan Akhgari from comment #40)
> Does my test case pass with this patch?
Yes, it does.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/107247
Title:
Launchpad bug pages trigger caret bro
Created attachment 569554
Proposed patch
The names of the commands are configured in three places:
* GTK2 Native keybindings
* Editor bindings (editor-base.inc and libeditor)
* Browser bindings (browser-base.inc and nsGlobalWindowCommands)
The browser bindings have six differences to the other two
(In reply to Ehsan Akhgari from comment #37)
> If so, we can get them landed. :-)
Except it's very much proof of concept (although I wouldn't mind landing
the nsFocusManager.cpp change which would be necessary anyway).
In particular, I'm not sure a) which keys need to be changed b) whether
those
Created attachment 565950
Fixed proof of concept
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/107247
Title:
Launchpad bug pages trigger caret browsing in Firefox and other Gecko
browsers
To mana
(In reply to Neil Deakin from comment #28)
> (In reply to n...@parkwaycc.co.uk from comment #27)
> > (In reply to Neil Deakin from comment #26)
> > > Expected:
> > > The caret moves up/down a line
> > Well, that's what I get locally. Does caret browsing work in your build?
> I get the same whethe
(In reply to Neil Deakin from comment #26)
> Expected:
> The caret moves up/down a line
Well, that's what I get locally. Does caret browsing work in your build?
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.n
Comment on attachment 552655
patch v2.7
>+ PRUnichar *currentDictionary = nsnull;
>+ rv = mSpellCheck->GetCurrentDictionary(¤tDictionary);
Fortunately you fixed this leak in attachment 553150!
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to
(In reply to comment #23)
> The former fixes an issue where there is a selection within the editable
> area, but the editable area is not focusable, then tab is pressed. (The
> removed code from nsFocusManager is only called when there is nothing
> focused).
I could only get that code to be hit whe
58 matches
Mail list logo