Re: Mahout parallel K-Means - algorithms analysis

2014-03-17 Thread Weishung Chung
You could take a look at org.apache.mahout.clustering.classify/ClusterClassificationMapper Enjoy, Wei Shung On Sat, Mar 15, 2014 at 2:51 PM, Suneel Marthi wrote: > The clustering code is cimapper and cireducer. Following the clustering, > there is cluster classification which is mapper only. >

Re: Visualize clusters

2012-07-24 Thread Weishung Chung
Thank you On Tue, Jul 24, 2012 at 5:02 AM, Dan Brickley wrote: > > > > > On 24 Jul 2012, at 03:30, Lance Norskog wrote: > > > Here is the only tool I know: use 'bin/mahout clusterdump' to export > > clusters with the graphml option. The the 'Giraph' program (available > > for free somewhere on

Re: : Visualize clusters

2012-07-23 Thread Weishung Chung
lassifier framework and > the old KMeansMapper, Reducer and Combiner were removed. > > > On 7/23/12 2:27 PM, Weishung Chung wrote: > >> Ok...I need to flip through the book...has been sitting on my desk :) >> >> Btw, I couldn't find the KMeansMap

Re: : Visualize clusters

2012-07-23 Thread Weishung Chung
Ok...I need to flip through the book...has been sitting on my desk :) Btw, I couldn't find the KMeansMapper and KMeansReducer classes anymore in the org.apache.mahout.clustering.kmeans package anymore when checking out the source from svn. Have they been relocated to another package ? Thank you :

Re: KMeansMapper

2012-07-16 Thread Weishung Chung
Thank you. Found it in the source zip :) On Mon, Jul 16, 2012 at 12:08 AM, bing wang wrote: > org.apache.mahout.clustering.kmeans.KMeansMapper > > 2012/7/16 Weishung Chung > > > Hi, > > > > Could anyone tell me where is KMeansMapper in the package ? > >

KMeansMapper

2012-07-15 Thread Weishung Chung
Hi, Could anyone tell me where is KMeansMapper in the package ? I can't find it :( Thank you, Wei Shung

Re: cardinality vs size

2011-02-12 Thread Weishung Chung
art at the initialCapacity and grow as needed > but always be <= size() + epsilon and >= the number of non-zeros. For some > other sparse formats, it might be equal to the current number of non-zeros. > > On Sat, Feb 12, 2011 at 8:52 AM, Weishung Chung > wrote: > >

Re: cardinality vs size

2011-02-12 Thread Weishung Chung
I believe most of us understand that Vector.size() and Matrix.size() refer to the size of the vector or matrix, so it's not that a big deal. But I would recommend just rename the size in the constructor to initialCapacity which would be clear to most of us that it refers to the initialCapacity of t

Re: cardinality vs size

2011-02-11 Thread Weishung Chung
gt; On Fri, Feb 11, 2011 at 10:13 AM, Sebastian Schelter > <mailto:s...@apache.org>> wrote: >> >>Maybe we should rename them to something like dimension and >> initialCapacity then? >> >>--sebastian >> >> >>On 11.0

Re: cardinality vs size

2011-02-11 Thread Weishung Chung
to have in the vector > initially, much in the style of ArrayList where you specify how many > elements to pre-allocate. > > On Fri, Feb 11, 2011 at 8:33 AM, Weishung Chung > wrote: > > > Is cardinality the original size of the vector including zeros and size > is > > the n

cardinality vs size

2011-02-11 Thread Weishung Chung
Is cardinality the original size of the vector including zeros and size is the number of nonzeros in the vector? I am referring to public RandomAccessSparseVector(int cardinality, int size) Thank you :)

Re: where is OpenIntDoubleHashMap

2011-02-11 Thread Weishung Chung
On Fri, Feb 11, 2011 at 10:02 AM, Weishung Chung wrote: > I checked out the source but I can't find this class, > org.apache.mahout.math.map.OpenIntDoubleHashMap, am I missing something? > Thank you :) >