[v8-dev] Android IA32: enable PIE (issue 1145513006 by jing....@intel.com)

2015-05-18 Thread jing . bao
Reviewers: ulan, Jakob, Description: Android IA32: enable PIE BUG= Please review this at https://codereview.chromium.org/1145513006/ Base URL: https://chromium.googlesource.com/v8/v8.git@master Affected files (+1, -1 lines): M build/android.gypi Index: build/android.gypi diff --git a/buil

[v8-dev] [ia32] Introduce BMI instructions (issue 1069683002 by jing....@intel.com)

2015-04-08 Thread jing . bao
Reviewers: Weiliang, Benedikt Meurer, danno, Description: [ia32] Introduce BMI instructions BUG= Please review this at https://codereview.chromium.org/1069683002/ Base URL: https://chromium.googlesource.com/v8/v8.git@master Affected files (+708, -8 lines): M src/ia32/assembler-ia32.h M sr

[v8-dev] Re: [x64] introduce BMI instructions (issue 1040603002 by jing....@intel.com)

2015-04-07 Thread jing . bao
On 2015/04/08 05:45:41, Benedikt Meurer wrote: Err, that was not what I meant. Since we still need to support machines without LZCNT, it is important to keep the macro assembler functions around, and use them. https://codereview.chromium.org/1040603002/diff/80001/src/compiler/x64/code-gene

[v8-dev] Re: [x64] introduce BMI instructions (issue 1040603002 by jing....@intel.com)

2015-04-07 Thread jing . bao
On 2015/04/08 04:36:21, Benedikt Meurer wrote: Looking good with nit. Can you also fix the two TODO(intel) in macro-assembler-x64.cc (MacroAssembler::Lzcntl)? https://codereview.chromium.org/1040603002/diff/60001/src/base/cpu.cc File src/base/cpu.cc (right): https://codereview.chromium.org/

[v8-dev] [x64] introduce BMI instructions (issue 1040603002 by jing....@intel.com)

2015-04-02 Thread jing . bao
Reviewers: Benedikt Meurer (Google), danno, Weiliang, Description: [x64] introduce BMI instructions BUG= Please review this at https://codereview.chromium.org/1040603002/ Base URL: https://chromium.googlesource.com/v8/v8.git@master Affected files (+1331, -25 lines): M src/base/cpu.h M src

[v8-dev] [turbofan]IA: ChangeFloat32ToFloat64 supports mem operand (issue 641153003 by jing....@intel.com)

2014-10-10 Thread jing . bao
Reviewers: Benedikt Meurer, titzer, dcarney, danno, Description: [turbofan]IA: ChangeFloat32ToFloat64 supports mem operand BUG= Please review this at https://codereview.chromium.org/641153003/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+47, -8 lines): M src/compile

[v8-dev] Re: [turbofan] IA: Uint32ToFloat64 supports mem operand. (issue 583963002 by jing....@intel.com)

2014-09-26 Thread jing . bao
On 2014/09/25 07:59:38, dcarney wrote: On 2014/09/25 07:44:49, danno wrote: > Adding Dan as reviewer lgtm if you add an instruction-selector unit test to verify matching when the intel backend was first introduced, we didn't have the unit test framework in place, but now that we do, all new se

[v8-dev] [turbofan] IA: Uint32ToFloat64 supports mem operand. (issue 583963002 by jing....@intel.com)

2014-09-20 Thread jing . bao
Reviewers: danno, titzer, Benedikt Meurer, Description: [turbofan] IA: Uint32ToFloat64 supports mem operand. BUG= Please review this at https://codereview.chromium.org/583963002/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+27, -15 lines): M src/compiler/ia32/code-g

[v8-dev] X87: Convert KeyedLoad indexed interceptor case to a Handler. (issue 581273005 by jing....@intel.com)

2014-09-18 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Convert KeyedLoad indexed interceptor case to a Handler. port r24042. original commit message: Convert KeyedLoad indexed interceptor case to a Handler. Currently, KeyedLoads on objects with indexed interceptors are handled with a speci

[v8-dev] X87: Move state sentinels into TypeFeedbackVector. (issue 585743002 by jing....@intel.com)

2014-09-18 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Move state sentinels into TypeFeedbackVector. port r24037. original commit message: Move state sentinels into TypeFeedbackVector. These sentinels were in the wrong place, living in only tangentially related class TypeFeedbackInfo, but t

[v8-dev] X87: Removing ic.h from code-stubs.h (issue 573123003 by jing....@intel.com)

2014-09-16 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Removing ic.h from code-stubs.h port r23977. original commit message: Removing ic.h from code-stubs.h CodeStubs use state types defined in ic.h, but this has the unfortunate effect of spreading ic.h all over the place. Instead, define th

[v8-dev] X87: Eliminate Turbofan shims with CodeFactory (issue 567953002 by jing....@intel.com)

2014-09-12 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Eliminate Turbofan shims with CodeFactory port r23877. original commit message: Turbofan needs a code handle and a CallInterfaceDescriptor. At the same time we spread knowledge about how to create the initial IC code object too widely. C

[v8-dev] X87: Added CallInterfaceDescriptors to all code stubs. (issue 566843004 by jing....@intel.com)

2014-09-12 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Added CallInterfaceDescriptors to all code stubs. port r23854. original commit message: Added CallInterfaceDescriptors to all code stubs. A handful of code stubs are too complex to be described this way, and they are encoded with the macr

[v8-dev] X87: Rename ascii to one-byte where applicable. (issue 565853002 by jing....@intel.com)

2014-09-11 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Rename ascii to one-byte where applicable. port r23840. original commit message: Rename ascii to one-byte where applicable. BUG= Please review this at https://codereview.chromium.org/565853002/ SVN Base: https://github.com/v8/v8.git@bleeding_ed

[v8-dev] X87: Get CallInterfaceDescriptor directly from CodeStub. (issue 562983003 by jing....@intel.com)

2014-09-11 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Get CallInterfaceDescriptor directly from CodeStub. port r23778. original commit message: Get CallInterfaceDescriptor directly from CodeStub. BUG= Please review this at https://codereview.chromium.org/562983003/ SVN Base: https://github.com/v8/

[v8-dev] X87: Initialize CodeStubInterfaceDescriptor in the constructor. (issue 563133002 by jing....@intel.com)

2014-09-11 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Initialize CodeStubInterfaceDescriptor in the constructor. port r23773. original commit message: Initialize CodeStubInterfaceDescriptor in the constructor. BUG= Please review this at https://codereview.chromium.org/563133002/ SVN Base: https://

[v8-dev] X87: Encapsulate megamorphic load/tail-call in hydrogen (issue 564683002 by jing....@intel.com)

2014-09-11 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Encapsulate megamorphic load/tail-call in hydrogen port r23772. original commit message: To aid vector-based load ic work, we need to be able to handle the megamorphic load case in hydrogen. A simple approach is to wrap the probe activity

[v8-dev] X87: Do not cache CodeStubInterfaceDescriptor on the isolate. (issue 560793002 by jing....@intel.com)

2014-09-10 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Do not cache CodeStubInterfaceDescriptor on the isolate. port r23744. original commit message: Do not cache CodeStubInterfaceDescriptor on the isolate. BUG= Please review this at https://codereview.chromium.org/560793002/ SVN Base: https://gith

[v8-dev] X87: Unify JSEntryStub and JSConstructEntryStub, and some more code stub cleanups. (issue 557233002 by jing....@intel.com)

2014-09-09 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Unify JSEntryStub and JSConstructEntryStub, and some more code stub cleanups. port r23742. original commit message: Unify JSEntryStub and JSConstructEntryStub, and some more code stub cleanups. BUG= Please review this at https://codereview.ch

[v8-dev] Re: X87: Introduce code stub constructors for stub keys. (issue 556653004 by jing....@intel.com)

2014-09-08 Thread jing . bao
https://codereview.chromium.org/556653004/ -- -- v8-dev mailing list v8-dev@googlegroups.com http://groups.google.com/group/v8-dev --- You received this message because you are subscribed to the Google Groups "v8-dev" group. To unsubscribe from this group and stop receiving emails from it, send

[v8-dev] X87: Introduce code stub constructors for stub keys. (issue 556653004 by jing....@intel.com)

2014-09-08 Thread jing . bao
Reviewers: Weiliang, Description: X87: Introduce code stub constructors for stub keys. port r23716. original commit message: Introduce code stub constructors for stub keys. BUG= Please review this at https://codereview.chromium.org/556653004/ SVN Base: https://github.com/v8/v8.git@bleedin

[v8-dev] X87: Fix build (issue 545133003 by jing....@intel.com)

2014-09-05 Thread jing . bao
Reviewers: Weiliang, Description: X87: Fix build BUG= Please review this at https://codereview.chromium.org/545133003/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+2, -2 lines): M src/x87/code-stubs-x87.cc M src/x87/macro-assembler-x87.cc Index: src/x87/code-stu

[v8-dev] X87: Remove dead code for inline string hashing. (issue 545093002 by jing....@intel.com)

2014-09-05 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Remove dead code for inline string hashing. port r23689. original commit message: Remove dead code for inline string hashing. This has become obsolete since hydrogenized StringAdd. BUG= Please review this at https://codereview.chromium.org/54

[v8-dev] X87: Clean up code stubs and ensure distinct major keys. (issue 543013002 by jing....@intel.com)

2014-09-05 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Clean up code stubs and ensure distinct major keys. port r23655. original commit message: Clean up code stubs and ensure distinct major keys. BUG= Please review this at https://codereview.chromium.org/543013002/ SVN Base: https://github.com/v8/

[v8-dev] X87: CallDescriptors::InitializeForIsolate() is no longer needed. (issue 541353002 by jing....@intel.com)

2014-09-04 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: CallDescriptors::InitializeForIsolate() is no longer needed. port r23652. original commit message: CallDescriptors::InitializeForIsolate() is no longer needed. CallInterfaceDescriptors initialize themselves lazily. Soon we can also tear

[v8-dev] X87: Minor-key-ify remaining code stubs (issue 542043002 by jing....@intel.com)

2014-09-04 Thread jing . bao
Reviewers: Weiliang, Yang, Description: X87: Minor-key-ify remaining code stubs port r23643. original commit message: Minor-key-ify remaining code stubs BUG= Please review this at https://codereview.chromium.org/542043002/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected fi

[v8-dev] X87: enable snapshot (issue 545673003 by jing....@intel.com)

2014-09-04 Thread jing . bao
Reviewers: Weiliang, Description: X87: enable snapshot Tweak LConstantD and LStoreKeyed to avoid fp register spilling BUG= Please review this at https://codereview.chromium.org/545673003/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+4, -12 lines): M src/x87/lithium

[v8-dev] X87: Make concrete classes for individual call descriptors (issue 544943002 by jing....@intel.com)

2014-09-04 Thread jing . bao
Reviewers: Weiliang, mvstanton, Description: X87: Make concrete classes for individual call descriptors port r23639 original commit message: Make concrete classes for individual call descriptors. The ic-convention classes that hold register specifications are merged into these new call

[v8-dev] X87: Unify some PlatformCodeStubs (issue 540763002 by jing....@intel.com)

2014-09-03 Thread jing . bao
Reviewers: Weiliang, Description: X87: Unify some PlatformCodeStubs port r23631. original commit message: Unify some PlatformCodeStubs BUG= Please review this at https://codereview.chromium.org/540763002/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+23, -79 line

[v8-dev] Pass dependency to HLoadNamedField for array length load (issue 267773004)

2014-05-05 Thread jing . bao
Reviewers: Toon Verwaest, Description: Pass dependency to HLoadNamedField for array length load BUG= Please review this at https://codereview.chromium.org/267773004/ SVN Base: https://github.com/v8/v8.git@bleeding_edge Affected files (+1, -1 lines): M src/hydrogen.cc Index: src/hydrogen.c