RE: [virtio-dev] Re: [PATCH v11] virtio-net: support inner header hash

2023-03-20 Thread Parav Pandit
> From: Heng Qi > Sent: Monday, March 20, 2023 11:56 PM > > the same flow? If enough people agree this is needed we can accept this > > but did you at all consider using something programmable like BPF for > > I think the problem is that our virtio device cannot support ebpf, we > can also

[virtio-dev] [PATCH v2 6/7] virtio-net: Avoid duplicate receive queue example

2023-03-20 Thread Parav Pandit
Receive queue number/index example is duplicate which is already defined in the Setting RSS parameters section. Hence, avoid such duplicate example and prepare it for the subsequent patch to describe using receive queue handle. Fixes: https://github.com/oasis-tcs/virtio-spec/issues/163

[virtio-dev] [PATCH v2 2/7] transport-mmio: Rename QueueNum register

2023-03-20 Thread Parav Pandit
Currently specification uses virtqueue index and number interchangeably to refer to the virtqueue. It is better to always refer to it the virtqueue in consistent manner. Two registers QueueNumMax and QueueNum actually reflects the queue size or queue depth indicating max and actual number of

[virtio-dev] [PATCH v2 4/7] transport-ccw: Rename queue depth/size to other transports

2023-03-20 Thread Parav Pandit
max_num field reflects the maximum queue size/depth. Hence align name of this field with similar field in PCI and MMIO transport to max_queue_size. Similarly rename 'num' to 'size'. Fixes: https://github.com/oasis-tcs/virtio-spec/issues/163 Signed-off-by: Parav Pandit --- transport-ccw.tex | 26

[virtio-dev] [PATCH v2 7/7] virtio-net: Describe RSS using receive queue handle

2023-03-20 Thread Parav Pandit
The content of indirection table and unclassified_queue which are based on math calculation historically. To better describe this, to avoid intermixing array index with virtqueue index and to use virtqueue number introduce a field rq_handle (receive queue handle) and refer them to describe

[virtio-dev] [PATCH v2 5/7] transport-ccw: Refer to the vq by its number

2023-03-20 Thread Parav Pandit
Currently specification uses virtqueue index and number interchangeably to refer to the virtqueue. Instead refer to it by its number. Fixes: https://github.com/oasis-tcs/virtio-spec/issues/163 Signed-off-by: Parav Pandit --- changelog: v0->v1: - new patch --- transport-ccw.tex | 15

[virtio-dev] [PATCH v2 1/7] transport-pci: Refer to the vq by its number

2023-03-20 Thread Parav Pandit
Currently specification uses virtqueue index and number interchangeably to refer to the virtqueue. Instead refer to it by its number. This patch is on top of [1]. [1] https://lists.oasis-open.org/archives/virtio-dev/202302/msg00527.html Fixes:

[virtio-dev] [PATCH v2 3/7] transport-mmio: Refer to the vq by its number

2023-03-20 Thread Parav Pandit
Currently specification uses virtqueue index and number interchangeably to refer to the virtqueue. Instead refer to it by its number. Fixes: https://github.com/oasis-tcs/virtio-spec/issues/163 Reviewed-by: Jiri Pirko Signed-off-by: Parav Pandit --- transport-mmio.tex | 14 ++ 1

[virtio-dev] [PATCH v2 0/7] Rename queue index to queue number

2023-03-20 Thread Parav Pandit
1. Currently, virtqueue is identified between driver and device interchangeably using either number of index terminology. 2. Between PCI and MMIO transport the queue size (depth) is defined as queue_size and QueueNum respectively. To avoid confusion and to have consistency, unify them to use as

[virtio-dev] Re: [PATCH v11] virtio-net: support inner header hash

2023-03-20 Thread Jason Wang
On Tue, Mar 21, 2023 at 3:43 AM Michael S. Tsirkin wrote: > > On Mon, Mar 20, 2023 at 07:18:40PM +0800, Heng Qi wrote: > > 1. Currently, a received encapsulated packet has an outer and an inner > > header, but > > the virtio device is unable to calculate the hash for the inner header. > >

[virtio-dev] Re: [PATCH v11] virtio-net: support inner header hash

2023-03-20 Thread Michael S. Tsirkin
On Mon, Mar 20, 2023 at 03:43:51PM -0400, Michael S. Tsirkin wrote: > On Mon, Mar 20, 2023 at 07:18:40PM +0800, Heng Qi wrote: > > 1. Currently, a received encapsulated packet has an outer and an inner > > header, but > > the virtio device is unable to calculate the hash for the inner header. >

[virtio-dev] Re: [virtio-comment] Re: [virtio-dev] Re: [virtio-comment] Re: [virtio-dev] Re: [PATCH v9] virtio-net: support inner header hash

2023-03-20 Thread Michael S. Tsirkin
On Wed, Mar 15, 2023 at 08:55:45PM +0800, Heng Qi wrote: > We use the most basic GRE header fields (not NVGRE), not even optional > fields. I'd say yes, the most convincing usecase is with legacy GRE. Given that, do you need the rest of protocols there? We can start with just legacy GRE (think

[virtio-dev] Re: [virtio-comment] Re: [virtio-dev] Re: [virtio-comment] Re: [virtio-dev] Re: [PATCH v9] virtio-net: support inner header hash

2023-03-20 Thread Michael S. Tsirkin
On Thu, Mar 16, 2023 at 09:17:26PM +0800, Heng Qi wrote: > On Wed, Mar 15, 2023 at 10:57:40AM -0400, Michael S. Tsirkin wrote: > > On Wed, Mar 15, 2023 at 08:55:45PM +0800, Heng Qi wrote: > > > > > > > > > 在 2023/3/15 下午7:58, Michael S. Tsirkin 写道: > > > > On Sat, Mar 11, 2023 at 11:23:08AM

[virtio-dev] Re: [PATCH v11] virtio-net: support inner header hash

2023-03-20 Thread Michael S. Tsirkin
On Mon, Mar 20, 2023 at 07:18:40PM +0800, Heng Qi wrote: > 1. Currently, a received encapsulated packet has an outer and an inner > header, but > the virtio device is unable to calculate the hash for the inner header. > Multiple > flows with the same outer header but different inner headers are

[virtio-dev] Re: [virtio-comment] [PATCH v12] virtio-net: support the virtqueue coalescing moderation

2023-03-20 Thread Michael S. Tsirkin
On Mon, Mar 20, 2023 at 05:35:38PM +0100, Cornelia Huck wrote: > On Sun, Mar 12 2023, Heng Qi wrote: > > > Currently, coalescing parameters are grouped for all transmit and receive > > virtqueues. This patch supports setting or getting the parameters for a > > specified virtqueue, and a typical

[virtio-dev] Re: [virtio-comment] [PATCH v12] virtio-net: support the virtqueue coalescing moderation

2023-03-20 Thread Cornelia Huck
On Sun, Mar 12 2023, Heng Qi wrote: > Currently, coalescing parameters are grouped for all transmit and receive > virtqueues. This patch supports setting or getting the parameters for a > specified virtqueue, and a typical application of this function is netdim[1]. > > When the traffic between