Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > Thanks. A replacement would suit. > Subject: Allow paravirt backend to choose kernel PMD sharing Normally when running in PAE mode, the 4th PMD maps the kernel address space, which can be shared among all processes (since they all need the same kernel mappings). Xen, ho

Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Andrew Morton
On Fri, 06 Apr 2007 17:40:13 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > Andrew Morton wrote: > > Something like that. I don't want to redo my patch if we're going to change > > your patch ;) > > > > OK. I won't specifically redo it on top of your patches, but I'll > rework it to

Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > Something like that. I don't want to redo my patch if we're going to change > your patch ;) > OK. I won't specifically redo it on top of your patches, but I'll rework it to remove the inline function and add the if() statement. Do you want an incremental update or a co

Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Andrew Morton
On Fri, 06 Apr 2007 17:02:58 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > Andrew Morton wrote: > > All this paravirt stuff isn't making the kernel any prettier, is it? > > > > You're too kind. wli's comment on the first version of this patch was > something along the lines of "this

Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > All this paravirt stuff isn't making the kernel any prettier, is it? > You're too kind. wli's comment on the first version of this patch was something along the lines of "this patch causes a surprising amount of damage for what little it achieves". >> ... >> >> -#ifnd

Re: [patch 18/20] clean up tsc-based sched_clock

2007-04-06 Thread Andrew Morton
On Fri, 06 Apr 2007 16:27:20 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > > I still need to work out why that hang is happening - it is very > > mysterious. I got as far as working out that it was hanging on > > write_seqlock_irqsave(xtime_lock), then remembered that it's with > > CONF

Re: [patch 18/20] clean up tsc-based sched_clock

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > On Wed, 04 Apr 2007 12:12:09 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> > wrote: > > >> Three cleanups: >> - change "instable" -> "unstable" >> - its better to use get_cpu_var for getting this cpu's variables >> - change cycles_2_ns to do the full computation rather

Re: [patch 07/20] Allow paravirt backend to choose kernel PMD sharing

2007-04-06 Thread Andrew Morton
On Wed, 04 Apr 2007 12:11:58 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > Normally when running in PAE mode, the 4th PMD maps the kernel address > space, which can be shared among all processes (since they all need > the same kernel mappings). > > Xen, however, does not allow guests to

Re: [patch 18/20] clean up tsc-based sched_clock

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > On Wed, 04 Apr 2007 12:12:09 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> > wrote: > > >> Three cleanups: >> - change "instable" -> "unstable" >> - its better to use get_cpu_var for getting this cpu's variables >> - change cycles_2_ns to do the full computation rather

Re: [patch 09/20] rename struct paravirt_patch to paravirt_patch_site for clarity

2007-04-06 Thread Jeremy Fitzhardinge
Andrew Morton wrote: > Needed a bit of updating for Andi's recently-merged > x86_64-mm-vmi-backend-for-paravirt-ops.patch but I think I got it > right. We'll see if it compiles. > Yeah, it's just a simple name change, so it will either compile or not. J ___

Re: [patch 18/20] clean up tsc-based sched_clock

2007-04-06 Thread Andrew Morton
On Wed, 04 Apr 2007 12:12:09 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > Three cleanups: > - change "instable" -> "unstable" > - its better to use get_cpu_var for getting this cpu's variables > - change cycles_2_ns to do the full computation rather than just the >tsc->ns scaling

Re: [patch 09/20] rename struct paravirt_patch to paravirt_patch_site for clarity

2007-04-06 Thread Andrew Morton
On Wed, 04 Apr 2007 12:12:00 -0700 Jeremy Fitzhardinge <[EMAIL PROTECTED]> wrote: > Rename struct paravirt_patch to paravirt_patch_site, so that it > clearly refers to a callsite, and not the patch which may be applied > to that callsite. Needed a bit of updating for Andi's recently-merged x86_6

[patch 1/4] Clean up asm-i386/bugs.h

2007-04-06 Thread Jeremy Fitzhardinge
Most of asm-i386/bugs.h is code which should be in a C file, so put it there. Signed-off-by: Jeremy Fitzhardinge <[EMAIL PROTECTED]> Cc: Linus Torvalds <[EMAIL PROTECTED]> --- arch/i386/kernel/cpu/Makefile |2 arch/i386/kernel/cpu/bugs.c| 191 +++ i

[patch 3/4] Relocate VDSO ELF headers to match mapped location with COMPAT_VDSO

2007-04-06 Thread Jeremy Fitzhardinge
Some versions of libc can't deal with a VDSO which doesn't have its ELF headers matching its mapped address. COMPAT_VDSO maps the VDSO at a specific system-wide fixed address. Previously this was all done at build time, on the grounds that the fixed VDSO address is always at the top of the addres

[patch 2/4] clean up identify_cpu

2007-04-06 Thread Jeremy Fitzhardinge
identify_cpu() is used to identify both the boot CPU and secondary CPUs, but it performs some actions which only apply to the boot CPU. Those functions are therefore really __init functions, but because they're called by identify_cpu(), they must be marked __cpuinit. This patch splits identify_cpu

[patch 4/4] Make COMPAT_VDSO runtime selectable.

2007-04-06 Thread Jeremy Fitzhardinge
Now that relocation of the VDSO for COMPAT_VDSO users is done at runtime rather than compile time, it is possible to enable/disable compat mode at runtime. This patch allows you to enable COMPAT_VDSO mode with "vdso=2" on the kernel command line, or via sysctl. (Switching on a running system shou

[patch 0/4] Clean up asm/bugs.h, identify_cpu() and update COMPAT_VDSO

2007-04-06 Thread Jeremy Fitzhardinge
Hi Andi, Four patches: - clean up asm/bugs.h, by moving all the C code into its own C file - split identify_cpu() into boot and secondary variants, so that boot-time setup functions can be marked __init - repost of the COMPAT_VDSO patches with a bit more robustness from unknown DT_tags, a

Re: [PATCH] Define EFLAGS_IF

2007-04-06 Thread H. Peter Anvin
Andi Kleen wrote: > On Thu, Apr 05, 2007 at 06:06:16PM -0700, H. Peter Anvin wrote: >> Andi Kleen wrote: >>> No processor.h is such a hodgepodge of unrelated stuff that any >>> splitting up is a good thing. >>> >> Fair enough. However, I'd still like to see the X86_CR* constants >> moved, too (an

Re: [PATCH] Define EFLAGS_IF

2007-04-06 Thread Andi Kleen
On Thu, Apr 05, 2007 at 06:06:16PM -0700, H. Peter Anvin wrote: > Andi Kleen wrote: > > > >No processor.h is such a hodgepodge of unrelated stuff that any > >splitting up is a good thing. > > > > Fair enough. However, I'd still like to see the X86_CR* constants > moved, too (and constants added