[PATCH] xen: Make xen-blkfront write its protocol ABI to xenstore

2007-12-06 Thread Markus Armbruster
Frontends are expected to write their protocol ABI to xenstore. Since the protocol ABI defaults to the backend's native ABI, things work fine without that as long as the frontend's native ABI is identical to the backend's native ABI. This is not the case for xen-blkfront running 32-on-64,

[PATCH] virtnet: remove double ether_setup

2007-12-06 Thread Christian Borntraeger
Hello Rusty, virtnet_probe already calls alloc_etherdev, which calls ether_setup. There is no need to do that again. Signed-off-by: Christian Borntraeger [EMAIL PROTECTED] --- drivers/net/virtio_net.c |1 - 1 file changed, 1 deletion(-) Index: kvm/drivers/net/virtio_net.c

Re: [Xen-devel] Re: Next steps with pv_ops for Xen

2007-12-06 Thread Gerd Hoffmann
D.G. Murray wrote: Hi Mark, Maybe a change to the gntdev userspace API to allow batching of mapping requests? Something along the lines of the following? void *xc_gnttab_map_grant_refs(int xcg_handle, uint32_t count,

Re: [Xen-devel] Re: Next steps with pv_ops for Xen

2007-12-06 Thread Derek Murray
Gerd Hoffmann wrote: Yes, except that it should actually work ;) It doesn't for me (Fedora 8 again). Grab xenner 0.9 (just uploaded), edit blkbackd.c and flip the BATCH_MAPS from 0 to 1, compile, run, see it not work. Which version of the Xen tools are you using? There was a bug in the

[PATCH] virtio_net: Fix stalled inbound traffic on early packets

2007-12-06 Thread Christian Borntraeger
The current virtio_net driver has a startup race, which prevents any incoming traffic: If try_fill_recv submits buffers to the host system data might be filled in and an interrupt is sent, before napi_enable finishes. In that case the interrupt will kick skb_recv_done which will then call

[PATCH 3/19] change gdt acessor macro name

2007-12-06 Thread Glauber de Oliveira Costa
This patch changes the name of x86_64 macro used to access the per-cpu gdt. It is now equal to the i386 version, which will allow code to be shared. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/setup64.c |2 +- arch/x86/kernel/suspend_64.c |2 +-

[PATCH 1/19] unify desc_struct

2007-12-06 Thread Glauber de Oliveira Costa
This patch aims to make the access of struct desc_struct variables equal across architectures. In this patch, I unify the i386 and x86_64 versions under an anonymous union, keeping the way they are accessed untouched (a and b for 32-bit code, individual bit-fields for 64-bit). This solution is

[PATCH 0/19] desc_struct integration

2007-12-06 Thread Glauber de Oliveira Costa
Hi, this is a series of patches that unify the struct desc_struct and friends across x86_64 and i386. As usual, it provides paravirt capabilities as a side-effect for x86_64. I consider the main goal, namely, of unifying the desc_struct, an ongoing effort, being this the beginning. A lot of old

[PATCH 4/19] removed unused variable

2007-12-06 Thread Glauber de Oliveira Costa
This variable is not used anywere, and is then removed Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- include/asm-x86/desc_64.h |5 - 1 files changed, 0 insertions(+), 5 deletions(-) diff --git a/include/asm-x86/desc_64.h b/include/asm-x86/desc_64.h index

[PATCH 6/19] change write_idt_entry signature

2007-12-06 Thread Glauber de Oliveira Costa
this patch changes write_idt_entry signature. It now takes a gate_desc instead of the a and b parameters. It will allow it to be later unified between i386 and x86_64. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/paravirt_32.c |2 +- arch/x86/xen/enlighten.c

[PATCH 5/19] introduce gate_desc type.

2007-12-06 Thread Glauber de Oliveira Costa
To account for the differences in gate descriptor in i386 and x86_64 a gate_desc type is introduced. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/traps_32.c |3 ++- include/asm-x86/desc_32.h | 15 --- include/asm-x86/desc_64.h |4 ++--

[PATCH 2/19] unify struct desc_ptr

2007-12-06 Thread Glauber de Oliveira Costa
This patch unifies struct desc_ptr between i386 and x86_64. They can be expressed in the exact same way in C code, only having to change the name of one of them. As Xgt_desc_struct is ugly and big, this is the one that goes away. There's also a padding field in i386, but it is not really needed

[PATCH 7/19] introduce ldt_desc type.

2007-12-06 Thread Glauber de Oliveira Costa
this patch introduces ldt_desc type to account for the differences in the ldt descriptor in x86_64 and i386 Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- include/asm-x86/desc_64.h |2 +- include/asm-x86/desc_defs.h |4 +++- 2 files changed, 4 insertions(+), 2

[PATCH 8/19] modify write_ldt function

2007-12-06 Thread Glauber de Oliveira Costa
This patch modifies the write_ldt() function to make use of the new struct desc_struct instead of entry_1 and entry_2 entries Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/ldt.c | 15 +++ 1 files changed, 7 insertions(+), 8 deletions(-) diff --git

[PATCH 11/19] change write_ldt_entry signature

2007-12-06 Thread Glauber de Oliveira Costa
this patch changes the signature of write_ldt_entry. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/ldt.c |3 +-- arch/x86/xen/enlighten.c |4 ++-- include/asm-x86/desc_32.h |9 - include/asm-x86/desc_64.h |7 ++-

[PATCH 16/19] provide tss_desc

2007-12-06 Thread Glauber de Oliveira Costa
Provide a new type, tss_desc, to represent the tss descriptor in a unified way accross x86_64 and i386 Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- include/asm-x86/desc_defs.h |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/include/asm-x86/desc_defs.h

[PATCH 13/19] unify non-paravirt parts of desc.h

2007-12-06 Thread Glauber de Oliveira Costa
This patch unifies the non-paravirt part of desc_{32,64}.h into desc.h. Most of it, is simply common code, that is moved to the shared header. The only exception is the set_ldt_desc in desc_64.h, which is changed - included its name - to accomodate for the way the ldt is set up in i386. Also,

[PATCH 12/19] move constants to desc_defs.h

2007-12-06 Thread Glauber de Oliveira Costa
this patch moves constant definitions regarding descriptor types from desc_32.h to desc_defs.h. The change from defines to enum to comply with previous versions in desc_defs.h Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- include/asm-x86/desc_32.h |8

[PATCH 18/19] move _set_gate and its users to a common location

2007-12-06 Thread Glauber de Oliveira Costa
This patch moves _set_gate and its users to desc.h. We can now use common code for x86_64 and i386. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- arch/x86/kernel/traps_32.c | 34 include/asm-x86/desc.h | 88 +++

[PATCH 17/19] unify paravirt pieces of descriptor handling

2007-12-06 Thread Glauber de Oliveira Costa
With the types used to access descriptors in x86_64 and i386 now being the same, the code that effectively handles them can now be easily shared. This patch moves the paravirt part of desc_32.h into desc.h, and then, we get paravirt support in x86_64 for free. Signed-off-by: Glauber de Oliveira

[PATCH 19/19] unify set_tss_desc

2007-12-06 Thread Glauber de Oliveira Costa
This patch unifies the set_tss_desc between i386 and x86_64, which can now have a common implementation. After the old functions are removed from desc_{32,64}.h, nothing important is left, and the files can be removed. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] ---

[PATCH 14/19] use the same data type for tls_array.

2007-12-06 Thread Glauber de Oliveira Costa
This patch changes the type of tls_array in x86_64 to a desc_struct. Now, both i386 and x86_64 tls_array have the same type, and code accessing it can be shared. Signed-off-by: Glauber de Oliveira Costa [EMAIL PROTECTED] --- include/asm-x86/desc_64.h |2 +-

[PATCH 10/19] change write_gdt_entry signature.

2007-12-06 Thread Glauber de Oliveira Costa
This patch changes the write_gdt_entry function signature. Instead of the old a and b parameters, it now receives a pointer to a desc_struct, and the size of the entry being handled. This is because x86_64 can have some 16-byte entries as well as 8-byte ones. Signed-off-by: Glauber de Oliveira

Re: [PATCH 1/19] unify desc_struct

2007-12-06 Thread Glauber de Oliveira Costa
On Dec 6, 2007 5:24 PM, Jeremy Fitzhardinge [EMAIL PROTECTED] wrote: Glauber de Oliveira Costa wrote: This patch aims to make the access of struct desc_struct variables equal across architectures. In this patch, I unify the i386 and x86_64 versions under an anonymous union, keeping the way

Re: [Xen-devel] Re: Next steps with pv_ops for Xen

2007-12-06 Thread Jeremy Fitzhardinge
Derek Murray wrote: Keir Fraser wrote: You'd need to track pte-grant_handle mappings somewhere, but it could certainly be done this way, yes. At the moment, blktap and gntdev provide struct pages to get_user_pages by smuggling them in the vm_private_data field of the relevant